aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-01 02:37:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-01 02:37:50 +0200
commit814d57cc3419d18e76d32b22f1e042e1dbb304d0 (patch)
tree7ff16fbaff2b56dc9a0bcfad0a94340446010d6c /community
parentbedd1a23bfbef1bcebb50e4b4f5204c7beabd66e (diff)
downloadaports-814d57cc3419d18e76d32b22f1e042e1dbb304d0.tar.bz2
aports-814d57cc3419d18e76d32b22f1e042e1dbb304d0.tar.xz
community/ruby2.1: remove, security support by upstream has ended
https://www.ruby-lang.org/en/news/2017/04/01/support-of-ruby-2-1-has-ended/
Diffstat (limited to 'community')
-rw-r--r--community/ruby2.1/APKBUILD183
-rw-r--r--community/ruby2.1/libressl.patch40
2 files changed, 0 insertions, 223 deletions
diff --git a/community/ruby2.1/APKBUILD b/community/ruby2.1/APKBUILD
deleted file mode 100644
index 6130172ca6..0000000000
--- a/community/ruby2.1/APKBUILD
+++ /dev/null
@@ -1,183 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=ruby2.1
-_pkgname=ruby
-_majorver=${pkgname#ruby}
-pkgver="$_majorver.10"
-_pkgver=${pkgver/_/-}
-_abiver="$_majorver.0"
-pkgrel=2
-pkgdesc="An object-oriented language for quick and easy programming"
-url="http://www.ruby-lang.org/en/"
-arch="all"
-license="Ruby"
-depends=""
-makedepends="zlib-dev libressl-dev gdbm-dev db-dev readline-dev
- libffi-dev coreutils yaml-dev autoconf"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-irb::noarch
- $pkgname-rdoc::noarch $pkgname-rake::noarch $pkgname-bigdecimal::noarch
- $pkgname-io-console:io_console $pkgname-minitest::noarch
- $pkgname-json $pkgname-libs
- "
-source="ftp://ftp.ruby-lang.org/pub/ruby/${pkgver%.*}/$_pkgname-$_pkgver.tar.bz2
- libressl.patch"
-options="!fhs"
-builddir="$srcdir/$_pkgname-$_pkgver"
-
-_gemdir="/usr/lib/ruby/gems/$_abiver"
-_rubydir="/usr/lib/ruby/$_abiver"
-_chost="${CHOST/-alpine-/-}"
-
-case "$CARCH" in
- x86) _arch="i386";;
- *) _arch="$CARCH";;
-esac
-
-prepare() {
- default_prepare || return 1
-
- cd "$builddir"
- autoconf
-}
-
-build() {
- cd "$builddir"
-
- # -fomit-frame-pointer makes ruby segfault, see gentoo bug #150413
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- export CFLAGS="$CFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
- export CPPFLAGS="$CPPFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
-
- # ruby saves path to install. we want use $PATH
- export INSTALL=install
-
- # the configure script does not detect isnan/isinf as macros
- export ac_cv_func_isnan=yes
- export ac_cv_func_isinf=yes
-
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --with-sitedir='/usr/local/lib/site_ruby' \
- --with-search-path="/usr/lib/site_ruby/\$(ruby_ver)/$_arch-linux" \
- --enable-pthread \
- --disable-rpath \
- --enable-shared \
- --with-mantype=man \
- --program-suffix=$_majorver \
- --with-soname=$pkgname \
- || return 1
- make || return 1
- make test
-}
-
-package() {
- cd "$builddir"
-
- make DESTDIR="$pkgdir" install || return 1
-
- if [ -d "$pkgdir"/usr/local ]; then
- local f=$(cd "$pkgdir" ; find usr/local -type f)
- if [ -n "$f" ]; then
- error "Found files in /usr/local:"
- echo "$f"
- return 1
- fi
- fi
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
-}
-
-rake() {
- pkgdesc="Ruby based make-like utility"
- depends="$pkgname"
-
- _mvgem rake || return 1
- _mv usr/bin/rake$_majorver
-}
-
-irb() {
- pkgdesc="The Interactive Ruby"
- replaces="$pkgname"
- depends="$pkgname"
-
- cd "$pkgdir"
- _mv usr/bin/irb$_majorver \
- usr/lib/ruby/$_abiver/irb*
-}
-
-rdoc() {
- pkgdesc="Ruby documentation tool"
- depends="$pkgname $pkgname-json"
-
- _mvgem rdoc || return 1
- _mv usr/bin/ri$_majorver \
- usr/bin/rdoc$_majorver
-}
-
-bigdecimal() {
- pkgdesc="Ruby arbitrary-precision floating point decimal arithmetic"
- depends="$pkgname"
-
- _mvgem bigdecimal
-}
-
-io_console() {
- pkgdesc="Ruby simple console IO library"
- depends="$pkgname"
-
- _mvgem io-console
- _mv $_rubydir/io \
- $_rubydir/$_chost/io/console.so
-}
-
-minitest() {
- pkgdesc="Ruby suite of testing facilities"
- depends="$pkgname"
-
- _mvgem minitest
-}
-
-json() {
- pkgdesc="JSON implementation as a Ruby extension in C"
- depends="$pkgname"
-
- _mvgem json
-}
-
-libs() {
- pkgdesc="Libraries necessary to run Ruby"
- depends=""
-
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
-}
-
-_mv() {
- local i; for i in "$@"; do
- mkdir -p "$subpkgdir"/${i%/*}
- mv "$pkgdir"/${i} "$subpkgdir"/${i%/*}/ || return 1
- done
-}
-
-_mvgem() {
- cd "$pkgdir"
- local path; for path in ./$_rubydir/${1}.rb \
- ./$_rubydir/${1} \
- ./$_rubydir/$_chost/${1} \
- ./$_gemdir/gems/${1}-* \
- ./$_gemdir/specifications/default/${1}-* ; do
- [ -e "$pkgdir/$path" ] && _mv "$path"
- done
-}
-
-md5sums="5155c624807ff2418a9e9f15202954d0 ruby-2.1.10.tar.bz2
-cc59ea987caa211a8f664fc58c94e0c2 libressl.patch"
-sha256sums="a74675578a9a801ac25eb7152bef3023432d6267f875b198eb9cd6944a5bf4f1 ruby-2.1.10.tar.bz2
-a8b740102616c1041331cd7c5eb56ecf64a253ccd02fc31ca4a3bcf76cf499e5 libressl.patch"
-sha512sums="4b7213695416876e4de3cbce912f61ac89db052c74f0daa8424477991cfc49b07300e960177ff576b634a97ee8afef3c5aded5d5806329dbd01d0ce7b42b9b63 ruby-2.1.10.tar.bz2
-183601253b23c29246a4901d2fb939df07be64320ffafc282191f9d2ddfeff7ab621c69debd59fcde7df038bac1ccc1aecb5da9cc8e6da50cf29b087e6264ba7 libressl.patch"
diff --git a/community/ruby2.1/libressl.patch b/community/ruby2.1/libressl.patch
deleted file mode 100644
index 43e7fc42ec..0000000000
--- a/community/ruby2.1/libressl.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Source: https://github.com/gentoo/libressl/blob/776060f4bc3418dbba6be5aec1a76cd2ec84476e/dev-lang/ruby/files/ruby-conditional-randegd.patch
---- a/ext/openssl/extconf.rb
-+++ b/ext/openssl/extconf.rb
-@@ -87,6 +87,7 @@
- have_func("PEM_def_callback")
- have_func("PKCS5_PBKDF2_HMAC")
- have_func("PKCS5_PBKDF2_HMAC_SHA1")
-+have_func("RAND_egd")
- have_func("X509V3_set_nconf")
- have_func("X509V3_EXT_nconf_nid")
- have_func("X509_CRL_add0_revoked")
---- a/ext/openssl/ossl_rand.c
-+++ b/ext/openssl/ossl_rand.c
-@@ -125,6 +125,7 @@
- return str;
- }
-
-+#ifdef HAVE_RAND_EGD
- /*
- * call-seq:
- * egd(filename) -> true
-@@ -158,6 +159,7 @@
- }
- return Qtrue;
- }
-+#endif /* HAVE_RAND_EGD */
-
- /*
- * call-seq:
-@@ -195,8 +197,10 @@
- DEFMETH(mRandom, "write_random_file", ossl_rand_write_file, 1);
- DEFMETH(mRandom, "random_bytes", ossl_rand_bytes, 1);
- DEFMETH(mRandom, "pseudo_bytes", ossl_rand_pseudo_bytes, 1);
-+#ifdef HAVE_RAND_EGD
- DEFMETH(mRandom, "egd", ossl_rand_egd, 1);
- DEFMETH(mRandom, "egd_bytes", ossl_rand_egd_bytes, 2);
-+#endif /* HAVE_RAND_EGD */
- DEFMETH(mRandom, "status?", ossl_rand_status, 0)
- }
-