aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-04-02 06:00:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-02 06:05:51 +0000
commit973d2613fefed6f710e7c9c3a2881bf2a157185b (patch)
tree7b3828b60139ccaf8fc9136aa0fc81eb47f4f7bd /community
parentcc4b41b0b3b77d5d8fe09b40670968d1a2307a43 (diff)
downloadaports-973d2613fefed6f710e7c9c3a2881bf2a157185b.tar.bz2
aports-973d2613fefed6f710e7c9c3a2881bf2a157185b.tar.xz
community/wireguard-lts: upgrade to 1.0.20200330 and kernel 5.4.29
Diffstat (limited to 'community')
-rw-r--r--community/wireguard-lts/APKBUILD11
-rw-r--r--community/wireguard-lts/hack-5.4.29.patch20
2 files changed, 27 insertions, 4 deletions
diff --git a/community/wireguard-lts/APKBUILD b/community/wireguard-lts/APKBUILD
index 0b062787ad..edde151aa4 100644
--- a/community/wireguard-lts/APKBUILD
+++ b/community/wireguard-lts/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
# wireguard version
-_ver=0.0.20200215
+_ver=1.0.20200330
_rel=0
# kernel version
-_kver=5.4.28
+_kver=5.4.29
_krel=0
_kpkgver="$_kver-r$_krel"
@@ -39,7 +39,9 @@ makedepends="
"
install_if="wireguard-tools-wg linux-$_flavor=$_kpkgver"
options="!check"
-source="https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-$_ver.tar.xz"
+source="https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-$_ver.tar.xz
+ hack-5.4.29.patch
+ "
builddir="$srcdir"/wireguard-linux-compat-$_ver
for f in $_extra_flavors; do
@@ -88,4 +90,5 @@ _extra() {
"$subpkgdir/lib/modules/$kabi/extra/wireguard.ko"
}
-sha512sums="4ccb902fc322010dc7138b17c3348870e8e83e3ed65f4b49476847b544c6e9d7cbaaadc1f02ffb97453f16802f623bf6b8782122236ced23255d46d88ebe239c wireguard-linux-compat-0.0.20200215.tar.xz"
+sha512sums="b133f530f9e7a38b837c119fb5defa3af702cdcf2407f847a078a94a92598216074e7bbd26d27c86a998a79480ba10a99825debf20aff94de80a943892fa856b wireguard-linux-compat-1.0.20200330.tar.xz
+927825a584b5e8cbe5e3a17c3b29c2c06f8a9444a32dccfb3a24d21c0486d598a30456f7e132c5b83d98c9e018b6e682f29915e90bfa96c115831e1785565f1c hack-5.4.29.patch"
diff --git a/community/wireguard-lts/hack-5.4.29.patch b/community/wireguard-lts/hack-5.4.29.patch
new file mode 100644
index 0000000000..255b8847d6
--- /dev/null
+++ b/community/wireguard-lts/hack-5.4.29.patch
@@ -0,0 +1,20 @@
+diff --git a/src/compat/compat.h b/src/compat/compat.h
+index fe2d07e..7f23283 100644
+--- a/src/compat/compat.h
++++ b/src/compat/compat.h
+@@ -1024,15 +1024,6 @@ out:
+ #define COMPAT_CANNOT_USE_MAX_MTU
+ #endif
+
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 6, 0)
+-#include <linux/skbuff.h>
+-static inline void skb_reset_redirect(struct sk_buff *skb)
+-{
+-#ifdef CONFIG_NET_SCHED
+- skb_reset_tc(skb);
+-#endif
+-}
+-#endif
+
+ #if defined(ISUBUNTU1604)
+ #include <linux/siphash.h>