aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorOliver Smith <ollieparanoid@bitmessage.ch>2018-09-20 06:57:20 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-09-24 10:19:24 +0300
commit9d9f981a2c421f44db3ae66b90293202748eb9f3 (patch)
tree8790d020333778e4441e1160ef2b17fb6d8e7a0d /community
parent993843fcca32a014f8c0aa87195c4dbed36fdb16 (diff)
downloadaports-9d9f981a2c421f44db3ae66b90293202748eb9f3.tar.bz2
aports-9d9f981a2c421f44db3ae66b90293202748eb9f3.tar.xz
aports: add support for armv7 [skip ci]
This makes it possible to provide armv7 as additional architecture in Alpine, next to armhf. See the discussion in this ML thread: <https://lists.alpinelinux.org/alpine-devel/6271.html> It's done by adding armv7 next to armhf in the arch line and also !armv7 where the arch line said !armhf. The following script was used:
Diffstat (limited to 'community')
-rw-r--r--community/bitcoin/APKBUILD2
-rw-r--r--community/chromium/APKBUILD2
-rw-r--r--community/domoticz/APKBUILD2
-rw-r--r--community/drawterm/APKBUILD2
-rw-r--r--community/dune/APKBUILD2
-rw-r--r--community/gst-ffmpeg0.10/APKBUILD2
-rw-r--r--community/icinga2/APKBUILD2
-rw-r--r--community/icingaweb2-module-director/APKBUILD2
-rw-r--r--community/icingaweb2/APKBUILD2
-rw-r--r--community/john/APKBUILD2
-rw-r--r--community/mruby/APKBUILD2
-rw-r--r--community/nnn/APKBUILD2
-rw-r--r--community/ocaml-camlp4/APKBUILD2
-rw-r--r--community/ocaml-findlib/APKBUILD2
-rw-r--r--community/ocaml-lablgtk/APKBUILD2
-rw-r--r--community/ocaml/APKBUILD2
-rw-r--r--community/ocamlbuild/APKBUILD2
-rw-r--r--community/omxplayer/APKBUILD2
-rw-r--r--community/opam/APKBUILD2
-rw-r--r--community/py-gpiozero/APKBUILD2
-rw-r--r--community/py-rpigpio/APKBUILD2
-rw-r--r--community/py-sensehat/APKBUILD2
-rw-r--r--community/rspamd/APKBUILD2
-rw-r--r--community/shotwell/APKBUILD2
-rw-r--r--community/syncthing/APKBUILD2
-rw-r--r--community/terraform/APKBUILD2
-rw-r--r--community/tinc-pre/APKBUILD2
-rw-r--r--community/unison/APKBUILD2
-rw-r--r--community/unit/APKBUILD2
-rw-r--r--community/wiringpi/APKBUILD2
-rw-r--r--community/xpra/APKBUILD2
-rw-r--r--community/zstd/APKBUILD2
32 files changed, 32 insertions, 32 deletions
diff --git a/community/bitcoin/APKBUILD b/community/bitcoin/APKBUILD
index 90be2be521..ae6e4c25b8 100644
--- a/community/bitcoin/APKBUILD
+++ b/community/bitcoin/APKBUILD
@@ -6,7 +6,7 @@ _ver=${pkgver/_/}
pkgrel=5
pkgdesc="Decentralized P2P electronic cash system"
url="https://www.bitcoin.org"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="MIT"
makedepends="autoconf automake libtool boost-dev libressl-dev db-dev miniupnpc-dev
qt5-qtbase-dev qt5-qttools-dev protobuf-dev libqrencode-dev libevent-dev chrpath"
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 12850e1813..925ad98cac 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -5,7 +5,7 @@ pkgver=68.0.3440.106
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
-arch="x86_64 aarch64 armhf"
+arch="x86_64 aarch64 armhf armv7"
license="BSD"
depends="xdg-utils"
depends_dev=""
diff --git a/community/domoticz/APKBUILD b/community/domoticz/APKBUILD
index 7b40e6288b..e9c2d608f3 100644
--- a/community/domoticz/APKBUILD
+++ b/community/domoticz/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.8153
pkgrel=2
pkgdesc="Open source Home Automation System"
url="http://www.domoticz.com/"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="GPL"
pkgusers="$pkgname"
pkggroups="$pkgname"
diff --git a/community/drawterm/APKBUILD b/community/drawterm/APKBUILD
index d18f3b0f68..f06a132b54 100644
--- a/community/drawterm/APKBUILD
+++ b/community/drawterm/APKBUILD
@@ -5,7 +5,7 @@ pkgver=20170119
pkgrel=2
pkgdesc="Connect to Plan 9 CPU servers from other operating systems"
url="http://drawterm.9front.org/"
-arch="all !armhf !aarch64 !s390x"
+arch="all !armhf !armv7 !aarch64 !s390x"
license="custom"
depends=""
options="!check"
diff --git a/community/dune/APKBUILD b/community/dune/APKBUILD
index f807d0b657..895855d879 100644
--- a/community/dune/APKBUILD
+++ b/community/dune/APKBUILD
@@ -7,7 +7,7 @@ _pkgver=1.0+beta20
pkgrel=0
pkgdesc="A composable build system for OCaml (formerly Jbuilder)"
url="https://github.com/ocaml/dune"
-arch="all !x86 !armhf !s390x" # limited by ocaml abuild
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml abuild
license="Apache-2.0"
checkdepends="bash"
makedepends="ocaml ocaml-findlib-dev"
diff --git a/community/gst-ffmpeg0.10/APKBUILD b/community/gst-ffmpeg0.10/APKBUILD
index d8a90c8f8c..d589ac466b 100644
--- a/community/gst-ffmpeg0.10/APKBUILD
+++ b/community/gst-ffmpeg0.10/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.10.13
pkgrel=2
pkgdesc="Gstreamer FFMpeg Plugin"
url="http://www.gstreamer.net"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="GPL"
makedepends="gstreamer0.10-dev gst-plugins-base0.10-dev orc-dev coreutils
orc-dev"
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 70f4fb4b6a..10545d3963 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.9.1
pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="GPL"
depends="monitoring-plugins"
makedepends="$depends_dev cmake bison flex boost-dev yajl-dev
diff --git a/community/icingaweb2-module-director/APKBUILD b/community/icingaweb2-module-director/APKBUILD
index b5a3059cfb..6a07dc8b62 100644
--- a/community/icingaweb2-module-director/APKBUILD
+++ b/community/icingaweb2-module-director/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.4.3
pkgrel=1
pkgdesc="Configuration frontend for Icinga 2, integrated automation"
url="http://www.icinga.org"
-arch="noarch !armhf"
+arch="noarch !armhf !armv7"
license="GPL-2.0"
_php=php7
depends="icingaweb2 ${_php}-curl"
diff --git a/community/icingaweb2/APKBUILD b/community/icingaweb2/APKBUILD
index 6361c981f9..769023e5f0 100644
--- a/community/icingaweb2/APKBUILD
+++ b/community/icingaweb2/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.6.1
pkgrel=0
pkgdesc="Web Interface for Icinga2"
url="http://www.icinga.org"
-arch="noarch !armhf"
+arch="noarch !armhf !armv7"
license="GPL"
_php=php7
depends="icinga2 $_php ${_php}-gd ${_php}-ldap ${_php}-intl ${_php}-pgsql
diff --git a/community/john/APKBUILD b/community/john/APKBUILD
index 9467b526da..c92dbcae88 100644
--- a/community/john/APKBUILD
+++ b/community/john/APKBUILD
@@ -7,7 +7,7 @@ _pkgrel=jumbo-1
pkgrel=10
pkgdesc="John the Ripper password cracker"
url="http://www.openwall.com/john"
-arch="x86_64 armhf ppc64le"
+arch="x86_64 armhf armv7 ppc64le"
license="GPL-2.0"
depends="nss"
options="!strip"
diff --git a/community/mruby/APKBUILD b/community/mruby/APKBUILD
index 53d2aa3c24..a9587a422a 100644
--- a/community/mruby/APKBUILD
+++ b/community/mruby/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.4.1
pkgrel=0
pkgdesc="Lightweight Ruby"
url="http://mruby.org"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="MIT"
depends=""
makedepends="$depends_dev bison ruby"
diff --git a/community/nnn/APKBUILD b/community/nnn/APKBUILD
index 552174e813..340b24066b 100644
--- a/community/nnn/APKBUILD
+++ b/community/nnn/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.9
pkgrel=0
pkgdesc="The missing terminal file browser for X"
url="https://github.com/jarun/nnn"
-arch="all !armhf" # armhf: fails to build
+arch="all !armhf !armv7" # armhf: fails to build
license="BSD-2-Clause"
makedepends="ncurses-dev readline-dev"
options="!check" # no tests provided and `nnn -v` requires tty
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index 37011e1006..7d9e1deec6 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -10,7 +10,7 @@ _ocamlver=${pkgver%.*}
pkgrel=1
pkgdesc="Caml preprocessor and pretty-printer"
url="https://github.com/ocaml/camlp4/releases"
-arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
+arch="all !x86 !armhf !armv7 !s390x" # ocaml not avail on excluded platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
depends="ocaml-runtime=~$_ocamlver ocaml-ocamlbuild"
depends_dev="$pkgname=$pkgver-r$pkgrel"
diff --git a/community/ocaml-findlib/APKBUILD b/community/ocaml-findlib/APKBUILD
index be6706a012..f35df02723 100644
--- a/community/ocaml-findlib/APKBUILD
+++ b/community/ocaml-findlib/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.8.0
pkgrel=0
pkgdesc="OCaml package manager"
url="http://projects.camlcity.org/projects/findlib.html"
-arch="all !x86 !armhf !s390x" # limited by ocaml abuild
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml abuild
license="MIT"
depends="ocaml ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel"
diff --git a/community/ocaml-lablgtk/APKBUILD b/community/ocaml-lablgtk/APKBUILD
index c11830fa04..dfbf77907c 100644
--- a/community/ocaml-lablgtk/APKBUILD
+++ b/community/ocaml-lablgtk/APKBUILD
@@ -6,7 +6,7 @@ pkgver=2.18.6
pkgrel=0
pkgdesc="An OCaml interface to GTK+ 2.x"
url="http://lablgtk.forge.ocamlcore.org/"
-arch="all !x86 !armhf !s390x" # limited by ocaml aport
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
license="LGPL-2.1-only-WITH-linking-exception"
depends="ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 3747b897a4..b69819c287 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -6,7 +6,7 @@ pkgver=4.06.1
pkgrel=2
pkgdesc="Main implementation of the Caml programming language"
url="http://ocaml.org/"
-arch="all !x86 !armhf !s390x"
+arch="all !x86 !armhf !armv7 !s390x"
license="LGPL-2.1-or-later-WITH-linking-exception"
depends="$pkgname-runtime=$pkgver-r$pkgrel gcc"
makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev"
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index 7f599a1556..a7ca751544 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.12.0
pkgrel=3
pkgdesc="Generic build tool with built-in rules for building OCaml library and programs"
url="https://github.com/ocaml/ocamlbuild"
-arch="all !x86 !armhf !s390x" # limited by ocaml aport
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
license="LGPL-2.0-or-later-WITH-linking-exception"
checkdepends="ocaml-compiler-libs ocaml-findlib"
depends="ocaml-$pkgname=$pkgver-r$pkgrel cmd:tput"
diff --git a/community/omxplayer/APKBUILD b/community/omxplayer/APKBUILD
index 8e2390c75b..bb9a994aee 100644
--- a/community/omxplayer/APKBUILD
+++ b/community/omxplayer/APKBUILD
@@ -5,7 +5,7 @@ _commitid=96800576209bbf02939a3d71dec91ec1c1da586b
pkgrel=0
pkgdesc="Commandline OMX player for Raspberry Pi"
url="https://github.com/popcornmix/omxplayer"
-arch="armhf"
+arch="armhf armv7"
license="GPL-2.0"
depends="ttf-freefont"
makedepends="linux-headers raspberrypi-dev ffmpeg-dev pcre-dev
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 7c7f52982e..7306f66851 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.2.2
pkgrel=4
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
-arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
+arch="all !x86 !armhf !armv7 !s390x" # ocaml not avail on excluded platforms
license="LGPL-3.0"
depends="ocaml ocaml-camlp4 curl tar unzip rsync aspcud patch"
makedepends="ocaml-compiler-libs ocaml-camlp4-dev"
diff --git a/community/py-gpiozero/APKBUILD b/community/py-gpiozero/APKBUILD
index 5d9103ae63..12a48df1ae 100644
--- a/community/py-gpiozero/APKBUILD
+++ b/community/py-gpiozero/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.1.0
pkgrel=0
pkgdesc="A simple interface to everyday GPIO components used with Raspberry Pi"
url="http://gpiozero.readthedocs.org"
-arch="armhf"
+arch="armhf armv7"
license="BSD-3-Clause"
depends="python2"
depends_dev=""
diff --git a/community/py-rpigpio/APKBUILD b/community/py-rpigpio/APKBUILD
index a50e864f93..619bf907cb 100644
--- a/community/py-rpigpio/APKBUILD
+++ b/community/py-rpigpio/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.6.3
pkgrel=1
pkgdesc="This package provides a class to control the GPIO on a Raspberry Pi."
url="https://pypi.python.org/pypi/RPi.GPIO"
-arch="armhf"
+arch="armhf armv7"
license="MIT"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
diff --git a/community/py-sensehat/APKBUILD b/community/py-sensehat/APKBUILD
index 343bc73f27..1d0cf3d6a9 100644
--- a/community/py-sensehat/APKBUILD
+++ b/community/py-sensehat/APKBUILD
@@ -6,7 +6,7 @@ pkgver=2.2.0
pkgrel=0
pkgdesc="Python module to control the Raspberry Pi Sense HAT"
url="https://www.raspberrypi.org/products/sense-hat/"
-arch="armhf"
+arch="armhf armv7"
license="BSD-3-Clause"
depends=""
# Package doesn't provide tests
diff --git a/community/rspamd/APKBUILD b/community/rspamd/APKBUILD
index 21326aff06..545c62b78a 100644
--- a/community/rspamd/APKBUILD
+++ b/community/rspamd/APKBUILD
@@ -8,7 +8,7 @@ pkgver=1.7.9
pkgrel=0
pkgdesc="Fast, free and open-source spam filtering system"
url="https://rspamd.com"
-arch="x86_64 x86 armhf ppc64le"
+arch="x86_64 x86 armhf armv7 ppc64le"
license="Apache-2.0 BSD-1-Clause BSD-2-Clause BSD-3-Clause CC0 LGPL-2.1-or-later
LGPL-3.0-only MIT Zlib"
options="!check"
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
index 4d5c5aa040..f1b42926b2 100644
--- a/community/shotwell/APKBUILD
+++ b/community/shotwell/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.28.2
pkgrel=0
pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
url="https://wiki.gnome.org/Apps/Shotwell"
-arch="all !armhf !aarch64"
+arch="all !armhf !armv7 !aarch64"
license="CC-BY-SA-3.0 LGPL-2.1-or-later"
install="shotwell.post-upgrade shotwell.post-install shotwell.pre-deinstall"
subpackages="$pkgname-lang $pkgname-doc"
diff --git a/community/syncthing/APKBUILD b/community/syncthing/APKBUILD
index 4a9036817a..ee99a94fb3 100644
--- a/community/syncthing/APKBUILD
+++ b/community/syncthing/APKBUILD
@@ -7,7 +7,7 @@ pkgver=0.14.50
pkgrel=0
pkgdesc="Open Source Continuous File Synchronization"
url="https://syncthing.net/"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="MPL-2.0"
pkgusers="$pkgname"
pkggroups="$pkgname"
diff --git a/community/terraform/APKBUILD b/community/terraform/APKBUILD
index 4bfa6ec895..2ab517d6cc 100644
--- a/community/terraform/APKBUILD
+++ b/community/terraform/APKBUILD
@@ -7,7 +7,7 @@ pkgver=0.11.8
pkgrel=0
pkgdesc="Building, changing and combining infrastructure safely and efficiently"
url="https://www.terraform.io/"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="MPL-2.0"
makedepends="go"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/terraform/archive/v$pkgver.tar.gz"
diff --git a/community/tinc-pre/APKBUILD b/community/tinc-pre/APKBUILD
index 17f27e21b3..313dde9e4f 100644
--- a/community/tinc-pre/APKBUILD
+++ b/community/tinc-pre/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Virtual Private Network (VPN) daemon (pre-release)"
url="http://tinc-vpn.org/"
# s390x: tests hang
# armhf: tests fail
-arch="all !s390x !armhf"
+arch="all !s390x !armhf !armv7"
license="GPL-2.0"
makedepends="linux-headers ncurses-dev readline-dev
zlib-dev lzo-dev libressl-dev texinfo
diff --git a/community/unison/APKBUILD b/community/unison/APKBUILD
index a79acae88d..970e9ec147 100644
--- a/community/unison/APKBUILD
+++ b/community/unison/APKBUILD
@@ -10,7 +10,7 @@ pkgdesc="Efficient file-synchronization tool"
url="https://www.cis.upenn.edu/~bcpierce/unison/"
# ocaml is not built for x86, armhf, s390x
# ocaml-lablgtk is not built for aarch64
-arch="all !x86 !armhf !aarch64 !s390x"
+arch="all !x86 !armhf !armv7 !aarch64 !s390x"
license="GPL-3.0+"
makedepends="ocaml ocaml-lablgtk-dev linux-headers emacs-nox bash"
subpackages="$pkgname-gui"
diff --git a/community/unit/APKBUILD b/community/unit/APKBUILD
index 92308b52f9..2947e6359e 100644
--- a/community/unit/APKBUILD
+++ b/community/unit/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="NGINX Unit is a dynamic web application server"
url="https://unit.nginx.org/"
# armhf, x86: tests fail (https://github.com/nginx/unit/issues/118)
# s390x: tests fail
-arch="all !armhf !x86 !s390x"
+arch="all !armhf !armv7 !x86 !s390x"
license="Apache-2.0"
_phpver=7
makedepends="perl-dev php$_phpver-dev php$_phpver-embed python3-dev ruby-dev"
diff --git a/community/wiringpi/APKBUILD b/community/wiringpi/APKBUILD
index 897985d400..128777b50b 100644
--- a/community/wiringpi/APKBUILD
+++ b/community/wiringpi/APKBUILD
@@ -5,7 +5,7 @@ _commitid=5edd177
pkgrel=0
pkgdesc="command line interface for Raspberry Pi gpio"
url="http://wiringpi.com/the-gpio-utility/"
-arch="armhf"
+arch="armhf armv7"
license="LGPL-3.0"
depends=""
makedepends="linux-headers"
diff --git a/community/xpra/APKBUILD b/community/xpra/APKBUILD
index 01576355fb..741c492b45 100644
--- a/community/xpra/APKBUILD
+++ b/community/xpra/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Xpra is 'screen for X' & allows you to run X programs, usually on a remote host over SSH or encrypted tcp"
url="http://xpra.org"
# !armhf: fails to build
-arch="all !armhf"
+arch="all !armhf !armv7"
license="GPL-2.0-or-later"
depends="py-gobject py-gtk py-gtkglext py-imaging py-opencl>=2018.1.1-r1 py-rencode py2-cryptography
py2-lz4 py2-numpy py2-pillow py2-xxhash setxkbmap xf86-video-dummy xorg-server xvfb"
diff --git a/community/zstd/APKBUILD b/community/zstd/APKBUILD
index 1307ae51b4..be2f1a1194 100644
--- a/community/zstd/APKBUILD
+++ b/community/zstd/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.3.5
pkgrel=0
pkgdesc="Zstandard - Fast real-time compression algorithm"
url="http://www.zstd.net"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="BSD-3-Clause GPL-2.0-or-later"
checkdepends="file"
subpackages="$pkgname-static $pkgname-libs $pkgname-dev $pkgname-doc"