aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 22:18:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 22:21:21 -0300
commitc1fd0367c060b81769a19bd7f65bef94463b730b (patch)
treeb6d613b93d28a3ebe62fd8f153572dd58af70378 /community
parent308ba4c2b39a64e51122d578a250ec85f4ffad75 (diff)
downloadaports-c1fd0367c060b81769a19bd7f65bef94463b730b.tar.bz2
aports-c1fd0367c060b81769a19bd7f65bef94463b730b.tar.xz
community/py3-bottle: drop py2
Diffstat (limited to 'community')
-rw-r--r--community/py3-bottle/APKBUILD37
1 files changed, 12 insertions, 25 deletions
diff --git a/community/py3-bottle/APKBUILD b/community/py3-bottle/APKBUILD
index 62016cc569..be900c1956 100644
--- a/community/py3-bottle/APKBUILD
+++ b/community/py3-bottle/APKBUILD
@@ -1,45 +1,32 @@
# Contributor: Paul Kilar <pkilar@gmail.com>
# Maintainer: Paul Kilar <pkilar@gmail.com>
-pkgname=py-bottle
+pkgname=py3-bottle
_pkgname=bottle
pkgver=0.12.17
-pkgrel=0
+pkgrel=1
pkgdesc="A fast, simple and lightweight WSGI micro web-framework"
+options="!check" # failures=1
url="https://bottlepy.org/docs/dev"
arch="noarch"
license="MIT"
-depends=""
-makedepends="py2-setuptools py3-setuptools"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-bottle" # Backwards compatibility
+provides="py-bottle=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
+check() {
+ python3 test/testall.py
}
-_py3() {
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="349231666b41d10f2af7ce834cd64aa8dbe187aee05699a83ab5b7810ffe28994392bee2149d0f134087df24a5b0632ccfefeb3e1152773034f68c583fe520c3 bottle-0.12.17.tar.gz"