aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-12-02 11:13:03 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-12-02 11:13:03 +0000
commitd3a11e8f226904a8856b5f48fec750055f2b3541 (patch)
tree05c9e2666d072f8b44a3938c7cf2f6d31eb0039d /community
parent2ab9d107c59006829c663ad5d2de5e8ce06956b4 (diff)
downloadaports-d3a11e8f226904a8856b5f48fec750055f2b3541.tar.bz2
aports-d3a11e8f226904a8856b5f48fec750055f2b3541.tar.xz
community/patchwork: removed strong version checking
Diffstat (limited to 'community')
-rw-r--r--community/patchwork/APKBUILD14
-rw-r--r--community/patchwork/dependencies-fix.patch15
-rw-r--r--community/patchwork/py-django-rest-framwork-py-django-filter.patch13
3 files changed, 23 insertions, 19 deletions
diff --git a/community/patchwork/APKBUILD b/community/patchwork/APKBUILD
index 22c9f523bb..bbed83733b 100644
--- a/community/patchwork/APKBUILD
+++ b/community/patchwork/APKBUILD
@@ -2,17 +2,17 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=2.1.4
-pkgrel=0
+pkgrel=1
pkgdesc="Web-based patch tracking system"
url="https://github.com/getpatchwork/patchwork"
arch="noarch"
license="GPL-2.0-or-later"
options="!check"
depends="
- py3-django<2.0
- py3-django-rest-framework<3.9
- py3-django-filter<2.0.1
- py3-psycopg2<2.8
+ py3-django
+ py3-django-rest-framework
+ py3-django-filter
+ py3-psycopg2
py3-sqlparse
"
subpackages="
@@ -24,6 +24,7 @@ subpackages="
pwclient:pwclient
"
source="patchwork-$pkgver.tar.gz::https://github.com/getpatchwork/patchwork/archive/v$pkgver.tar.gz
+ dependencies-fix.patch
0001-support-busybox-readlink.patch
0002-remove-uneeded-bashism-from-tools-and-change-path.patch
nginx-uwsgi-patchwork-conf.ini
@@ -88,8 +89,9 @@ pwclient() {
}
sha512sums="e15e1b2b9d386d98f74d55efcc805ecad827be40610c993245d3ac13d04b655a264bf0ebe7ec83b929db52059a9dd13c49bd56676a5c1d2f25d965b310bccfb0 patchwork-2.1.4.tar.gz
+1721531735c02d2f3d0241341ffe4620c66771cf99fb9b597156bcc3b19b5cdfd17835d4e79f2fdfef33c1f3bf13444174b3fb0c9363520574918d924dae454c dependencies-fix.patch
5facc2c2620b2d614011bcdc06bb481fb1481c79333579e5a7fa5b8bc4f97d1651cc8c4632a5e150b62674d64c00345341229319f1edb2016721868e84146826 0001-support-busybox-readlink.patch
f6d3590b3ac53797e0ae25fe50ab0935608be5ded44665599cbc91e93558895eddc6a7a717153d81fc194b314d7854686577ef5ecf9e0302b7824ce3b3863f7b 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
28911a25e00a254237f7214fb681e5e984a2eae331e610be62967d5e246958e0f8d3f84861d8fd17c1190c1df72a25f28ddb33843b3679a3864beb00cb4b4961 nginx-uwsgi-patchwork-conf.ini
862dd2522236a0b18d2a8d06f1ad91ad0fd0936fa502d95e09556641e67d42e1212821bfd7fb98923e4fe8b8a7369ded8c23831fb496b1e2833d9831c1b23725 nginx-patchwork.conf
-47f040f80836bf5e8c0c5d5a95e7cf6c5d9714437eac2f6c6e927ca6b346b86eb50b87e7deace33e3d1cd11ab6c74146e725aac835a1355864a5e5e9179b0082 py-django-rest-framwork-py-django-filter.patch"
+5f1d5189bde5ba4494aec3e9517583a58791f50632c67b5e17a05cd2b9beaef02b5c12dfbb7d076e8af49c5dffe6fb3f4739897a58a2c7d2915baf19fb26c4fc py-django-rest-framwork-py-django-filter.patch"
diff --git a/community/patchwork/dependencies-fix.patch b/community/patchwork/dependencies-fix.patch
new file mode 100644
index 0000000000..74834d4fd9
--- /dev/null
+++ b/community/patchwork/dependencies-fix.patch
@@ -0,0 +1,15 @@
+diff --git a/requirements-prod.txt b/requirements-prod.txt
+index d249ad8..27f9e5e 100644
+--- a/requirements-prod.txt
++++ b/requirements-prod.txt
+@@ -1,5 +1,5 @@
+-Django>=1.8,<2.0
+-djangorestframework>=3.4,<3.7
+-django-filter>=1.0,<1.1
+-psycopg2>=2.7,<2.8
+-sqlparse==0.2.4
++Django>=1.8
++djangorestframework>=3.4
++django-filter>=1.0
++psycopg2>=2.7
++sqlparse>0.2.4
diff --git a/community/patchwork/py-django-rest-framwork-py-django-filter.patch b/community/patchwork/py-django-rest-framwork-py-django-filter.patch
index 84755de9ee..acae36cabd 100644
--- a/community/patchwork/py-django-rest-framwork-py-django-filter.patch
+++ b/community/patchwork/py-django-rest-framwork-py-django-filter.patch
@@ -116,16 +116,3 @@ index 3bbff44..d1d89c1 100644
# reverse, reverse_lazy
#
-diff --git a/requirements-prod.txt b/requirements-prod.txt
-index d249ad8..4246b61 100644
---- a/requirements-prod.txt
-+++ b/requirements-prod.txt
-@@ -1,5 +1,5 @@
- Django>=1.8,<2.0
--djangorestframework>=3.4,<3.7
--django-filter>=1.0,<1.1
-+djangorestframework>=3.4,<3.9
-+django-filter==2.0.0
- psycopg2>=2.7,<2.8
- sqlparse==0.2.4
-