aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-05-03 11:49:41 +0200
committerMilan P. Stanić <mps@arvanta.net>2020-05-03 11:49:41 +0200
commitd96fa886095f4d87d48971d5c79125fa65f1ebda (patch)
treef8331fd750b423e648cd4ae8fdee2b29a3007450 /community
parent2c682d5ed0b97ef7400e4ebc3afe9582ae829a15 (diff)
downloadaports-d96fa886095f4d87d48971d5c79125fa65f1ebda.tar.bz2
aports-d96fa886095f4d87d48971d5c79125fa65f1ebda.tar.xz
community/jo: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/jo/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/jo/APKBUILD b/community/jo/APKBUILD
new file mode 100644
index 0000000000..97328255b7
--- /dev/null
+++ b/community/jo/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Orion <systmkor@gmail.com>
+# Maintainer: Orion <systmkor@gmail.com>
+pkgname=jo
+pkgver=1.3
+pkgrel=0
+pkgdesc="JSON output from a shell"
+url="https://github.com/jpmens/jo/"
+arch="all"
+license="GPL-2.0-or-later"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch"
+source="https://github.com/jpmens/jo/releases/download/$pkgver/jo-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv "$pkgdir"/etc/bash_completion.d \
+ "$subpkgdir"/usr/share/bash-completion/completions
+}
+
+sha512sums="3c9480257d0ab9d9f19f1aaeb3a5b72e69caff6dcf87118bea8aca74a3b0864c0d17ed52bfc5550783c4636ee3a6acb8578f08316d976cea4f06af7096c12f02 jo-1.3.tar.gz"