aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-03 04:01:10 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-03 12:13:04 +0100
commitdd502921478ee7eeaeace500929d294a09487a28 (patch)
treeecbd7d0105869ddc2c71b6cfbe84ecdc3ea30e1e /community
parentdd8a947d2130b90fc7fb0b2d15cc2153a8393224 (diff)
downloadaports-dd502921478ee7eeaeace500929d294a09487a28.tar.bz2
aports-dd502921478ee7eeaeace500929d294a09487a28.tar.xz
rebuild against libfmt-6.1.0
The soname didn't change but it still broke.
Diffstat (limited to 'community')
-rw-r--r--community/kodi/APKBUILD4
-rw-r--r--community/kodi/cassert.patch25
-rw-r--r--community/spdlog/APKBUILD9
-rw-r--r--community/spdlog/cassert.patch25
-rw-r--r--community/waybar/APKBUILD6
-rw-r--r--community/waybar/cassert.patch12
6 files changed, 75 insertions, 6 deletions
diff --git a/community/kodi/APKBUILD b/community/kodi/APKBUILD
index 0661e9fc3b..757c4d7eee 100644
--- a/community/kodi/APKBUILD
+++ b/community/kodi/APKBUILD
@@ -3,7 +3,7 @@
pkgname=kodi
pkgver=18.3
_realname=Leia
-pkgrel=2
+pkgrel=3
_libdvdcss_pkgver="1.4.2-Leia-Beta-5"
_libdvdread_pkgver="6.0.0-Leia-Alpha-3"
_libdvdnav_pkgver="6.0.0-Leia-Alpha-3"
@@ -97,6 +97,7 @@ source="https://github.com/xbmc/xbmc/archive/$pkgver-$_realname.tar.gz
crossguid-$_crossguid_hash.tar.gz::https://mirrors.kodi.tv/build-deps/sources/crossguid-$_crossguid_hash.tar.gz
set-default-stacksize.patch
fix-musl-incompability.patch
+ cassert.patch
kodi.initd
60-kodi.rules
"
@@ -233,5 +234,6 @@ b3419ba0a1a2dd70f1bb6236afdfe1c6e88c9ad4264198b289e3bba9375e077cecf7f89848c7b09d
2682d63609d3dcdfcd8136be632e45df26ad88ce93b9c49745cf728bbd2e6254a7b05c8b059ab581d532372e504206a525a52564b64d076dfdae9c965a09fd16 crossguid-8f399e8bd4.tar.gz
3fd97e9fa22e59b3cd30fdad19474e177a9d062598765fa8ba4955f1da4e10581ff1463dd0794d3ee3cefebf753007a4d445b2bc47a257574d3927c1408b8876 set-default-stacksize.patch
65b78a96bef33cec975b371f1a930d551d7b224955d6075b7edc7e51ec30fec9c77d34f622abbaf827c60df6029206b72c02ee2d2f138d276c1b843336fd14ab fix-musl-incompability.patch
+7348495a805d07730dc569b091f15765ca9d86fa28987a343dfc7fa36cd6ecbb52ac4ea76d7c9fe9eab90ed8552ef6aeae7ffd72edd11f8d780c1de2e9ffe49d cassert.patch
7e2a2289da3098e0007e461ad538dcd6435e908283caf1719788248fe736615890175e11392ca0cd68002872217bbf7b70cf909f228307828aa82467d5502ed4 kodi.initd
465a2079d598bf909a458d8e9d0ddd2b2a41dff83ba736542cffec7811c044295d5af092928f20aaa6cd3bc8b13bb03ede5c7ded1783680f890464e103392787 60-kodi.rules"
diff --git a/community/kodi/cassert.patch b/community/kodi/cassert.patch
new file mode 100644
index 0000000000..5246c5cedc
--- /dev/null
+++ b/community/kodi/cassert.patch
@@ -0,0 +1,25 @@
+diff --git a/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp b/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
+index 222d1fa..0f654ee 100644
+--- a/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
++++ b/xbmc/profiles/dialogs/GUIDialogProfileSettings.cpp
+@@ -30,6 +30,7 @@
+ #include "utils/log.h"
+ #include "utils/StringUtils.h"
+ #include "utils/URIUtils.h"
++#include <cassert>
+ #include "utils/Variant.h"
+ #include "ServiceBroker.h"
+
+diff --git a/xbmc/windowing/GraphicContext.cpp b/xbmc/windowing/GraphicContext.cpp
+index 1ced496..0ddbe64 100644
+--- a/xbmc/windowing/GraphicContext.cpp
++++ b/xbmc/windowing/GraphicContext.cpp
+@@ -24,6 +24,8 @@
+ #include "guilib/GUIWindowManager.h"
+ #include "guilib/TextureManager.h"
+
++#include <cassert>
++
+ using namespace KODI::MESSAGING;
+
+ CGraphicContext::CGraphicContext(void) = default;
diff --git a/community/spdlog/APKBUILD b/community/spdlog/APKBUILD
index fe5ecaffc1..9c51439d72 100644
--- a/community/spdlog/APKBUILD
+++ b/community/spdlog/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=spdlog
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Fast C++ logging library"
url="https://github.com/gabime/spdlog"
arch="all"
license="MIT"
makedepends="cmake fmt-dev"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gabime/spdlog/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gabime/spdlog/archive/v$pkgver.tar.gz
+ cassert.patch
+ "
build() {
mkdir build
@@ -51,4 +53,5 @@ dev() {
rmdir -p "$pkgdir"/usr/lib/spdlog || true
}
-sha512sums="886b489138a1bdf363b5eab65a7d973f570a01c399ff5b910fcfee172ad4ff4d42a45dc2ae24e77b07130df527fb13a86b3e55ac992e72c418aebb232e27eabf spdlog-1.4.2.tar.gz"
+sha512sums="886b489138a1bdf363b5eab65a7d973f570a01c399ff5b910fcfee172ad4ff4d42a45dc2ae24e77b07130df527fb13a86b3e55ac992e72c418aebb232e27eabf spdlog-1.4.2.tar.gz
+f3db0d78bcb6a3e29a061a67cec1583a2f4aee2ecd3309b29315f5c205482dc271eadac49ff186ec36547ab2e7c429b090da73bead82a8bed15b514af53710d8 cassert.patch"
diff --git a/community/spdlog/cassert.patch b/community/spdlog/cassert.patch
new file mode 100644
index 0000000000..18c87b816c
--- /dev/null
+++ b/community/spdlog/cassert.patch
@@ -0,0 +1,25 @@
+diff --git a/include/spdlog/details/pattern_formatter-inl.h b/include/spdlog/details/pattern_formatter-inl.h
+index 1b95eb6..a77a472 100644
+--- a/include/spdlog/details/pattern_formatter-inl.h
++++ b/include/spdlog/details/pattern_formatter-inl.h
+@@ -15,6 +15,7 @@
+
+ #include <array>
+ #include <chrono>
++#include <cassert>
+ #include <ctime>
+ #include <cctype>
+ #include <cstring>
+diff --git a/include/spdlog/details/thread_pool-inl.h b/include/spdlog/details/thread_pool-inl.h
+index 77d0b1f..c773149 100644
+--- a/include/spdlog/details/thread_pool-inl.h
++++ b/include/spdlog/details/thread_pool-inl.h
+@@ -9,6 +9,8 @@
+
+ #include "spdlog/common.h"
+
++#include <cassert>
++
+ namespace spdlog {
+ namespace details {
+
diff --git a/community/waybar/APKBUILD b/community/waybar/APKBUILD
index beeb094f36..d7c6ba7a98 100644
--- a/community/waybar/APKBUILD
+++ b/community/waybar/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname="waybar"
pkgver="0.8.0"
-pkgrel=2
+pkgrel=3
pkgdesc="Highly customizable Wayland bar for Sway and Wlroots based compositors"
url="https://github.com/Alexays/Waybar/"
arch="all"
@@ -12,6 +12,7 @@ makedepends="meson gtkmm3-dev jsoncpp-dev spdlog-dev fmt-dev libinput-dev
libnl3-dev pulseaudio-dev libmpdclient-dev eudev-dev scdoc"
subpackages="$pkgname-doc"
source="Waybar-$pkgver.tar.gz::https://github.com/Alexays/Waybar/archive/$pkgver.tar.gz
+ cassert.patch
"
options="!check" # No test suite
builddir="$srcdir/Waybar-$pkgver"
@@ -31,4 +32,5 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="c670fd21a7d29396d8bbe1b7540ddbbe44a98f7fb49f8518e0cc302aa57e5bb993ff8306973a7b8ca4ec000a7ecc311872762a0782ce19e4bf4cff8ea09caccb Waybar-0.8.0.tar.gz"
+sha512sums="c670fd21a7d29396d8bbe1b7540ddbbe44a98f7fb49f8518e0cc302aa57e5bb993ff8306973a7b8ca4ec000a7ecc311872762a0782ce19e4bf4cff8ea09caccb Waybar-0.8.0.tar.gz
+8eaf4121b326ece3f62708e3e2dd58f6c5d827db9ee6c1f4a5c22d2a2162e18a5aac730994b55f5ac290214da7f8b6a88ece68ee30643308fd80beea0a252883 cassert.patch"
diff --git a/community/waybar/cassert.patch b/community/waybar/cassert.patch
new file mode 100644
index 0000000000..c9544dd4cc
--- /dev/null
+++ b/community/waybar/cassert.patch
@@ -0,0 +1,12 @@
+diff --git a/src/modules/network.cpp b/src/modules/network.cpp
+index 6ba607b..f7f4a1d 100644
+--- a/src/modules/network.cpp
++++ b/src/modules/network.cpp
+@@ -2,6 +2,7 @@
+ #include <spdlog/spdlog.h>
+ #include <sys/eventfd.h>
+ #include <fstream>
++#include <cassert>
+
+ namespace {
+