aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-02 08:57:59 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-02 15:11:02 +0100
commite29ba71ad72c43189f911d3704d1aa4a85103e61 (patch)
tree10523d4587d2d20c5918f967e825f74595f5488a /community
parentddb627807cc7b7b9bbb0b60a883449aaeaf5efc9 (diff)
downloadaports-e29ba71ad72c43189f911d3704d1aa4a85103e61.tar.bz2
aports-e29ba71ad72c43189f911d3704d1aa4a85103e61.tar.xz
community/font-hermit-nerd: upgrade to 2.1.0
Diffstat (limited to 'community')
-rw-r--r--community/font-hermit-nerd/APKBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/community/font-hermit-nerd/APKBUILD b/community/font-hermit-nerd/APKBUILD
index 72eba86a96..3d0c963fff 100644
--- a/community/font-hermit-nerd/APKBUILD
+++ b/community/font-hermit-nerd/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
-pkgname=font-hermit-nerd
-pkgver=2.0.0
+pkgname=nerd-fonts
+pkgver=2.1.0
pkgrel=0
pkgdesc="Iconic font aggregator, collection and patcher"
url="https://nerdfonts.com"
@@ -8,13 +8,33 @@ arch="noarch"
options="!check" # No testsuite provided
license="MIT"
depends="fontconfig"
-source="$pkgname-$pkgver.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Hermit.zip"
+subpackages="
+ font-hermit-nerd:hermit:noarch
+ font-ia-writer-nerd:writer:noarch
+ "
+source="
+ Hermit-$pkgver.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Hermit.zip
+ ia-Writer-$pkgver.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/iA-Writer.zip
+ "
builddir="$srcdir"
package() {
+ mkdir -p "$pkgdir"
+}
+
+hermit() {
+ pkgdesc="$pkgdesc (Hermit)"
find . -iname 'Hurmit*.otf' | while read -r otf; do
- install -Dm644 "$otf" "$pkgdir"/usr/share/fonts/OTF/"$otf"
+ install -Dm644 "$otf" "$subpkgdir"/usr/share/fonts/OTF/"$otf"
+ done
+}
+
+writer() {
+ pkgdesc="$pkgdesc (iA Writer)"
+ find . -iname 'iM Writing*.otf' | while read -r otf; do
+ install -Dm644 "$otf" "$subpkgdir"/usr/share/fonts/OTF/"$otf"
done
}
-sha512sums="8bd0b7e7ed07ab9e5ecb4b348203aa298aecb078ae6b71065d089193aa59956377d9b3d59d65b0d397f157614decc84cc521b7df61878fd8d071bc5e0c29f423 font-hermit-nerd-2.0.0.zip"
+sha512sums="caf9026646ea1756c0c3d4f5ef08b2329ce10f6bfeefd7a4c7cfba1ac16c85e08103cd05fe4ba9c34fc6f35bb1a5a8830053dc5f90f153410fec12ef134bf84a Hermit-2.1.0.zip
+6fc219e954295fe4cc1a778141aa464f2b08d73def4c3428e875502d7c1cce1f2d5a4f178a83641e1e4b5d5c45eb406f11ab7858723894dd0bf4ec5e08775adf ia-Writer-2.1.0.zip"