aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorAnjandev Momi <anjan@momi.ca>2020-05-03 02:26:16 -0700
committerLeo <thinkabit.ukim@gmail.com>2020-05-03 22:56:26 +0000
commite50a6e410ba533bc918aa1d6d16d17c909f126f2 (patch)
tree4da121b5ecbf3a78e41a07b5fb34e65a3790afd8 /community
parenteb8d66629539275f2c35e0e57b13e329f37819fc (diff)
downloadaports-e50a6e410ba533bc918aa1d6d16d17c909f126f2.tar.bz2
aports-e50a6e410ba533bc918aa1d6d16d17c909f126f2.tar.xz
community/xdo: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/xdo/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/xdo/APKBUILD b/community/xdo/APKBUILD
new file mode 100644
index 0000000000..705cf09e6c
--- /dev/null
+++ b/community/xdo/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Anjandev Momi <anjan@momi.ca>
+# Maintainer: Anjandev Momi <anjan@momi.ca>
+pkgname=xdo
+pkgver=0.5.7
+pkgrel=0
+pkgdesc="Small X utility to perform elementary actions on windows"
+url="https://github.com/baskerville/xdo"
+arch="all"
+license="BSD-2-Clause"
+makedepends="xcb-util-wm-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/baskerville/xdo/archive/$pkgver.tar.gz"
+
+build() {
+ make -C "$builddir"
+}
+
+package() {
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
+sha512sums="0978a8571a35899c916495c9d38458adb6c766db4d498dfacf2f0a46e373f7caa3c3e227096b3e60e03c67b972777cf7519e5b6eee7ebb91f82d4450ac0ff98d xdo-0.5.7.tar.gz"