aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 21:14:39 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-04 09:00:50 -0300
commitf98521cdb58a443fcaac3664dd198e9ed6e0aaf7 (patch)
treef5c737641f2a0dc72cbd4e9f59c1afbe80a1c02e /community
parenta95d7efded7650a16db9f1cfa01e95bc5513cf83 (diff)
downloadaports-f98521cdb58a443fcaac3664dd198e9ed6e0aaf7.tar.bz2
aports-f98521cdb58a443fcaac3664dd198e9ed6e0aaf7.tar.xz
community/vkd3d: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/vkd3d/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/vkd3d/APKBUILD b/community/vkd3d/APKBUILD
new file mode 100644
index 0000000000..ee8581a2e1
--- /dev/null
+++ b/community/vkd3d/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=vkd3d
+pkgver=1.1
+pkgrel=0
+pkgdesc="Direct3D 12 to Vulkan translation library"
+url="https://www.winehq.org"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="vulkan-headers vulkan-loader-dev spirv-headers spirv-tools-dev libxcb-dev
+ xcb-util-keysyms-dev"
+subpackages="$pkgname-static $pkgname-dev"
+source="https://dl.winehq.org/vkd3d/source/vkd3d-${pkgver}.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-xcb \
+ --with-spirv-tools
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e107612bdca95e998f9d819bdf74e4ffe1b4d400d250ab855c4ebf94b7d3f088b3221591fef03b1c6b8ecb030feb1673f74831bd8bd8edda2989d09a8846b0f7 vkd3d-1.1.tar.xz"