aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 23:15:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 09:35:45 -0300
commitfe30af5e6e0df4713dd4709baddc40f5e0a37081 (patch)
treee85593c963503c310091bc8892d5574787c71831 /community
parente626156b30b07a1863a83d1eeb40a9f07c9f388e (diff)
downloadaports-fe30af5e6e0df4713dd4709baddc40f5e0a37081.tar.bz2
aports-fe30af5e6e0df4713dd4709baddc40f5e0a37081.tar.xz
community/py3-appdirs: move from testing
Required for py3-opencl
Diffstat (limited to 'community')
-rw-r--r--community/py3-appdirs/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-appdirs/APKBUILD b/community/py3-appdirs/APKBUILD
new file mode 100644
index 0000000000..2ed01a2d57
--- /dev/null
+++ b/community/py3-appdirs/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer:
+pkgname=py3-appdirs
+_pkgname=${pkgname#py3-}
+pkgver=1.4.3
+pkgrel=0
+pkgdesc="A small Python module for determining appropriate platform-specific dirs."
+url="https://pypi.org/project/appdirs/"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="964db6c9f830c9b23d78f0230c5f574f214f08faf3fd24f10ccc941d23e38de66186461d754f7effb94aa0553c25df4843c9ff5dcd375c992c322550b3d98cce appdirs-1.4.3.tar.gz"