aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-01-07 16:26:45 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-08 16:41:55 +0000
commit0803c9e42279ead9693826fd05e75a7c8f35553a (patch)
tree362287c9abab273f1b8a9b3e07965d8d07a2fd81 /community
parentd50efca46c062181c44f0a38b8f69c54489cfb0a (diff)
downloadaports-0803c9e42279ead9693826fd05e75a7c8f35553a.tar.bz2
aports-0803c9e42279ead9693826fd05e75a7c8f35553a.tar.xz
main/zstd: move from community
Diffstat (limited to 'community')
-rw-r--r--community/zstd/APKBUILD44
-rw-r--r--community/zstd/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch12
2 files changed, 0 insertions, 56 deletions
diff --git a/community/zstd/APKBUILD b/community/zstd/APKBUILD
deleted file mode 100644
index 868c4d12d2..0000000000
--- a/community/zstd/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: stef <l0ls0fo2i@ctrlc.hu>
-# Maintainer: André Klitzing <aklitzing@gmail.com>
-pkgname=zstd
-pkgver=1.3.8
-pkgrel=0
-pkgdesc="Zstandard - Fast real-time compression algorithm"
-url="http://www.zstd.net"
-arch="all !armhf"
-license="BSD-3-Clause GPL-2.0-or-later"
-checkdepends="file"
-makedepends="grep"
-subpackages="$pkgname-static $pkgname-libs $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/zstd/archive/v$pkgver.tar.gz
- lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- unset CPPFLAGS
- make HAVE_PTHREAD=1 HAVE_ZLIB=0 HAVE_LZMA=0 HAVE_LZ4=0 MOREFLAGS="-O2"
-}
-
-check() {
- cd "$builddir"
- case "$CARCH" in
- arm*) make check ;;
- *) make test ;;
- esac
-}
-
-package() {
- cd "$builddir"
- make PREFIX="/usr" DESTDIR="$pkgdir" install
-}
-
-static() {
- pkgdesc="zstd static library"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
-}
-
-sha512sums="834f7b6477c1e7d70f71105ea52be15c33866b48b93b7a3c6dff4f10c761e5ad35f3903899516317690a4b768051f6eedf7c030292f57cea5613d4017fab9466 zstd-1.3.8.tar.gz
-4e577dc44f7b870ef55e179865e03a924f1cab5307367658e011f9868ef82562ca299e31411ef2ea15f0ac4247bcc5ce013a5c716479e08b34d0229d896aefc8 lift-XXH_FORCE_MEMORY_ACCESS-condition.patch"
diff --git a/community/zstd/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch b/community/zstd/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
deleted file mode 100644
index dc514a005c..0000000000
--- a/community/zstd/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/lib/common/xxhash.c
-+++ b/lib/common/xxhash.c
-@@ -52,8 +52,7 @@
- #ifndef XXH_FORCE_MEMORY_ACCESS /* can be defined externally, on command line for example */
- # if defined(__GNUC__) && ( defined(__ARM_ARCH_6__) || defined(__ARM_ARCH_6J__) || defined(__ARM_ARCH_6K__) || defined(__ARM_ARCH_6Z__) || defined(__ARM_ARCH_6ZK__) || defined(__ARM_ARCH_6T2__) )
- # define XXH_FORCE_MEMORY_ACCESS 2
--# elif (defined(__INTEL_COMPILER) && !defined(WIN32)) || \
-- (defined(__GNUC__) && ( defined(__ARM_ARCH_7__) || defined(__ARM_ARCH_7A__) || defined(__ARM_ARCH_7R__) || defined(__ARM_ARCH_7M__) || defined(__ARM_ARCH_7S__) ))
-+# elif (defined(__INTEL_COMPILER) && !defined(WIN32)) || defined(__GNUC__)
- # define XXH_FORCE_MEMORY_ACCESS 1
- # endif
- #endif