aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authornoname <noname@no.com>2019-01-06 12:46:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-07 14:30:27 +0000
commit42d0fe5b17329c55a287471860d50478d65c8669 (patch)
tree547da47a5b025fd3ef51ee7df8c7f96be0fcc5da /community
parente59e2abc0e39b003b4bf8bcf8fb03bcb6fd15bf6 (diff)
downloadaports-42d0fe5b17329c55a287471860d50478d65c8669.tar.bz2
aports-42d0fe5b17329c55a287471860d50478d65c8669.tar.xz
community/firefox-esr: upgrade to 60.4.0
Diffstat (limited to 'community')
-rw-r--r--community/firefox-esr/APKBUILD126
-rw-r--r--community/firefox-esr/discard-x86-precision-musl.patch11
-rw-r--r--community/firefox-esr/fix-bug-1261392.patch25
-rw-r--r--community/firefox-esr/fix-fortify-system-wrappers.patch20
-rw-r--r--community/firefox-esr/fix-rust-target.patch24
-rw-r--r--community/firefox-esr/fix-tools.patch52
-rw-r--r--community/firefox-esr/fix-webrtc-glibcisms.patch13
-rw-r--r--community/firefox-esr/missing-header-s390x.patch12
-rw-r--r--community/firefox-esr/musl-pthread-setname.patch14
-rw-r--r--community/firefox-esr/rust-unitialized-field.patch19
10 files changed, 164 insertions, 152 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index 9a8c484dac..e5aa416f85 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -1,19 +1,23 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=firefox-esr
-pkgver=52.9.0
-_pkgver=$pkgver
-_xulver=$pkgver
-pkgrel=1
-pkgdesc="Firefox web browser - Extended Support Release"
-url="https://www.mozilla.org/en-US/firefox/organizations/faq/"
-arch="all"
+pkgver=60.4.0
+pkgrel=0
+pkgdesc="Firefox web browser - Extended Support Release"
+url="https://www.mozilla.org/en-US/firefox/organizations/"
+# limited by rust and cargo
+arch="x86_64"
license="GPL LGPL MPL"
-depends=""
-depends_dev="
+makedepends="
alsa-lib-dev
+ autoconf2.13
+ automake
+ bsd-compat-headers
bzip2-dev
+ cargo
+ clang-dev
dbus-glib-dev
+ ffmpeg-dev
gconf-dev
gtk+2.0-dev
gtk+3.0-dev
@@ -25,58 +29,51 @@ depends_dev="
libnotify-dev
libogg-dev
libtheora-dev
+ libtool
libvorbis-dev
libvpx-dev
libxt-dev
libxcomposite-dev
+ llvm5-dev
mesa-dev
nspr-dev
nss-dev
- sqlite-dev
- startup-notification-dev
- wireless-tools-dev
- "
-makedepends="$depends_dev
- autoconf2.13
- automake
- bsd-compat-headers
- libtool
nss-static
paxmark
python2
+ sqlite-dev
sed
+ startup-notification-dev
+ wireless-tools-dev
yasm
zip
"
-install=""
-subpackages="$pkgname-dev"
-source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
+source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-"$pkgver"esr.source.tar.xz
stab.h
- 0002-Use-C99-math-isfinite.patch
+ fix-fortify-system-wrappers.patch
fix-fortify-inline.patch
disable-hunspell_hooks.patch
fix-seccomp-bpf.patch
fix-toolkit.patch
fix-tools.patch
mallinfo.patch
- musl-pthread-setname.patch
- fix-fortify-system-wrappers.patch
fix-arm-atomics-grsec.patch
fix-arm-version-detect.patch
mozilla-build-arm.patch
disable-moz-stackwalk.patch
- missing-header-s390x.patch
- discard-x86-precision-musl.patch
+ fix-rust-target.patch
+ fix-bug-1261392.patch
+ rust-unitialized-field.patch
+ fix-webrtc-glibcisms.patch
firefox.desktop
firefox-safe.desktop"
-builddir="${srcdir}/firefox-${pkgver}esr"/objdir
-_mozappdir=/usr/lib/firefox-${pkgver}
-_mozappdirdev=/usr/lib/firefox-devel-${pkgver}
+builddir="${srcdir}/firefox-$pkgver"
+_mozappdir=/usr/lib/firefox
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
@@ -99,20 +96,13 @@ ldpath="$_mozappdir"
# - CVE-2017-7843
prepare() {
- local i
- mkdir -p "$builddir"
- cd "$builddir"/..
-
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
}
build() {
- cd "$builddir"
+ mkdir -p "$builddir"/objdir
+ cd "$builddir"/objdir
export SHELL=/bin/sh
export BUILD_OFFICIAL=1
@@ -124,14 +114,12 @@ build() {
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
- local extra_flags=""
- [ "$CARCH" = "s390x" ] && extra_flags="--disable-startupcache"
-
../configure \
--prefix=/usr \
\
--disable-crashreporter \
--disable-elf-hack \
+ --disable-gold \
--disable-install-strip \
--disable-jemalloc \
--disable-profiling \
@@ -142,8 +130,6 @@ build() {
\
--enable-alsa \
--enable-default-toolkit=cairo-gtk3 \
- --enable-gio \
- --enable-gold=no \
--enable-official-branding \
--enable-optimize="$CFLAGS" \
--enable-pie \
@@ -151,6 +137,7 @@ build() {
--enable-system-ffi \
--enable-system-hunspell \
--enable-system-sqlite \
+ --enable-ffmpeg \
\
--with-pthreads \
--with-system-bz2 \
@@ -163,25 +150,25 @@ build() {
--with-system-pixman \
--with-system-png \
--with-system-zlib \
- $extra_flags
- make || return 1
+ --with-clang-path=/usr/bin/clang \
+ --with-libclang-path=/usr/lib
+ make
# paxmark outside fakeroot
- paxmark -msp dist/bin/xpcshell || return 1
+ paxmark -msp dist/bin/xpcshell
}
package() {
- cd "$builddir"
+ cd "$builddir"/objdir
# only used for startupcache creation.
local paxflags="-msp"
- paxmark "$paxflags" dist/bin/xpcshell || return 1
+ paxmark "$paxflags" dist/bin/xpcshell
make install \
DESTDIR="$pkgdir" \
- MOZ_MAKE_FLAGS="$MAKEOPTS" \
- || return 1
+ MOZ_MAKE_FLAGS="$MAKEOPTS"
install -m755 -d ${pkgdir}/usr/share/applications
install -m755 -d ${pkgdir}/usr/share/pixmaps
@@ -190,11 +177,11 @@ package() {
for png in ../browser/branding/official/default*.png; do
local i=${_png%.png}
i=${i##*/default}
- install -D -m644 "$png" "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png || return 1
+ install -D -m644 "$png" "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png
done
- install -m644 "$builddir"/../browser/branding/official/default48.png \
- ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
+ install -m644 "$builddir"/browser/branding/official/default48.png \
+ ${pkgdir}/usr/share/pixmaps/firefox.png
install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/firefox.desktop
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
@@ -202,15 +189,11 @@ package() {
local paxflags="-mp"
[ "$CARCH" = "x86" ] && paxflags="-msp"
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/firefox || return 1
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/plugin-container || return 1
-
- # xulrunner stub launcher has changed to using a symlink overlay...
- # go figure
- ln -sf /usr/lib/xulrunner-${_xulver} ${pkgdir}/$_mozappdir/xulrunner
+ paxmark "$paxflags" "$pkgdir"/$_mozappdir/firefox
+ paxmark "$paxflags" "$pkgdir"/$_mozappdir/plugin-container
# launcher as symlink is broken from firefox-7.0
- rm "$pkgdir"/usr/bin/firefox || return 1
+ rm "$pkgdir"/usr/bin/firefox
libgl=$(scanelf -qF '#F%S' /usr/lib/libGL.so)
cat > "$pkgdir"/usr/bin/firefox << __EOF__
#!/bin/sh
@@ -240,29 +223,22 @@ __EOF__
rm -f "$pkgdir"/${_mozappdirdev}/sdk/lib/libxul.so
}
-dev() {
- mkdir -p "$subpkgdir"/${_mozappdirdev%/*}
- mv "$pkgdir"/${_mozappdirdev} "$subpkgdir"/${_mozappdirdev%/*} \
- || return 1
- default_dev
-}
-
-sha512sums="bfca42668ca78a12a9fb56368f4aae5334b1f7a71966fbba4c32b9c5e6597aac79a6e340ac3966779d2d5563eb47c054ab33cc40bfb7306172138ccbd3adb2b9 firefox-52.9.0esr.source.tar.xz
+sha512sums="8119f52b2fc06f76868bf0781fec9d46c8551f0a3ca832ac9bdef6aa6d77c1d785e50d35059f0df5e3586f3396b912af06e448d65e7f5d1f468338eebe8b2cd4 firefox-60.4.0esr.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
-7e123144bc2b1efed149dfb41b255c447d43ea93a63ebe114d01945e6a6d69edc2f2a3c36980a93279106c1842355851b8b6c1d96679ee6be7b9b30513e0b1a8 0002-Use-C99-math-isfinite.patch
+2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
0fcc647af53a3ce21c2bc36e5631eb0935e7243ebb3ab59b5719542cc54a6ac023a4a857b43b75756efb9ed80c0aecaa94dc5679a3b3792f82e87bf2c1af82e1 disable-hunspell_hooks.patch
70863b985427b9653ce5e28d6064f078fb6d4ccf43dd1b68e72f97f44868fc0ce063161c39a4e77a0a1a207b7365d5dc7a7ca5e68c726825eba814f2b93e2f5d fix-seccomp-bpf.patch
a2925045154f4fd34e5fc056656f4f9da100341529e5d4104d249154db0c7863384083f421ce6e47e0f20566a8b20787fa35444c7933c03cd03f96f06dcd4532 fix-toolkit.patch
-7d7531a0dbb1b3c2f4cbf155168e750f274dbf19cd767d6395d479ef1626a651e714b41e353465d9d58239dc15256d83eeb1bf06c6adf47c521a0db5ee88bb50 fix-tools.patch
+b46cb90d4fdd1a925a61e2c6c545489cd542f5d82980c529361c02042eed31d5c26972b5e237c1a020f87ffcfd12736d1f4f6e33eaa83ae156d523c808c718cb fix-tools.patch
bdcd1b402d2ec94957ba5d08cbad7b1a7f59c251c311be9095208491a05abb05a956c79f27908e1f26b54a3679387b2f33a51e945b650671ad85c0a2d59a5a29 mallinfo.patch
-3f535b1e4e9a5a0506ef6f6d9427a84fae1efa3c8e8d6b25b21046d2d04c132bde1a7a98e415067e5c542f699d89249b8cc3d925e0be4e96db498037429691ef musl-pthread-setname.patch
-2a967e4619fd89a046bd40be7fdcef646fcb1eba5e47afc96aa1d59c25bcc8747cb07baee6c11f3b803db0981aced181534b806778e4d21e74958f5f4d74c784 fix-fortify-system-wrappers.patch
ed0d344c66fc8e1cc83a11e9858b32c42e841cbeedd9eb9438811e9fcc3593dc824a8336d00058d55836cedc970aeadd6a82c6dcd7bc0fb746e564d8b478cc6c fix-arm-atomics-grsec.patch
015e1ff6dbf920033982b5df95d869a0b7bf56c6964e45e50649ddf46d1ce09563458e45240c3ecb92808662b1300b67507f7af272ba184835d91068a9e7d5b0 fix-arm-version-detect.patch
e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb18b9e3138273ea8ddcfdcb1084fdcaa922a1e5b30146a3b18 mozilla-build-arm.patch
4797d2d89ac63a57abb826b8ea9f751314ce66946194033deb9d78c2ff377b88106fd2c7bc5034dc13ad03dd5085b1893c3ccae1a9e63fde35655bb0921f7188 disable-moz-stackwalk.patch
-6beba471b6a7fc229a9c105d58137f80cec07219e52bb9a666c787b37ca88635d6ec2eba651eccb5096429c2965709c9475c89839c255c3545f8c96c5d40f403 missing-header-s390x.patch
-fc3fd5a3ad4b83feb9dbe9ecc91d5ae51ce5cd13af481b79910e1e13a79ac6c9b77cf025c14516327391a55172bc13a6f02d9bc7a51eef08fcbbcaaa37845818 discard-x86-precision-musl.patch
+42cc44fda4b05259b38f055d6f51461746aa89a474cedc5e92fb9d20879da0d12b1b515b273a549e7302cda9c7eddde20d5fdba09853e5c658784ad6d0b20078 fix-rust-target.patch
+a50b412edf9573a0bd04a43578b1c927967a616b73a5995eefb15bfa78fd2bd14e36ec05315a0703f6370ecd524e6bcb012e7285beb1245e9add9b8553acb79e fix-bug-1261392.patch
+01b48a708cc6bc6e3cd7cc7b16f5137ec344566ac891d699b65e322bc992726072fa14a54cef1a7775799fcbbcf90a6c170107c8524caba3bc311b42d93b7581 rust-unitialized-field.patch
+75b97d59e81e5f1debe6a459b535da704d5a2ac4a57c446d16058fd18db81e22317fcc3ec11b89f569f4de87e8e80ced027c0e72e7f1dd16f6fd0feb6b263919 fix-webrtc-glibcisms.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/community/firefox-esr/discard-x86-precision-musl.patch b/community/firefox-esr/discard-x86-precision-musl.patch
deleted file mode 100644
index 0a5aa4721d..0000000000
--- a/community/firefox-esr/discard-x86-precision-musl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/js/src/jsnum.cpp
-+++ b/js/src/jsnum.cpp
-@@ -1120,7 +1120,7 @@
- void
- js::FIX_FPU()
- {
--#if (defined __GNUC__ && defined __i386__) || \
-+#if (defined __GLIBC__ && defined __i386__) || \
- (defined __SUNPRO_CC && defined __i386)
- short control;
- asm("fstcw %0" : "=m" (control) : );
diff --git a/community/firefox-esr/fix-bug-1261392.patch b/community/firefox-esr/fix-bug-1261392.patch
new file mode 100644
index 0000000000..1f7a36af3b
--- /dev/null
+++ b/community/firefox-esr/fix-bug-1261392.patch
@@ -0,0 +1,25 @@
+--- a/tools/profiler/core/platform.h 2017-05-27 11:44:06.733119794 +0000
++++ b/tools/profiler/core/platform.h 2017-05-27 11:46:16.004253520 +0000
+@@ -54,10 +54,11 @@
+ #include <vector>
+ #include "StackTop.h"
+
+-// We need a definition of gettid(), but glibc doesn't provide a
+-// wrapper for it.
+-#if defined(__GLIBC__)
++// We need a definition of gettid(), but Linux libc implementations don't
++// provide a wrapper for it (except for Bionic)
++#if defined(__linux__)
+ #include <unistd.h>
++#if !defined(__BIONIC__)
+ #include <sys/syscall.h>
+ static inline pid_t gettid()
+ {
+@@ -71,6 +72,7 @@
+ return (pid_t) syscall(SYS_thread_selfid);
+ }
+ #endif
++#endif
+
+ #ifdef XP_WIN
+ #include <windows.h>
diff --git a/community/firefox-esr/fix-fortify-system-wrappers.patch b/community/firefox-esr/fix-fortify-system-wrappers.patch
index c966f31f9d..17cf7e303d 100644
--- a/community/firefox-esr/fix-fortify-system-wrappers.patch
+++ b/community/firefox-esr/fix-fortify-system-wrappers.patch
@@ -1,13 +1,13 @@
The wrapper features.h gets pulled in by system headers causing thigns to
break. We work around it by simply not wrap features.h
---- ./config/system-headers.orig
-+++ ./config/system-headers
-@@ -422,7 +422,6 @@
- extras.h
- fabdef.h
- fcntl.h
--features.h
- fibdef.h
- File.h
- filehdr.h
+--- ./config/system-headers.mozbuild.orig
++++ ./config/system-headers.mozbuild
+@@ -229,7 +229,6 @@
+ 'execinfo.h',
+ 'extras.h',
+ 'fcntl.h',
+- 'features.h',
+ 'fenv.h',
+ 'ffi.h',
+ 'fibdef.h',
diff --git a/community/firefox-esr/fix-rust-target.patch b/community/firefox-esr/fix-rust-target.patch
new file mode 100644
index 0000000000..7dd760ca1d
--- /dev/null
+++ b/community/firefox-esr/fix-rust-target.patch
@@ -0,0 +1,24 @@
+--- a/build/moz.configure/rust.configure
++++ b/build/moz.configure/rust.configure
+@@ -181,9 +181,11 @@
+ die("Don't know how to translate {} for rustc".format(
+ host_or_target.alias))
+
++ fixed_alias = rustc_target.alias.replace("-unknown-", "-alpine-").replace("-gnu", "-musl")
++
+ # Check to see whether our rustc has a reasonably functional stdlib
+ # for our chosen target.
+- target_arg = '--target=' + rustc_target.alias
++ target_arg = '--target=' + fixed_alias
+ in_fd, in_path = mkstemp(prefix='conftest', suffix='.rs')
+ out_fd, out_path = mkstemp(prefix='conftest', suffix='.rlib')
+ os.close(out_fd)
+@@ -220,7 +222,7 @@
+ os.remove(out_path)
+
+ # This target is usable.
+- return rustc_target.alias
++ return fixed_alias
+
+ return rust_target
+
diff --git a/community/firefox-esr/fix-tools.patch b/community/firefox-esr/fix-tools.patch
index ea5a2cd785..84f7fa9cb8 100644
--- a/community/firefox-esr/fix-tools.patch
+++ b/community/firefox-esr/fix-tools.patch
@@ -1,39 +1,17 @@
-diff --git a/tools/profiler/core/platform-linux.cc b/tools/profiler/core/platform-linux.cc
-index 0df1e8f..d868895 100644
---- a/tools/profiler/core/platform-linux.cc
-+++ b/tools/profiler/core/platform-linux.cc
-@@ -711,11 +711,13 @@ void OS::Startup() {
- void TickSample::PopulateContext(void* aContext)
- {
- MOZ_ASSERT(aContext);
-+#if defined(__GLIBC__)
- ucontext_t* pContext = reinterpret_cast<ucontext_t*>(aContext);
- if (!getcontext(pContext)) {
- context = pContext;
- SetSampleContext(this, aContext);
- }
-+#endif
- }
-
- void OS::SleepMicro(int microseconds)
-diff --git a/tools/profiler/core/platform.h b/tools/profiler/core/platform.h
-index a38b3b5..170bd75 100644
--- a/tools/profiler/core/platform.h
+++ b/tools/profiler/core/platform.h
-@@ -34,6 +34,8 @@
- #define MOZ_COUNT_DTOR(name)
- #endif
-
+@@ -29,6 +29,8 @@
+ #ifndef TOOLS_PLATFORM_H_
+ #define TOOLS_PLATFORM_H_
+
+#include <sys/types.h>
+
- #ifdef ANDROID
- #include <android/log.h>
- #else
-diff --git a/tools/profiler/lul/LulElf.cpp b/tools/profiler/lul/LulElf.cpp
-index a922137..d01dde1 100644
+ #include <stdint.h>
+ #include <math.h>
+ #include "MainThreadUtils.h"
--- a/tools/profiler/lul/LulElf.cpp
+++ b/tools/profiler/lul/LulElf.cpp
-@@ -483,10 +483,10 @@ string FormatIdentifier(unsigned char identifier[16]) {
+@@ -579,10 +579,10 @@
// Return the non-directory portion of FILENAME: the portion after the
// last slash, or the whole filename if there are no slashes.
string BaseFileName(const string &filename) {
@@ -47,4 +25,18 @@ index a922137..d01dde1 100644
+ string base = p ? p+1 : c_filename;
return base;
}
+
+--- a/tools/profiler/core/platform-linux-android.cpp.orig
++++ b/tools/profiler/core/platform-linux-android.cpp
+@@ -534,9 +534,11 @@
+ void
+ Registers::SyncPopulate()
+ {
++#if defined(__GLIBC__)
+ if (!getcontext(&sSyncUContext)) {
+ PopulateRegsFromContext(*this, &sSyncUContext);
+ }
++#endif
+ }
+ #endif
diff --git a/community/firefox-esr/fix-webrtc-glibcisms.patch b/community/firefox-esr/fix-webrtc-glibcisms.patch
new file mode 100644
index 0000000000..dc9206b50e
--- /dev/null
+++ b/community/firefox-esr/fix-webrtc-glibcisms.patch
@@ -0,0 +1,13 @@
+--- ./media/webrtc/trunk/webrtc/system_wrappers/source/cpu_features_linux.c.orig 2018-05-09 23:48:44.677389171 +0200
++++ ./media/webrtc/trunk/webrtc/system_wrappers/source/cpu_features_linux.c 2018-05-09 23:48:56.254373557 +0200
+@@ -11,7 +11,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <features.h>
+-#if __GLIBC_PREREQ(2, 16)
++#if !defined(__GLIBC__)
++#include <sys/auxv.h>
++#elif __GLIBC_PREREQ(2, 16)
+ #include <sys/auxv.h>
+ #else
+ #include <fcntl.h>
diff --git a/community/firefox-esr/missing-header-s390x.patch b/community/firefox-esr/missing-header-s390x.patch
deleted file mode 100644
index 39f4e2bc0d..0000000000
--- a/community/firefox-esr/missing-header-s390x.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/dom/filesystem/compat/FileSystemDirectoryReader.h b/dom/filesystem/compat/FileSystemDirectoryReader.h
-index d568990..12265f9 100644
---- a/dom/filesystem/compat/FileSystemDirectoryReader.h
-+++ b/dom/filesystem/compat/FileSystemDirectoryReader.h
-@@ -11,6 +11,7 @@
- #include "mozilla/ErrorResult.h"
- #include "mozilla/dom/BindingDeclarations.h"
- #include "nsCycleCollectionParticipant.h"
-+#include "mozilla/dom/FileSystemDirectoryEntry.h"
- #include "nsWrapperCache.h"
-
- namespace mozilla {
diff --git a/community/firefox-esr/musl-pthread-setname.patch b/community/firefox-esr/musl-pthread-setname.patch
deleted file mode 100644
index 3bf620219b..0000000000
--- a/community/firefox-esr/musl-pthread-setname.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/js/src/threading/posix/Thread.cpp.orig 2016-09-20 22:19:46.368622126 +0200
-+++ b/js/src/threading/posix/Thread.cpp 2016-09-20 22:23:35.495823534 +0200
-@@ -153,8 +153,10 @@
- rv = 0;
- #elif defined(__NetBSD__)
- rv = pthread_setname_np(pthread_self(), "%s", (void*)name);
--#else
-+#elif defined(__GLIBC__)
- rv = pthread_setname_np(pthread_self(), name);
-+#else
-+ rv = 0;
- #endif
- MOZ_RELEASE_ASSERT(!rv);
- }
diff --git a/community/firefox-esr/rust-unitialized-field.patch b/community/firefox-esr/rust-unitialized-field.patch
new file mode 100644
index 0000000000..67ef3a02ab
--- /dev/null
+++ b/community/firefox-esr/rust-unitialized-field.patch
@@ -0,0 +1,19 @@
+--- ./media/audioipc/audioipc/src/cmsg.rs.orig 2018-05-09 22:19:14.748631939 +0200
++++ ./media/audioipc/audioipc/src/cmsg.rs 2018-05-09 22:19:22.961620862 +0200
+@@ -106,11 +106,11 @@ impl ControlMsgBuilder {
+ return Err(Error::NoSpace);
+ }
+
+- let cmsghdr = cmsghdr {
+- cmsg_len: cmsg_len as _,
+- cmsg_level: level,
+- cmsg_type: kind,
+- };
++ use std::mem;
++ let mut cmsghdr: cmsghdr = unsafe { mem::zeroed() };
++ cmsghdr.cmsg_len = cmsg_len as _;
++ cmsghdr.cmsg_level = level;
++ cmsghdr.cmsg_type = kind;
+
+ let cmsghdr = unsafe {
+ slice::from_raw_parts(&cmsghdr as *const _ as *const _, mem::size_of::<cmsghdr>())