aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-08 12:26:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-08 12:27:28 +0000
commit6103234f35b1554a4ca8f584535e5b05918b31ed (patch)
treea56b2a29e235a2a561a296ab7ca36adeb024d59a /community
parent8600ad8feb1cb96843315aa76e0b2ac0deec0dc4 (diff)
downloadaports-6103234f35b1554a4ca8f584535e5b05918b31ed.tar.bz2
aports-6103234f35b1554a4ca8f584535e5b05918b31ed.tar.xz
community/cunit: add check and minor cleanup
we run default_prepare in prepare
Diffstat (limited to 'community')
-rw-r--r--community/cunit/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/community/cunit/APKBUILD b/community/cunit/APKBUILD
index 7433118af3..902129812e 100644
--- a/community/cunit/APKBUILD
+++ b/community/cunit/APKBUILD
@@ -4,12 +4,11 @@ pkgname=cunit
_pkgname=CUnit
pkgver=2.1.3
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=0
+pkgrel=1
pkgdesc="Automated testing framework for C"
url="http://cunit.sourceforge.net/"
arch="all"
license="GPL2"
-options="!check"
makedepends="automake autoconf libtool bash"
subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
@@ -17,6 +16,7 @@ source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_
builddir="$srcdir/$_pkgname-$_pkgver"
prepare() {
+ default_prepare
cd "$builddir"
libtoolize --force --copy
aclocal
@@ -27,7 +27,6 @@ prepare() {
build() {
cd "$builddir"
- default_prepare
./configure \
--prefix=/usr \
--includedir=/usr/include \
@@ -42,6 +41,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install