aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-11 07:21:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-11 09:54:14 +0000
commit73491742f51e47a7b589ddcca33f7882e44f2df3 (patch)
tree12999650e8bad0f6b951f1b553094dac396644c1 /community
parent14ec1674440a0616b6dcc0eb34df1828bf454c08 (diff)
downloadaports-73491742f51e47a7b589ddcca33f7882e44f2df3.tar.bz2
aports-73491742f51e47a7b589ddcca33f7882e44f2df3.tar.xz
community/faenza-icon-theme: cleanup and fix circular deps
add various subpackages for things we have packages for. drop the -extra subpackage due to many symlinks.
Diffstat (limited to 'community')
-rw-r--r--community/faenza-icon-theme/APKBUILD195
1 files changed, 53 insertions, 142 deletions
diff --git a/community/faenza-icon-theme/APKBUILD b/community/faenza-icon-theme/APKBUILD
index 271364fc05..1d4d92ae1e 100644
--- a/community/faenza-icon-theme/APKBUILD
+++ b/community/faenza-icon-theme/APKBUILD
@@ -1,29 +1,22 @@
-# Contributor:
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=faenza-icon-theme
pkgver=1.3.1
-pkgrel=5
+pkgrel=6
pkgdesc="icons designed to go in tandem with equinox themes"
options="!check" # No testsuite, just icons
arch="noarch"
url="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
license="GPL-3.0-or-later"
-subpackages="$pkgname-extras
-
+subpackages="
$pkgname-abiword
$pkgname-audacious
- $pkgname-audacity
+ $pkgname-bluefish
+ $pkgname-chromium
$pkgname-evince
$pkgname-firefox
$pkgname-geany
- $pkgname-gimp
- $pkgname-glade
$pkgname-gnome-panel:gnome_panel
- $pkgname-gnome-session:gnome_session
- $pkgname-gnumeric
$pkgname-gparted
- $pkgname-hexchat
- $pkgname-imagemagick
$pkgname-inkscape
$pkgname-libreoffice-calc:lo_calc
$pkgname-libreoffice-common:lo_common
@@ -34,17 +27,14 @@ subpackages="$pkgname-extras
$pkgname-libreoffice-writer:lo_writer
$pkgname-libreoffice
$pkgname-midori
- $pkgname-mplayer
- $pkgname-pidgin
$pkgname-shotwell
+ $pkgname-stellarium
$pkgname-thunar
$pkgname-transmission
$pkgname-vim
$pkgname-vlc
$pkgname-wine
- $pkgname-wireshark
$pkgname-xbmc
- $pkgname-xchat
$pkgname-xfce4-appfinder:xfce4_appfinder
$pkgname-xfce4-panel:xfce4_panel
$pkgname-xterm
@@ -54,20 +44,34 @@ subpackages="$pkgname-extras
$pkgname-gvim
$pkgname-filezilla
$pkgname-bash
- $pkgname-thunar
$pkgname-xscreensaver
$pkgname-deadbeef
$pkgname-dia
$pkgname-emacs
- $pkgname-evolution
- $pkgname-hardinfo
$pkgname-thunderbird
- $pkgname-totem
- $pkgname-deluge
$pkgname-ibus
$pkgname-gdm
$pkgname-nautilus
+
+
+ $pkgname-baobab
+ $pkgname-cheese
+ $pkgname-devhelp
+ $pkgname-meld
+ $pkgname-onboard
+ $pkgname-openttd
+ $pkgname-synapse
+ $pkgname-terminator
+ $pkgname-tracker
+ $pkgname-xournal
+ $pkgname-zim
+
+ $pkgname-sound-juicer:sound_juicer
+ $pkgname-deja-dup:deja_dup
+ $pkgname-gnome-documents:gnome_documents
+ $pkgname-gnome-sound-recorder:gnome_sound_recorder
+ $pkgname-gnome-terminal:gnome_terminal
"
@@ -88,6 +92,7 @@ _app() {
shift
pkgdesc="$pkgname - $app"
replaces="$pkgname"
+ depends=
if [ -n "$app" ]; then
install_if="$pkgname=$pkgver-r$pkgrel $app"
else
@@ -102,42 +107,51 @@ _app() {
done
}
+baobab() { _app baobab 'baobab.*'; }
+cheese() { _app cheese 'cheese.*'; }
+deja_dup() { _app deja_dup 'deja-dup.*'; }
+devhelp() { _app devhelp 'devhelp.*'; }
+gnome_documents() { _app gnome_documents 'gnome-documents.*'; }
+gnome_sound_recorder() { _app gnome_sound_recorder 'gnome-sound-recorder.*'; }
+gnome_terminal() { _app gnome_terminal 'gnome-terminal.*'; }
+meld() { _app meld 'meld.*'; }
+onboard() { _app onboard 'onboard.*'; }
+openttd() { _app openttd 'openttd.*'; }
+sound_juicer() { _app sound_juicer 'sound-juicer.*'; }
+synapse() { _app synapse 'synapse.*'; }
+terminator() { _app terminator 'terminator.*'; }
+tracker() { _app tracker 'tracker.*'; }
+xournal() { _app xournal 'xournal.*'; }
+zim() { _app zim 'zim.*'; }
+
abiword() { _app abiword 'abiword*'; }
audacious() { _app audacious 'audacious*'; }
-audacity() { _app audacity 'audacity*'; }
+bluefish() { _app bluefish 'bluefish*'; }
+chromium() { _app chromium 'chromium*' 'google-chrome*' ; }
evince() { _app evince 'evince*'; }
firefox() { _app firefox '*firefox*'; }
geany() { _app geany 'geany*'; }
-gimp() { _app gimp 'gimp*'; }
-glade() { _app glade 'glade*'; }
-gnome_panel() { _app gnome-panel 'gnome-panel*'; }
-gnome_session() { _app gnome-session 'gnome-session*'; }
-gnumeric() { _app gnumeric 'gnumeric*'; }
+gnome_panel() { _app gnome-panel 'gnome-panel.*'; }
gparted() { _app gparted 'gparted*'; }
-hexchat() { depends="$pkgname-xchat"; _app hexchat 'hexchat*'; }
-imagemagick() { _app imagemagick 'imagemagick*'; }
inkscape() { _app inkscape 'inkscape*'; }
-lo_base() { _app libreoffice-base 'libreoffice*-base*'; }
+lo_base() { _app libreoffice-base 'libreoffice*-base*'; }
lo_calc() { _app libreoffice-calc 'libreoffice*-calc*'; }
lo_common() { _app libreoffice-common 'libreoffice*-startcenter*'; }
lo_draw() { _app libreoffice-draw 'libreoffice*-draw*'; }
lo_impress() { _app libreoffice-impress 'libreoffice*-impress*'; }
lo_main() { _app libreoffice-main 'libreoffice*-main*'; }
lo_math() { _app libreoffice-math 'libreoffice*-math*'; }
-lo_writer() { _app libreoffice-writer 'libreoffice*-writer*'; }
-libreoffice() { _app libreoffice 'libreoffice*'; }
+lo_writer() { _app libreoffice-writer 'libreoffice*-writer*' 'ooo-writer*' 'office-writer.*'; }
+libreoffice() { _app libreoffice 'libreoffice*' 'openoffice*' 'ooo*'; }
midori() { _app midori 'midori*'; }
-mplayer() { _app mplayer 'mplayer*'; }
-pidgin() { _app pidgin 'pidgin*'; }
shotwell() { _app shotwell 'shotwell*'; }
-thunar() { _app thunar 'thunar*'; }
+stellarium() { _app stellarium 'stellarium*'; }
+thunar() { _app thunar 'thunar.*' 'Thunar.*'; }
transmission() { _app transmission 'transmission*'; }
vim() { _app vim 'vim*'; }
vlc() { _app vlc 'vlc*'; }
wine() { _app wine '*wine*'; }
-wireshark() { _app wireshark 'wireshark*'; }
xbmc() { _app xbmc 'xbmc*'; }
-xchat() { _app xchat 'xchat*'; }
xfce4_appfinder() { _app xfce4-appfinder 'xfce4-appfinder*'; }
xfce4_panel() { _app xfce4-panel 'xfce4-panel*'; }
xterm() { _app xterm 'xterm*'; }
@@ -147,118 +161,15 @@ xarchiver() { _app xarchiver 'xarchiver*'; }
gvim() { _app gvim 'gvim*'; }
filezilla() { _app filezilla 'filezilla*'; }
bash() { _app bash 'bash*'; }
-thunar() { _app thunar 'Thunar*'; }
xscreensaver() { _app xscreensaver 'xscreensaver*'; }
# testing
deadbeef() { _app deadbeef 'deadbeef*'; }
-dia() { _app dia 'dia*'; }
+dia() { _app dia 'dia.*'; }
emacs() { _app emacs 'emacs*'; }
-evolution() { _app evolution '*evolution*'; }
-hardinfo() { _app hardinfo 'hardinfo*'; }
thunderbird() { _app thunderbird '*thunderbird*'; }
-totem() { _app totem 'totem*'; }
-deluge() { _app deluge 'deluge*'; }
ibus() { _app ibus 'ibus*'; }
-gdm() { _app gdm 'gdm*'; }
+gdm() { _app gdm 'gdm.*'; }
nautilus() { _app nautilus 'nautilus*'; }
-
-#unsupported apps
-extras() { _app "" \
- '*adobe*' \
- '*chess*' \
- '*crom*' \
- '*ubuntu*' \
- 'WorldOfGoo*' \
- 'amue*' \
- 'blender*' \
- 'bluefish*' \
- 'bluegriffon' \
- 'brasero*' \
- 'bug-buddy*' \
- 'chromium-browser' \
- 'clementine*' \
- 'comix' \
- 'computerjanitor*' \
- 'desura*' \
- 'docky*' \
- 'dropbox*' \
- 'eclipse*' \
- 'emesene' \
- 'emsene*' \
- 'eog.*' \
- 'exaile*' \
- 'f-spot*' \
- 'fedora*' \
- 'filezilla' \
- 'frostwire*' \
- 'gajim*' \
- 'gbrainy*' \
- 'gcstar*' \
- 'glippy*' \
- 'gnome-activity' \
- 'gnome-aisleriot' \
- 'gnome-do*' \
- 'gnome-freecell' \
- 'gnome-glines' \
- 'gnome-gnect*' \
- 'gnome-gnibbles' \
- 'gnome-iagno' \
- 'gnome-klotski' \
- 'gnome-lightsoff' \
- 'gnome-mahjong*' \
- 'gnome-mines*' \
- 'gnome-mines*' \
- 'gnome-quadrapassel' \
- 'gnome-robots' \
- 'gnome-samegnome' \
- 'gnome-sudoku' \
- 'gnome-swell-foop' \
- 'gnome-tali*' \
- 'gnome-tetravex' \
- 'google-chrome' \
- 'googleearth*' \
- 'guayadeque*' \
- 'gwibber*' \
- 'haguichi*' \
- 'homebank*' \
- 'icedove' \
- 'iceweasel' \
- 'jdownloader' \
- 'jockey*' \
- 'library-internet-radio' \
- 'logviewer' \
- 'miro*' \
- 'mono*' \
- 'mypaint*' \
- 'netbeans*' \
- 'nvidia-settings*' \
- 'ooo-*' \
- 'ooo-*' \
- 'openttd*' \
- 'opera*' \
- 'picasa*' \
- 'pino*' \
- 'pithos*' \
- 'pitivi*' \
- 'ppa.*' \
- 'rhythmbox' \
- 'rythmbox*' \
- 'shutter*' \
- 'skype*' \
- 'softwarecenter-debian' \
- 'spotify*' \
- 'steam*' \
- 'stellarium*' \
- 'synapse*' \
- 'telepathy*' \
- 'tomboy*' \
- 'tvtime*' \
- 'wxbanker*' \
- 'xine' \
- 'xournal*' \
-
-}
-
sha512sums="0c017ddbaa2dba485341d3bb1e321fafad026aafc893fa2519ddfd3fe0475fc8d011c99ce3de581c9b1c6aa7d250312673dda7c10bb12783db2d45816646ddc9 faenza-icon-theme_1.3.1.tar.gz"