aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-11 16:27:26 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-11 23:58:47 +0000
commitceb9222c82b26adc4123f2b2506bc70286a05d71 (patch)
treee44c019b9000cdd38168da1922dfadbb032619ea /community
parent8d12b418117b217dd7856cac7b1e18bb892cf6af (diff)
downloadaports-ceb9222c82b26adc4123f2b2506bc70286a05d71.tar.bz2
aports-ceb9222c82b26adc4123f2b2506bc70286a05d71.tar.xz
community/plasma-workspace: apply patch to fix performance regression
Diffstat (limited to 'community')
-rw-r--r--community/plasma-workspace/APKBUILD9
-rw-r--r--community/plasma-workspace/D28238.patch95
2 files changed, 101 insertions, 3 deletions
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
index fc53af4739..0cf6dfecf2 100644
--- a/community/plasma-workspace/APKBUILD
+++ b/community/plasma-workspace/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace
pkgver=5.18.5
-pkgrel=0
+pkgrel=1
pkgdesc="KDE Plasma Workspace"
arch="all !armhf" # armhf blocked by kirigami2 -> qt5-qtdeclarative
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -11,7 +11,9 @@ depends="tzdata qt5-qtquickcontrols kirigami2 kinit qt5-qttools kwin kactivityma
depends_dev="plasma-framework-dev krunner-dev kjsembed-dev knotifyconfig-dev kdesu-dev knewstuff-dev kwallet-dev kidletime-dev kdeclarative-dev ki18n-dev kcmutils-dev ktextwidgets-dev kdelibs4support-dev kcrash-dev kglobalaccel-dev kdbusaddons-dev kwayland-dev kcoreaddons-dev kded-dev libksysguard-dev kpackage-dev kscreenlocker-dev phonon-dev zlib-dev kitemmodels-dev networkmanager-qt-dev baloo-dev ktexteditor-dev kwin-dev kholidays-dev prison-dev kpeople-dev kactivities-stats-dev libkscreen-dev gpsd-dev iso-codes-dev"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev libxtst-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
+ D28238.patch
+ "
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
build() {
@@ -32,4 +34,5 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="870cf89649d9498831f4ef9b21d3c07504b7fc7b09b95dd7e0a1d356b41fbfceed1c4f27aa258bcf1e23cfe915d31701c155325fcd4944f9cc957a287ebc1ee2 plasma-workspace-5.18.5.tar.xz"
+sha512sums="870cf89649d9498831f4ef9b21d3c07504b7fc7b09b95dd7e0a1d356b41fbfceed1c4f27aa258bcf1e23cfe915d31701c155325fcd4944f9cc957a287ebc1ee2 plasma-workspace-5.18.5.tar.xz
+ff73e9534e92a9df5ce9339aea8ba27104da2255d1425f9ab29d2a969f780cd8c007a2374cc679794cc524b572c865ccc569e758821bece2bb2e4ea961582efc D28238.patch"
diff --git a/community/plasma-workspace/D28238.patch b/community/plasma-workspace/D28238.patch
new file mode 100644
index 0000000000..67a2ee73ab
--- /dev/null
+++ b/community/plasma-workspace/D28238.patch
@@ -0,0 +1,95 @@
+Suggested by upstream to apply this when using KDE Frameworks 5.70 and
+Plasma 5.18 to improve performance. It's in master already and will be
+unnecessary when Plasma 5.19 is released.
+
+From 2958702524348e9e4fcbdf490be731e92b353dad Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Tue, 24 Mar 2020 08:10:54 -0600
+Subject: [PATCH] Stop multiplying duration values
+
+Summary:
+After D28144, some animations are now too long because they were inappropriately
+multiplying a duration value. That's no longer necessary, so let's remove the
+multiplication.
+
+Depends on D28144
+
+Test Plan: Various things that were a bit too slow before feel just right now
+
+Reviewers: #vdg, #plasma, cblack
+
+Reviewed By: #vdg, #plasma, cblack
+
+Subscribers: cblack, plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D28238
+---
+ .../devicenotifier/package/contents/ui/FullRepresentation.qml | 2 +-
+ applets/systemtray/package/contents/ui/ExpanderArrow.qml | 2 +-
+ lookandfeel/contents/components/ActionButton.qml | 4 ++--
+ lookandfeel/contents/components/UserDelegate.qml | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/applets/devicenotifier/package/contents/ui/FullRepresentation.qml b/applets/devicenotifier/package/contents/ui/FullRepresentation.qml
+index d15e47ca7..80b9c73cd 100644
+--- a/applets/devicenotifier/package/contents/ui/FullRepresentation.qml
++++ b/applets/devicenotifier/package/contents/ui/FullRepresentation.qml
+@@ -225,7 +225,7 @@ MouseArea {
+ popupIconTimer.restart()
+ }
+ }
+- Behavior on height { NumberAnimation { duration: units.shortDuration * 3 } }
++ Behavior on height { NumberAnimation { duration: units.shortDuration } }
+ }
+ }
+ }
+diff --git a/applets/systemtray/package/contents/ui/ExpanderArrow.qml b/applets/systemtray/package/contents/ui/ExpanderArrow.qml
+index 9baf654b0..729f56b23 100644
+--- a/applets/systemtray/package/contents/ui/ExpanderArrow.qml
++++ b/applets/systemtray/package/contents/ui/ExpanderArrow.qml
+@@ -37,7 +37,7 @@ PlasmaCore.ToolTipArea {
+ anchors.fill: parent
+ onClicked: root.expanded = !root.expanded
+
+- readonly property int arrowAnimationDuration: units.shortDuration * 3
++ readonly property int arrowAnimationDuration: units.shortDuration
+
+ PlasmaCore.Svg {
+ id: arrowSvg
+diff --git a/lookandfeel/contents/components/ActionButton.qml b/lookandfeel/contents/components/ActionButton.qml
+index 9fbd2a8ab..7a66c5642 100644
+--- a/lookandfeel/contents/components/ActionButton.qml
++++ b/lookandfeel/contents/components/ActionButton.qml
+@@ -44,7 +44,7 @@ Item {
+ opacity: activeFocus || containsMouse ? 1 : 0.85
+ Behavior on opacity {
+ PropertyAnimation { // OpacityAnimator makes it turn black at random intervals
+- duration: units.longDuration * 2
++ duration: units.longDuration
+ easing.type: Easing.InOutQuad
+ }
+ }
+@@ -59,7 +59,7 @@ Item {
+ opacity: activeFocus || containsMouse ? (softwareRendering ? 0.8 : 0.15) : (softwareRendering ? 0.6 : 0)
+ Behavior on opacity {
+ PropertyAnimation { // OpacityAnimator makes it turn black at random intervals
+- duration: units.longDuration * 3
++ duration: units.longDuration
+ easing.type: Easing.InOutQuad
+ }
+ }
+diff --git a/lookandfeel/contents/components/UserDelegate.qml b/lookandfeel/contents/components/UserDelegate.qml
+index 8882e39ae..cdb55f1a7 100644
+--- a/lookandfeel/contents/components/UserDelegate.qml
++++ b/lookandfeel/contents/components/UserDelegate.qml
+@@ -72,7 +72,7 @@ Item {
+ Behavior on width {
+ PropertyAnimation {
+ from: faceSize
+- duration: units.longDuration * 2;
++ duration: units.longDuration;
+ }
+ }
+ width: isCurrent ? faceSize : faceSize - units.largeSpacing