aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-27 06:14:33 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-27 06:14:38 +0000
commite49e7679fffea4ecf72113cbb0a0c3ecefcb9bee (patch)
tree7d473ae25bf077f20c238ca2337836fb79eaf283 /community
parentf9ba77b41956e34168c23da8fbdca7333bd57982 (diff)
downloadaports-e49e7679fffea4ecf72113cbb0a0c3ecefcb9bee.tar.bz2
aports-e49e7679fffea4ecf72113cbb0a0c3ecefcb9bee.tar.xz
community/py-pbr: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/py-pbr/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py-pbr/APKBUILD b/community/py-pbr/APKBUILD
new file mode 100644
index 0000000000..5a7c380030
--- /dev/null
+++ b/community/py-pbr/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-pbr
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="Python Build Reasonableness"
+url="https://pypi.python.org/pypi/pbr"
+arch="noarch"
+license="APACHE2.0"
+depends="python"
+depends_dev=""
+makedepends="$depends_dev python-dev py-setuptools"
+install=""
+subpackages="$pkgname-dev"
+source="https://pypi.python.org/packages/c3/2c/63275fab26a0fd8cadafca71a3623e4d0f0ee8ed7124a5bb128853d178a7/${pkgname/py-/}-$pkgver.tar.gz"
+
+builddir="$srcdir"/${pkgname/py-/}-$pkgver
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8e4968c587268f030e38329feb9c8f17 pbr-1.10.0.tar.gz"
+sha256sums="186428c270309e6fdfe2d5ab0949ab21ae5f7dea831eab96701b86bd666af39c pbr-1.10.0.tar.gz"
+sha512sums="f7f6ce2f70324e2d287f58c3d12e0be2e33ef9ed32311ad2c56410eb67cda20732adff2058ba2fc244249a17a4c95b0d589ba913db4777e63ff1023ae888c864 pbr-1.10.0.tar.gz"