aboutsummaryrefslogtreecommitdiffstats
path: root/core/linux-grsec-sources/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-16 18:55:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-16 18:55:25 +0000
commite0bb26315a4ac2199c791e310c1fdace1929e556 (patch)
treedee163f88ab3614550d3c928e56063cf53ddb576 /core/linux-grsec-sources/APKBUILD
parent89a4e424fd4a1abec4e65a08d4f7cd48dd1acaef (diff)
downloadaports-e0bb26315a4ac2199c791e310c1fdace1929e556.tar.bz2
aports-e0bb26315a4ac2199c791e310c1fdace1929e556.tar.xz
core/linux-grsec-sources: upgrade to 2.6.28.5
Diffstat (limited to 'core/linux-grsec-sources/APKBUILD')
-rw-r--r--core/linux-grsec-sources/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/core/linux-grsec-sources/APKBUILD b/core/linux-grsec-sources/APKBUILD
index 761407cee6..b91bbf8e1b 100644
--- a/core/linux-grsec-sources/APKBUILD
+++ b/core/linux-grsec-sources/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_suff=grsec
pkgname=linux-$_suff-sources
-pkgver=2.6.26.8
+pkgver=2.6.28.5
pkgdesc="Linux kernel sources with grsecurity patch"
-_kernver=2.6.26
-_grsecver=2.1.12-2.6.26.6-200810131006
+_kernver=2.6.28
+_grsecver=2.1.12-$_kernver.5-200902121552
pkgrel=2
options="!strip"
license=GPL-2
@@ -12,7 +12,8 @@ url=http://kernel.org
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
http://www.grsecurity.net/test/grsecurity-$_grsecver.patch
- linux-2.6.26.8-ipgre-strict-binding.diff
+ 0001-linux-2.6.28.5-ipgre-strict-binding.patch
+ 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch
"
build() {
@@ -21,15 +22,18 @@ build() {
bunzip2 -c < ../patch-$pkgver.bz2 | patch -p1 || return 1
fi
- patch -p1 < ../grsecurity-$_grsecver.patch || return 1
- patch -p1 < ../linux-2.6.26.8-ipgre-strict-binding.diff || return 1
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
mkdir -p "$pkgdir/usr/src"
cd "$srcdir"
mv "linux-$_kernver" "$pkgdir/usr/src/linux-$pkgver-$_suff"
}
-md5sums="5169d01c405bc3f866c59338e217968c linux-2.6.26.tar.bz2
-e27c07bb82e02532e874758980141281 patch-2.6.26.8.bz2
-5398417243c0abbcd8d94f5e52eff4bc grsecurity-2.1.12-2.6.26.6-200810131006.patch
-b83b352e8718c5c60accfb562482727f linux-2.6.26.8-ipgre-strict-binding.diff"
+md5sums="d351e44709c9810b85e29b877f50968a linux-2.6.28.tar.bz2
+7a062fcdec46cec78c3fedbf558e334b patch-2.6.28.5.bz2
+0ff9cf5f9c43797d30a0c90feea94e1e grsecurity-2.1.12-2.6.28.5-200902121552.patch
+7673b4521283ad41434a18ca18b16ad8 0001-linux-2.6.28.5-ipgre-strict-binding.patch
+8f405c738b150c532c46eaad5390cca2 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch"