aboutsummaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-04 15:10:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-04 15:10:48 +0000
commit15609c6abbdbdc803e1a05b3075c5482e5971b90 (patch)
tree9e4412df476498cd94808be95a94a80709c77718 /core
parent4c2463edc44e4ce25d54d33e6b86dc78e43dc676 (diff)
downloadaports-15609c6abbdbdc803e1a05b3075c5482e5971b90.tar.bz2
aports-15609c6abbdbdc803e1a05b3075c5482e5971b90.tar.xz
core/mkinitfs: fix for encrypted apkovls
should fix #40
Diffstat (limited to 'core')
-rw-r--r--core/mkinitfs/APKBUILD10
-rw-r--r--core/mkinitfs/init.patch39
2 files changed, 46 insertions, 3 deletions
diff --git a/core/mkinitfs/APKBUILD b/core/mkinitfs/APKBUILD
index f4a37223fe..bc79fc1411 100644
--- a/core/mkinitfs/APKBUILD
+++ b/core/mkinitfs/APKBUILD
@@ -1,16 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
pkgver=1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
depends="busybox"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ init.patch
+ "
license="GPL-2"
build() {
cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 < ../init.patch
make
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="0a7eefb454fc96763983048ee60a1bcd mkinitfs-1.5.tar.bz2"
+md5sums="0a7eefb454fc96763983048ee60a1bcd mkinitfs-1.5.tar.bz2
+deb3fa8e83c877e72e6b3b420cef3864 init.patch"
diff --git a/core/mkinitfs/init.patch b/core/mkinitfs/init.patch
new file mode 100644
index 0000000000..6f2c367eff
--- /dev/null
+++ b/core/mkinitfs/init.patch
@@ -0,0 +1,39 @@
+commit db606b4b4861076524232f52002411dc900a03ad
+Author: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu Jun 4 14:56:28 2009 +0000
+
+ init: unpack uclibc when dealing with encrypted apkovls
+
+ openssl needs libdl which is not there by default.
+
+diff --git a/initramfs-init.in b/initramfs-init.in
+index f8827a0..ae82e8a 100755
+--- a/initramfs-init.in
++++ b/initramfs-init.in
+@@ -66,6 +66,14 @@ retry_mount() {
+ return 1
+ }
+
++unpack_apk() {
++ local i
++ for i in $ALPINE_MNT/*/*/$1-[0-9]*.apk $ALPINE_MNT/*/$1-[0-9]*.apk; do
++ [ -f "$i" ] && tar --numeric-owner -C / -zxf $i && return 0
++ done
++ return 1
++}
++
+ unpack_apkovl() {
+ local ovl="$1"
+ local dest="$2"
+@@ -76,9 +84,8 @@ unpack_apkovl() {
+ return $?
+ fi
+
+- for i in $ALPINE_MNT/*/*/openssl-[0-9]*.apk $ALPINE_MNT/*/openssl-[0-9]*.apk; do
+- [ -f "$i" ] && tar --numeric-owner -C / -zxf $i && break
+- done
++ unpack_apk uclibc
++ unpack_apk openssl
+
+ if ! openssl list-cipher-commands | grep "^$suffix$" > /dev/null; then
+ errstr="Cipher $suffix is not supported"