aboutsummaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-09 15:16:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-09 15:16:39 +0000
commit49f63058d0859dd4a91aad9d98618e343b2c7382 (patch)
tree3bdac3bc2dd9a89de0f805f24d3001bb7f048572 /core
parente8a019ffbe9e37c96b88d9333d94634e13941a0a (diff)
downloadaports-49f63058d0859dd4a91aad9d98618e343b2c7382.tar.bz2
aports-49f63058d0859dd4a91aad9d98618e343b2c7382.tar.xz
core/beecrypt: add base64 patch, use uclibc++
TODO: we probably dont need to link to uclibc++ at all, but if we dont, it seems like the .so is not created at all. wierdo.
Diffstat (limited to 'core')
-rw-r--r--core/beecrypt/APKBUILD22
-rw-r--r--core/beecrypt/beecrypt-4.1.2-base64.patch11
2 files changed, 29 insertions, 4 deletions
diff --git a/core/beecrypt/APKBUILD b/core/beecrypt/APKBUILD
index 77f0b2a071..b11cba439f 100644
--- a/core/beecrypt/APKBUILD
+++ b/core/beecrypt/APKBUILD
@@ -2,24 +2,38 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=beecrypt
pkgver=4.1.2
+pkgrel=1
pkgdesc="general-purpose cryptography library"
url="http://sourceforge.net/projects/beecrypt"
license="LGPL"
-depends=uclibc
+# TODO: figure out why we link libgcc_s.so.1 and do something about gcc dep
+depends="uclibc uclibc++ gcc"
+makedepends="uclibc++-dev libtool"
+
subpackages="$pkgname-dev"
-source=http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-4.1.2-base64.patch
+ "
build() {
cd "$srcdir/$pkgname-$pkgver"
+ export CXX=g++-uc
+
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-threads \
--enable-shared \
--without-java \
--without-python \
- --without-cplusplus
+ --with-cplusplus=no
make || return 1
make DESTDIR="$pkgdir" install
}
-md5sums="820d26437843ab0a6a8a5151a73a657c beecrypt-4.1.2.tar.gz"
+md5sums="820d26437843ab0a6a8a5151a73a657c beecrypt-4.1.2.tar.gz
+01444edbffee71c2d8818fa66a3a8555 beecrypt-4.1.2-base64.patch"
diff --git a/core/beecrypt/beecrypt-4.1.2-base64.patch b/core/beecrypt/beecrypt-4.1.2-base64.patch
new file mode 100644
index 0000000000..c6c370bd07
--- /dev/null
+++ b/core/beecrypt/beecrypt-4.1.2-base64.patch
@@ -0,0 +1,11 @@
+Fix b64encode() for data starting with NUL from Miloslav Trmac <mitr@redhat.com>
+--- beecrypt-4.1.2/base64.c.b64 2005-04-26 21:46:27.000000000 +0200
++++ beecrypt-4.1.2/base64.c 2005-04-26 21:47:48.000000000 +0200
+@@ -253,7 +253,6 @@
+ unsigned c;
+
+ if (s == NULL) return NULL;
+- if (*s == '\0') return calloc(1, sizeof(*t));
+
+ if (ns == 0) ns = strlen((const char*) s);
+ nt = ((ns + 2) / 3) * 4;