aboutsummaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-10 17:16:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-10 17:16:20 +0000
commit7806751fc7ef00084bbdeefcd16e44615da7b729 (patch)
treebbcb61bc0d2f721a4cf31c7d61517b4e86db9334 /core
parent395062945635ba0551f36dc674ca4149a5532ccf (diff)
downloadaports-7806751fc7ef00084bbdeefcd16e44615da7b729.tar.bz2
aports-7806751fc7ef00084bbdeefcd16e44615da7b729.tar.xz
core/git: new aport
Diffstat (limited to 'core')
-rw-r--r--core/git/APKBUILD37
-rw-r--r--core/git/bb-tar.patch8
-rw-r--r--core/git/git-1.6.0.4-noperl.patch125
3 files changed, 170 insertions, 0 deletions
diff --git a/core/git/APKBUILD b/core/git/APKBUILD
new file mode 100644
index 0000000000..d506d0ed6c
--- /dev/null
+++ b/core/git/APKBUILD
@@ -0,0 +1,37 @@
+pkgname=git
+pkgver=1.6.0.4
+pkgrel=1
+pkgdesc="GIT - the stupid content tracker"
+url="http://git.or.cz/"
+license="GPL2"
+depends="zlib"
+makedepends=zlib-dev
+source="http://kernel.org/pub/software/scm/git/git-1.6.0.4.tar.bz2
+ http://kernel.org/pub/software/scm/git/git-manpages-1.6.0.4.tar.bz2
+ git-1.6.0.4-noperl.patch
+ bb-tar.patch
+ "
+
+build ()
+{
+ local makeopts="NO_ICONV=YesPlease
+ NO_CURL=YesPlease
+ NO_TCLTK=YesPlease
+ NO_PERL=YesPlease
+ NO_SVN_TESTS=YesPlease"
+
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../git-1.6.0.4-noperl.patch || return 1
+ patch -p1 < ../bb-tar.patch || return 1
+
+ make prefix=/usr DESTDIR="$pkgdir" $makeopts || return 1
+ make prefix=/usr DESTDIR="$pkgdir" $makeopts install
+
+}
+md5sums="ed8c4fa007a44d51b646865c35461ce8 git-1.6.0.4.tar.bz2
+7893d3b12809c36a6129e9bdbfb3afde git-manpages-1.6.0.4.tar.bz2
+89fe31c2317c285ed18527a700da7844 git-1.6.0.4-noperl.patch"
+md5sums="ed8c4fa007a44d51b646865c35461ce8 git-1.6.0.4.tar.bz2
+7893d3b12809c36a6129e9bdbfb3afde git-manpages-1.6.0.4.tar.bz2
+89fe31c2317c285ed18527a700da7844 git-1.6.0.4-noperl.patch
+04e1bdf76a0bac568f8488daad07dce7 bb-tar.patch"
diff --git a/core/git/bb-tar.patch b/core/git/bb-tar.patch
new file mode 100644
index 0000000000..0f15de5d25
--- /dev/null
+++ b/core/git/bb-tar.patch
@@ -0,0 +1,8 @@
+--- git-1.6.0.4/templates/Makefile.orig Mon Nov 10 17:10:51 2008
++++ git-1.6.0.4/templates/Makefile Mon Nov 10 17:11:25 2008
+@@ -50,4 +50,4 @@
+ install: all
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(template_instdir_SQ)'
+ (cd blt && $(TAR) cf - .) | \
+- (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) xfo -)
++ (cd '$(DESTDIR_SQ)$(template_instdir_SQ)' && umask 022 && $(TAR) x)
diff --git a/core/git/git-1.6.0.4-noperl.patch b/core/git/git-1.6.0.4-noperl.patch
new file mode 100644
index 0000000000..47d8302d8e
--- /dev/null
+++ b/core/git/git-1.6.0.4-noperl.patch
@@ -0,0 +1,125 @@
+--- git-1.6.0.4.orig/Makefile Mon Nov 10 17:03:54 2008
++++ git-1.6.0.4/Makefile Mon Nov 10 17:04:04 2008
+@@ -130,6 +130,8 @@
+ #
+ # Define NO_PERL_MAKEMAKER if you cannot use Makefiles generated by perl's
+ # MakeMaker (e.g. using ActiveState under Cygwin).
++
++# Define NO_PERL if you do not want Perl scripts at all.
+ #
+ # Define NO_TCLTK if you do not want Tcl/Tk GUI.
+ #
+@@ -263,6 +265,8 @@
+ SCRIPT_SH += git-submodule.sh
+ SCRIPT_SH += git-web--browse.sh
+
++SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH))
++ifndef NO_PERL
+ SCRIPT_PERL += git-add--interactive.perl
+ SCRIPT_PERL += git-archimport.perl
+ SCRIPT_PERL += git-cvsexportcommit.perl
+@@ -271,11 +275,12 @@
+ SCRIPT_PERL += git-relink.perl
+ SCRIPT_PERL += git-send-email.perl
+ SCRIPT_PERL += git-svn.perl
++SCRIPTS += $(patsubst %.perl,%,$(SCRIPT_PERL)) \
++ git-instaweb
++else
++SCRIPT_PERL =
++endif
+
+-SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH)) \
+- $(patsubst %.perl,%,$(SCRIPT_PERL)) \
+- git-instaweb
+-
+ # Empty...
+ EXTRA_PROGRAMS =
+
+@@ -320,7 +325,10 @@
+ ALL_PROGRAMS = $(PROGRAMS) $(SCRIPTS)
+
+ # what 'all' will build but not install in gitexecdir
+-OTHER_PROGRAMS = git$X gitweb/gitweb.cgi
++OTHER_PROGRAMS = git$X
++ifndef NO_PERL
++OTHER_PROGRAMS += gitweb/gitweb.cgi
++endif
+
+ # Set paths to tools early so that they can be used for version tests.
+ ifndef SHELL_PATH
+@@ -820,6 +828,10 @@
+ endif
+ endif
+
++ifdef NO_PERL
++ BASIC_CFLAGS += -DNO_PERL
++endif
++
+ ifdef ZLIB_PATH
+ BASIC_CFLAGS += -I$(ZLIB_PATH)/include
+ EXTLIBS += -L$(ZLIB_PATH)/$(lib) $(CC_LD_DYNPATH)$(ZLIB_PATH)/$(lib)
+@@ -1005,6 +1017,11 @@
+ ifeq ($(TCLTK_PATH),)
+ NO_TCLTK=NoThanks
+ endif
++ifeq ($(PERL_PATH),)
++NO_PERL=NoThanks
++export NO_PERL
++export NO_PERL_MAKEMAKER
++endif
+
+ QUIET_SUBDIR0 = +$(MAKE) -C # space to separate -C and subdir
+ QUIET_SUBDIR1 =
+@@ -1079,7 +1096,9 @@
+ $(QUIET_SUBDIR0)git-gui $(QUIET_SUBDIR1) gitexecdir='$(gitexec_instdir_SQ)' all
+ $(QUIET_SUBDIR0)gitk-git $(QUIET_SUBDIR1) all
+ endif
++ifndef NO_PERL
+ $(QUIET_SUBDIR0)perl $(QUIET_SUBDIR1) PERL_PATH='$(PERL_PATH_SQ)' prefix='$(prefix_SQ)' all
++endif
+ $(QUIET_SUBDIR0)templates $(QUIET_SUBDIR1)
+
+ please_set_SHELL_PATH_to_a_more_modern_shell:
+@@ -1126,6 +1145,7 @@
+ chmod +x $@+ && \
+ mv $@+ $@
+
++ifndef NO_PERL
+ $(patsubst %.perl,%,$(SCRIPT_PERL)): perl/perl.mak
+
+ perl/perl.mak: GIT-CFLAGS perl/Makefile perl/Makefile.PL
+@@ -1185,6 +1205,7 @@
+ $@.sh > $@+ && \
+ chmod +x $@+ && \
+ mv $@+ $@
++endif # NO_PERL
+
+ configure: configure.ac
+ $(QUIET_GEN)$(RM) $@ $<+ && \
+@@ -1355,9 +1376,12 @@
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(gitexec_instdir_SQ)'
+ $(INSTALL) $(ALL_PROGRAMS) '$(DESTDIR_SQ)$(gitexec_instdir_SQ)'
+- $(INSTALL) git$X git-upload-pack$X git-receive-pack$X git-upload-archive$X git-shell$X git-cvsserver '$(DESTDIR_SQ)$(bindir_SQ)'
++ $(INSTALL) git$X git-upload-pack$X git-receive-pack$X git-upload-archive$X git-shell$X '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(MAKE) -C templates DESTDIR='$(DESTDIR_SQ)' install
++ifndef NO_PERL
++ $(INSTALL) git-cvsserver '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(MAKE) -C perl prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install
++endif
+ ifndef NO_TCLTK
+ $(MAKE) -C gitk-git install
+ $(MAKE) -C git-gui gitexecdir='$(gitexec_instdir_SQ)' install
+@@ -1451,9 +1475,11 @@
+ $(RM) -r $(GIT_TARNAME) .doc-tmp-dir
+ $(RM) $(GIT_TARNAME).tar.gz git-core_$(GIT_VERSION)-*.tar.gz
+ $(RM) $(htmldocs).tar.gz $(manpages).tar.gz
+- $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C Documentation/ clean
++ifndef NO_PERL
++ $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C perl clean
++endif
+ $(MAKE) -C templates/ clean
+ $(MAKE) -C t/ clean
+ ifndef NO_TCLTK