aboutsummaryrefslogtreecommitdiffstats
path: root/extra/ccache
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-19 19:49:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-19 19:49:32 +0000
commit60d89f07d8d51c684821063ca41fe55b4b733a64 (patch)
treee3ea597cac3266960080888551cca053c1bfe589 /extra/ccache
parent774761fbeb5d3d3ea72229e11415302c06517076 (diff)
downloadaports-60d89f07d8d51c684821063ca41fe55b4b733a64.tar.bz2
aports-60d89f07d8d51c684821063ca41fe55b4b733a64.tar.xz
extra/ccache: new aport
ccache is a compiler cache http://ccache.samba.org/
Diffstat (limited to 'extra/ccache')
-rw-r--r--extra/ccache/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/extra/ccache/APKBUILD b/extra/ccache/APKBUILD
new file mode 100644
index 0000000000..2143bdb728
--- /dev/null
+++ b/extra/ccache/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ccache
+pkgver=2.4
+pkgrel=0
+pkgdesc="ccache is a compiler cache"
+url="http://ccache.samba.org/"
+license="GPL"
+subpackages="$pkgname-doc"
+depends="uclibc"
+makedepends=""
+source="http://samba.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ install -Dm 755 ccache "$pkgdir"/usr/bin/ccache
+ install -Dm 644 ccache.1 "$pkgdir"/usr/share/man/man1/ccache.1
+ mkdir -p "$pkgdir"/usr/lib/ccache/bin
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/cc
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/gcc
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/g++
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/cpp
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/c++
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-cc
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-gcc
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-g++
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-cpp
+ ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-c++
+}
+md5sums="73c1ed1e767c1752dd0f548ec1e66ce7 ccache-2.4.tar.gz"