aboutsummaryrefslogtreecommitdiffstats
path: root/extra/coreutils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-06 19:48:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-06 19:48:20 +0000
commit4fca61d5f48e7be06c23c985aea94d68b347a2bf (patch)
treed0df2cb97e86a3ce478ab9f3a3210dd5d66935f3 /extra/coreutils
parentdbde44389a08780c9650a94ae5a22c350e05df38 (diff)
downloadaports-4fca61d5f48e7be06c23c985aea94d68b347a2bf.tar.bz2
aports-4fca61d5f48e7be06c23c985aea94d68b347a2bf.tar.xz
extra/coreutils: moved from testing
Diffstat (limited to 'extra/coreutils')
-rw-r--r--extra/coreutils/APKBUILD31
-rw-r--r--extra/coreutils/coreutils.post-deinstall3
l---------extra/coreutils/coreutils.post-upgrade1
3 files changed, 35 insertions, 0 deletions
diff --git a/extra/coreutils/APKBUILD b/extra/coreutils/APKBUILD
new file mode 100644
index 0000000000..0dc4e1f755
--- /dev/null
+++ b/extra/coreutils/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer:
+pkgname=coreutils
+pkgver=7.1
+pkgrel=1
+pkgdesc="The basic file, shell and text manipulation utilities"
+url="http://www.gnu.org/software/coreutils/"
+license="GPL"
+depends="uclibc"
+makedepends=""
+install="$pkgname.post-deinstall $pkgname.post-upgrade"
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/gnu/coreutils/$pkgname-$pkgver.tar.gz
+ $install"
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-nls \
+ --without-gmp
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+}
+
+md5sums="cbb2b3d1718ee1237b808e00b5c11b1e coreutils-7.1.tar.gz
+b84506d253e04db3c5af9016fead45a3 coreutils.post-deinstall
+b84506d253e04db3c5af9016fead45a3 coreutils.post-upgrade"
diff --git a/extra/coreutils/coreutils.post-deinstall b/extra/coreutils/coreutils.post-deinstall
new file mode 100644
index 0000000000..99b57c4635
--- /dev/null
+++ b/extra/coreutils/coreutils.post-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+busybox --install -s
diff --git a/extra/coreutils/coreutils.post-upgrade b/extra/coreutils/coreutils.post-upgrade
new file mode 120000
index 0000000000..3e2b3c2a22
--- /dev/null
+++ b/extra/coreutils/coreutils.post-upgrade
@@ -0,0 +1 @@
+coreutils.post-deinstall \ No newline at end of file