aboutsummaryrefslogtreecommitdiffstats
path: root/extra/email
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2008-12-30 16:05:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-01 10:55:30 +0000
commit3c4a7b431a1d8e326cc76e2eca4b4f3f5efb46e4 (patch)
treebdf16f45db471557c82c2d24b6ec81d3ca251656 /extra/email
parentf6be32cbbda1b503462f7e87f735e5338e2da2db (diff)
downloadaports-3c4a7b431a1d8e326cc76e2eca4b4f3f5efb46e4.tar.bz2
aports-3c4a7b431a1d8e326cc76e2eca4b4f3f5efb46e4.tar.xz
extra/email: new aport
Diffstat (limited to 'extra/email')
-rw-r--r--extra/email/APKBUILD30
-rw-r--r--extra/email/email-3.1.0-ldflags.patch11
2 files changed, 41 insertions, 0 deletions
diff --git a/extra/email/APKBUILD b/extra/email/APKBUILD
new file mode 100644
index 0000000000..4982a3c19a
--- /dev/null
+++ b/extra/email/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
+pkgname=email
+pkgver=3.1.0
+pkgrel=0
+pkgdesc="A command line SMTP client that's simple"
+url="http://www.cleancode.org/projects/email"
+license="GPL"
+depends="uclibc openssl"
+makedepends="openssl-dev"
+source="http://www.cleancode.org/downloads/email/email-3.1.0.tar.bz2"
+
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for i in ../../*.patch; do
+ msg "Applying ${i##*/}"
+ patch -p1 -i $i || return 1
+ done
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="dc347ea65b58f49ee4fe8f578ea13535 email-3.1.0.tar.bz2"
diff --git a/extra/email/email-3.1.0-ldflags.patch b/extra/email/email-3.1.0-ldflags.patch
new file mode 100644
index 0000000000..d08896ee3a
--- /dev/null
+++ b/extra/email/email-3.1.0-ldflags.patch
@@ -0,0 +1,11 @@
+--- email-3.1.0.orig/src/Makefile.in Tue Dec 30 13:16:08 2008
++++ email-3.1.0/src/Makefile.in Tue Dec 30 13:17:00 2008
+@@ -18,7 +18,7 @@
+ remotesmtp.o sig_file.o smtpcommands.o utils.o
+
+ all: $(FILES)
+- $(CC) $(CFLAGS) -o email $(FILES) $(OTHER_FILES) $(LDFLAGS) $(LIBS) $(DLIB)
++ $(CC) $(CFLAGS) -o email $(FILES) $(OTHER_FILES) $(DLIB) $(LDFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o *.d email