aboutsummaryrefslogtreecommitdiffstats
path: root/extra/libgpg-error
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-09 15:26:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-09 15:26:53 +0000
commit1bb6b0f1a5d8b0126891cbe8356e6a41607471ea (patch)
tree285998d37d1abeea9911122cadad76df84fac1b1 /extra/libgpg-error
parentc5f7cb1eadc89e33d4659c3191aba8a6086d5833 (diff)
downloadaports-1bb6b0f1a5d8b0126891cbe8356e6a41607471ea.tar.bz2
aports-1bb6b0f1a5d8b0126891cbe8356e6a41607471ea.tar.xz
extra/libgpg-error: new aport
Support library for libgcrypt http://www.gnupg.org
Diffstat (limited to 'extra/libgpg-error')
-rw-r--r--extra/libgpg-error/APKBUILD32
-rw-r--r--extra/libgpg-error/nocxx.patch15
2 files changed, 47 insertions, 0 deletions
diff --git a/extra/libgpg-error/APKBUILD b/extra/libgpg-error/APKBUILD
new file mode 100644
index 0000000000..a51b0d3f2c
--- /dev/null
+++ b/extra/libgpg-error/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libgpg-error
+pkgver=1.6
+pkgrel=0
+pkgdesc="Support library for libgcrypt"
+url="http://www.gnupg.org"
+license="LGPL"
+depends="uclibc"
+subpackages="$pkgname-dev $pkgname-lisp"
+source="ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
+ nocxx.patch
+ "
+
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+ msg "Punting useless check for cpp..."
+ patch configure < ../nocxx.patch || return 1
+
+ ./configure --prefix=/usr \
+ --disable-nls
+
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+lisp() {
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr/share/
+}
+
+md5sums="f3e9870e213518b407a959f8d29cd554 libgpg-error-1.6.tar.bz2
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/extra/libgpg-error/nocxx.patch b/extra/libgpg-error/nocxx.patch
new file mode 100644
index 0000000000..beb1ab9006
--- /dev/null
+++ b/extra/libgpg-error/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc