aboutsummaryrefslogtreecommitdiffstats
path: root/extra/python
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-11 20:54:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-11 20:54:34 +0000
commit7206c19dfeb61905f3650a8df8703a6b9fdd7d39 (patch)
tree1bf5fac8d22d06f0e2d2a0c1e2f5fb2fffe5c5bf /extra/python
parentf6dbd5524c839b5fd8fd8097d7083e1140ed579b (diff)
downloadaports-7206c19dfeb61905f3650a8df8703a6b9fdd7d39.tar.bz2
aports-7206c19dfeb61905f3650a8df8703a6b9fdd7d39.tar.xz
extra/python: new aport
A high-level scripting language http://www.python.org
Diffstat (limited to 'extra/python')
-rw-r--r--extra/python/APKBUILD33
-rw-r--r--extra/python/python-2.6-internal-expat.patch33
2 files changed, 66 insertions, 0 deletions
diff --git a/extra/python/APKBUILD b/extra/python/APKBUILD
new file mode 100644
index 0000000000..4f5930cd3a
--- /dev/null
+++ b/extra/python/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=python
+pkgver=2.6.1
+pkgrel=0
+pkgdesc="A high-level scripting language"
+url="http://www.python.org"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="db expat openssl zlib"
+makedepends="db-dev expat-dev openssl-dev zlib-dev"
+source="http://www.$pkgname.org/ftp/$pkgname/$pkgver/Python-$pkgver.tar.bz2
+ $pkgname-2.6-internal-expat.patch
+ "
+
+build() {
+ cd "$srcdir/Python-$pkgver"
+ for i in ../*.patch; do
+ msg "Apply $i"
+ patch -p1 < $i || return 1
+ done
+
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --with-threads \
+ --enable-unicode \
+ --disable-gdbm
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="e81c2f0953aa60f8062c05a4673f2be0 Python-2.6.1.tar.bz2
+9d64df5e0a6aed149a792c7bff16e3d9 python-2.6-internal-expat.patch"
diff --git a/extra/python/python-2.6-internal-expat.patch b/extra/python/python-2.6-internal-expat.patch
new file mode 100644
index 0000000000..f345db8c8e
--- /dev/null
+++ b/extra/python/python-2.6-internal-expat.patch
@@ -0,0 +1,33 @@
+--- a/setup.py 2008-04-22 12:12:24.613554757 +0300
++++ b/setup.py 2008-04-22 12:13:09.276544063 +0300
+@@ -1035,18 +1035,15 @@
+ #
+ # More information on Expat can be found at www.libexpat.org.
+ #
+- expatinc = os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')
+- define_macros = [
+- ('HAVE_EXPAT_CONFIG_H', '1'),
+- ]
++ # Use system expat
++ expatinc = '/usr/include'
++ define_macros = []
+
+ exts.append(Extension('pyexpat',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
++ libraries = ['expat'],
+ sources = ['pyexpat.c',
+- 'expat/xmlparse.c',
+- 'expat/xmlrole.c',
+- 'expat/xmltok.c',
+ ],
+ ))
+
+@@ -1058,6 +1055,7 @@
+ exts.append(Extension('_elementtree',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
++ libraries = ['expat'],
+ sources = ['_elementtree.c'],
+ ))
+