aboutsummaryrefslogtreecommitdiffstats
path: root/extra/ruby
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /extra/ruby
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'extra/ruby')
-rw-r--r--extra/ruby/APKBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/extra/ruby/APKBUILD b/extra/ruby/APKBUILD
deleted file mode 100644
index ffeb781502..0000000000
--- a/extra/ruby/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=ruby
-pkgver=1.8.7_p174
-_pkgver=1.8.7-p174
-pkgrel=1
-pkgdesc="An object-oriented language for quick and easy programming"
-url="http://www.ruby-lang.org/en/"
-license="Ruby"
-depends=
-makedepends="zlib-dev openssl-dev libiconv-dev gdbm-dev db-dev readline-dev"
-subpackages="$pkgname-doc $pkgname-dev"
-source="ftp://ftp.ruby-lang.org/pub/ruby/1.8/${pkgname}-${_pkgver}.tar.bz2"
-#
-# maybe its a good idea to split dep libs to seperate pkg's.
-#
-build() {
- cd "$srcdir/$pkgname-${_pkgver}"
-
- # -fomit-frame-pointer makes ruby segfault, see gentoo bug #150413
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- export CFLAGS="$CFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
-
- # turn off distcc/ccache
- # http://bugs.alpinelinux.org/issues/show/1
- export CC=cc
-
- ./configure --build=${CHOST:-i486-alpine-linux-uclibc} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --with-sitedir='/usr/local/lib/site_ruby' \
- --with-extra-site-search-path='/usr/lib/site_ruby/$(ruby_ver)/i686-linux' \
- --enable-shared
- make || return 1
- make DESTDIR="$pkgdir" install
-
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}"/COPYING || return 1
-
-}
-
-md5sums="88c45aaf627b4404e5e4273cb03ba2ee ruby-1.8.7-p174.tar.bz2"