aboutsummaryrefslogtreecommitdiffstats
path: root/extra/valgrind
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /extra/valgrind
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'extra/valgrind')
-rw-r--r--extra/valgrind/APKBUILD55
-rw-r--r--extra/valgrind/valgrind-3.4.0-uclibc.patch12
2 files changed, 0 insertions, 67 deletions
diff --git a/extra/valgrind/APKBUILD b/extra/valgrind/APKBUILD
deleted file mode 100644
index dcba298373..0000000000
--- a/extra/valgrind/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=valgrind
-pkgver=3.4.1
-pkgrel=1
-pkgdesc="A tool to help find memory-management problems in programs"
-url="http://valgrind.org/"
-license="GPL"
-depends="uclibc"
-# it seems like busybox sed works but the configure script requires GNU sed
-makedepends="sed paxctl pax-utils"
-# from README_PACKAGERS:
-# Don't strip the debug info off lib/valgrind/$platform/vgpreload*.so
-# in the installation tree. Either Valgrind won't work at all, or it
-# will still work if you do, but will generate less helpful error
-# messages.
-options="!strip"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://$pkgname.org/downloads/$pkgname-$pkgver.tar.bz2
- $pkgname-3.4.0-uclibc.patch
- "
-
-build() {
- local i
- cd "$srcdir/$pkgname-$pkgver"
- for i in ../*.patch; do
- msg "Applying $i"
- patch -p1 < $i || return 1
- done
-
- # make sure our CFLAGS are respected
- sed -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long -fno-stack-protector":' \
- -i configure.in
-
- ./configure --prefix=/usr \
- --without-mpicc \
- --mandir=/usr/share/man || return 1
-
- make || return 1
- make DESTDIR="$pkgdir" install || return 1
-
- # we have options=!strip above so we strip the /usr/bin/* manually
- strip "$pkgdir"/usr/bin/valgrind \
- "$pkgdir"/usr/bin/no_op_client_for_valgrind \
- "$pkgdir"/usr/bin/valgrind-listener \
- "$pkgdir"/usr/bin/cg_merge
-
- # pax causes some issues
- # http://marc.info/?l=gentoo-hardened&m=119512627126298&w=2
- scanelf "$pkgdir"/usr/lib/valgrind/x86-linux \
- | awk '$1 == "ET_EXEC" {print $2}' | xargs paxctl -c -m
-
-}
-
-md5sums="b5f039dd2271aaf9ae570ab4116f87c7 valgrind-3.4.1.tar.bz2
-37bc90d0783bc0f8ba5754c8407e3dcc valgrind-3.4.0-uclibc.patch"
diff --git a/extra/valgrind/valgrind-3.4.0-uclibc.patch b/extra/valgrind/valgrind-3.4.0-uclibc.patch
deleted file mode 100644
index db6551996e..0000000000
--- a/extra/valgrind/valgrind-3.4.0-uclibc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- valgrind-3.4.0/drd/drd_pthread_intercepts.c.orig Thu Jan 22 14:37:52 2009
-+++ valgrind-3.4.0/drd/drd_pthread_intercepts.c Thu Jan 22 14:38:12 2009
-@@ -122,9 +122,6 @@
- /* PTHREAD_MUTEX_TIMED_NP */
- /* PTHREAD_MUTEX_NORMAL */
- case PTHREAD_MUTEX_DEFAULT:
--#if defined(HAVE_PTHREAD_MUTEX_ADAPTIVE_NP)
-- case PTHREAD_MUTEX_ADAPTIVE_NP:
--#endif
- return mutex_type_default_mutex;
- }
- return mutex_type_invalid_mutex;