aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-06-08 07:30:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-08 07:34:49 +0000
commit2e9052344602b6363ed83c119e26809be0bbfa09 (patch)
tree7e36bb365b7fcdd669e532443f73f7266659b461 /main/abuild
parent9265b8060b92b360410c1b5d94104f340194dfaa (diff)
downloadaports-2e9052344602b6363ed83c119e26809be0bbfa09.tar.bz2
aports-2e9052344602b6363ed83c119e26809be0bbfa09.tar.xz
main/abuild: fix provides in subpackages
we need clear install_if and provides for subpackages (cherry picked from commit a3af123bfbe600c6a78f74f1a2843cb489474d0a) This is needed to fix provides in freeradius. Otherwise would freeradius-dev also provide "freeradius3" which is not what we want.
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch30
-rw-r--r--main/abuild/APKBUILD12
2 files changed, 38 insertions, 4 deletions
diff --git a/main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch b/main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch
new file mode 100644
index 0000000000..971cec643b
--- /dev/null
+++ b/main/abuild/0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch
@@ -0,0 +1,30 @@
+From 563409ed82164663e08835ed07584337ce601773 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 8 Jun 2015 07:27:23 +0000
+Subject: [PATCH] abuild: clear inherit provides and install_if for subpackages
+
+Unexpected result will happen if subpackages inherits the provides or
+install_if from main package. So we clear them.
+---
+ abuild.in | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/abuild.in b/abuild.in
+index 9e6f43a..cb069f2 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -947,6 +947,11 @@ archcheck() {
+
+ prepare_package() {
+ msg "Preparing ${subpkgname:+sub}package ${subpkgname:-$pkgname}..."
++ if [ -n "$subpkgname" ]; then
++ # the subpackages should not inherit those
++ provides=""
++ install_if=""
++ fi
+ stripbin
+ prepare_metafiles \
+ && prepare_trace_rpaths \
+--
+2.4.2
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 110f9b4240..d608bb5bc6 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=2.22.0
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -20,6 +20,7 @@ subpackages="apkbuild-cpan:cpan"
options="suid"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -58,6 +59,9 @@ cpan() {
mv "$pkgdir"/usr/bin/apkbuild-cpan "$subpkgdir"/usr/bin/
}
-md5sums="46184ce2dc86294f3f8de9fe80200a7e abuild-2.22.0.tar.xz"
-sha256sums="0d24dca8fa8acc6a033e73d6cfbc6062e91c14e7b73456bd9a273f570cd91e47 abuild-2.22.0.tar.xz"
-sha512sums="c95b8ecba39ba9a76f2de6fc33aae70e040d6d6041b2365066ce2a8cb92a8ae115697f93add1c8e0ae71b1cac1ed43437416dd323fed8959a0610cc204b4a0f1 abuild-2.22.0.tar.xz"
+md5sums="46184ce2dc86294f3f8de9fe80200a7e abuild-2.22.0.tar.xz
+00bdd3304f7d89decc5d4b84e30a10b5 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch"
+sha256sums="0d24dca8fa8acc6a033e73d6cfbc6062e91c14e7b73456bd9a273f570cd91e47 abuild-2.22.0.tar.xz
+d8744ecb58d86ecb40ee22edbdbcdba1e93cc8e331a9d98641446c08b307873a 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch"
+sha512sums="c95b8ecba39ba9a76f2de6fc33aae70e040d6d6041b2365066ce2a8cb92a8ae115697f93add1c8e0ae71b1cac1ed43437416dd323fed8959a0610cc204b4a0f1 abuild-2.22.0.tar.xz
+bb55aad137f2cf02f36ce57581a1dc00f6f70f5d4df1c3fcf509772757668abfb3e5e862e40f2b62fad707ec44278f33242f8d37a64473bc72423263df939fea 0001-abuild-clear-inherit-provides-and-install_if-for-sub.patch"