aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-06 20:23:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-06 20:24:29 +0000
commit01b8509e69f65e54720fa8637ed892a1188c6e3f (patch)
treedda60e5896955b20552c5fa38693d1e2fb5fcb50 /main/abuild
parent061807a003e7b58f8aee63d4e0e228cec543114d (diff)
downloadaports-01b8509e69f65e54720fa8637ed892a1188c6e3f.tar.bz2
aports-01b8509e69f65e54720fa8637ed892a1188c6e3f.tar.xz
main/abuild: only warn when we think it should have been noarch
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-only-warn-when-we-think-there-should-have-bee.patch43
-rw-r--r--main/abuild/APKBUILD6
2 files changed, 47 insertions, 2 deletions
diff --git a/main/abuild/0001-abuild-only-warn-when-we-think-there-should-have-bee.patch b/main/abuild/0001-abuild-only-warn-when-we-think-there-should-have-bee.patch
new file mode 100644
index 0000000000..a2ca264b22
--- /dev/null
+++ b/main/abuild/0001-abuild-only-warn-when-we-think-there-should-have-bee.patch
@@ -0,0 +1,43 @@
+From 479cca4a44124b36f41872940adfb183597f40e7 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 6 Jan 2011 20:21:33 +0000
+Subject: [PATCH] abuild: only warn when we think there should have been noarch
+
+and we dont want -dev packages to be noarch
+---
+ abuild.in | 12 ++++++++----
+ 1 files changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index 904b1c3..0b602ca 100755
+--- a/abuild.in
++++ b/abuild.in
+@@ -566,6 +566,11 @@ dir_has_arch_binaries() {
+ return 1
+ }
+
++# returns true if this is the -dev package
++is_dev_pkg() {
++ test "${subpkgname%-dev}" != "$subpkgname"
++}
++
+ # check that noarch is set if needed
+ archcheck() {
+ options_has "!archcheck" && return 0
+@@ -573,10 +578,9 @@ archcheck() {
+ [ "$arch" != "noarch" ] && return 0
+ error "Arch specific binaries found so arch must not be set to \"noarch\""
+ return 1
+- else
+- [ "$arch" = "noarch" ] && return 0
+- error "No arch specific binaries found so arch should be set to \"noarch\""
+- return 1
++ elif [ "$arch" != "noarch" ] && ! is_dev_pkg; then
++ # we dont want -dev package go to noarch
++ warning "No arch specific binaries found so arch should probably be set to \"noarch\""
+ fi
+ return 0
+ }
+--
+1.7.3.4
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 59620054cd..dd10cd1771 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,9 +2,10 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.7
-pkgrel=0
+pkgrel=1
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
+ 0001-abuild-only-warn-when-we-think-there-should-have-bee.patch
"
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1"
makedepends="openssl-dev pkgconfig"
@@ -34,4 +35,5 @@ package() {
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="e6f5e18956d95e75da22adce128b2d52 abuild-2.7.tar.bz2"
+md5sums="e6f5e18956d95e75da22adce128b2d52 abuild-2.7.tar.bz2
+865f1e53e76cb77abb356cd6bb5b9588 0001-abuild-only-warn-when-we-think-there-should-have-bee.patch"