aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-28 16:05:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-28 16:05:37 +0000
commitada3afa9aa74972ec117df1f6cc420615fc0b176 (patch)
treecbcb4dfb81bf4249f0feb00a328a25a9dc63f5ca /main/abuild
parent9e581eee8d5bfd327be2a1d04927da4baed62460 (diff)
downloadaports-ada3afa9aa74972ec117df1f6cc420615fc0b176.tar.bz2
aports-ada3afa9aa74972ec117df1f6cc420615fc0b176.tar.xz
main/abuild: upgrade to 2.25.0_rc1
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch32
-rw-r--r--main/abuild/0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch55
-rw-r--r--main/abuild/0001-abuild-fix-check_depends_dev.patch41
-rw-r--r--main/abuild/0001-abuild-fix-fetch-lock-file-on-nfs.patch338
-rw-r--r--main/abuild/0001-abuild-fix-issue-in-maintainer-check.patch73
-rw-r--r--main/abuild/0001-abuild-try-to-validate-maintainer-address.patch60
-rw-r--r--main/abuild/APKBUILD34
7 files changed, 5 insertions, 628 deletions
diff --git a/main/abuild/0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch b/main/abuild/0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch
deleted file mode 100644
index fcf8c6f263..0000000000
--- a/main/abuild/0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From b67dec210ad22b1ff9156ead892593c8a2f23925 Mon Sep 17 00:00:00 2001
-From: Christian Kampka <christian@kampka.net>
-Date: Sat, 17 Oct 2015 15:49:27 +0200
-Subject: [PATCH] abuild: avoid division by zero when input is zero for
- calculating human size for packages
-
-This occurs when building meta packages that do not have any package content.
----
- abuild.in | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index 3b6fe04..0dd8f9a 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -1253,7 +1253,7 @@ scan_pkgconfig_depends() {
- # read size in bytes from stdin and show as human readable
- human_size() {
- awk '{ split("B KB MB GB TB PB", type)
-- for(i=5; y < 1; i--)
-+ for(i=5; y < 1 && $1 > 0; i--)
- y = $1 / (2**(10*i))
- printf("%.1f %s\n", y, type[i+2]) }'
- }
-@@ -2209,4 +2209,3 @@ for i in $install_after; do
- done
-
- cleanup
--
---
-2.6.1
-
diff --git a/main/abuild/0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch b/main/abuild/0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch
deleted file mode 100644
index ae70e3584c..0000000000
--- a/main/abuild/0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From ea8ab0c9205341175ff3808885bf5431d5bbd32b Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Mon, 28 Sep 2015 13:08:16 +0200
-Subject: [PATCH] abuild: check if depends_dev is set unnecessarily
-
-depends_dev are dependencies of the of the developement subpackage
-it does not need to be set when there is no developement subpackage
----
- abuild.in | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/abuild.in b/abuild.in
-index fd6fb53..995768a 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -212,6 +212,8 @@ default_sanitycheck() {
-
- check_maintainer || die "Provide a valid RFC822 maintainer address"
-
-+ check_depends_dev || warning "depends_dev found but no development subpackage found"
-+
- makedepends_has 'g++' && warning "g++ should not be in makedepends"
- return 0
- }
-@@ -729,6 +731,8 @@ get_maintainer() {
- fi
- }
-
-+
-+
- check_maintainer() {
- get_maintainer
- if [ -z "$maintainer" ]; then
-@@ -742,6 +746,18 @@ check_maintainer() {
- fi
- }
-
-+check_depends_dev() {
-+ if [ -n "$depends_dev" ]; then
-+ local pkgname
-+ for i in $pkgname $subpackages; do
-+ case "$pkgname" in
-+ *-dev) return 0 ;;
-+ esac
-+ done
-+ return 1
-+ fi
-+}
-+
- prepare_metafiles() {
- getpkgver || return 1
- local name=${subpkgname:-$pkgname}
---
-2.5.3
-
diff --git a/main/abuild/0001-abuild-fix-check_depends_dev.patch b/main/abuild/0001-abuild-fix-check_depends_dev.patch
deleted file mode 100644
index 028019f9c0..0000000000
--- a/main/abuild/0001-abuild-fix-check_depends_dev.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 62853e714521d98dead841ba954f2b9778f2ff37 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 12 Oct 2015 07:01:06 +0000
-Subject: [PATCH] abuild: fix check_depends_dev
-
----
- abuild.in | 17 +++++++++--------
- 1 file changed, 9 insertions(+), 8 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index 995768a..3b6fe04 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -747,15 +747,16 @@ check_maintainer() {
- }
-
- check_depends_dev() {
-- if [ -n "$depends_dev" ]; then
-- local pkgname
-- for i in $pkgname $subpackages; do
-- case "$pkgname" in
-- *-dev) return 0 ;;
-- esac
-- done
-- return 1
-+ if [ -z "$depends_dev" ]; then
-+ return 0
- fi
-+ local i
-+ for i in $pkgname $subpackages; do
-+ case "$i" in
-+ *-dev) return 0 ;;
-+ esac
-+ done
-+ return 1
- }
-
- prepare_metafiles() {
---
-2.6.1
-
diff --git a/main/abuild/0001-abuild-fix-fetch-lock-file-on-nfs.patch b/main/abuild/0001-abuild-fix-fetch-lock-file-on-nfs.patch
deleted file mode 100644
index 336a44092c..0000000000
--- a/main/abuild/0001-abuild-fix-fetch-lock-file-on-nfs.patch
+++ /dev/null
@@ -1,338 +0,0 @@
-From 92186b70ca9c520fc726e0885aac633aadace655 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 26 Aug 2015 08:14:36 +0200
-Subject: [PATCH] abuild: fix fetch lock file on nfs
-
-flock(2) on an NFS mount will on the server side convert the lock to a
-POSIX lock (fcntl(F_SETLK)). This means that abuild running on NFS
-server and client will create different locks and they will both try
-download same file at same time.
-
-We fix this by creating a small abuild-fetch application that will
-create a POSIX lock which works with NFS.
----
- Makefile | 6 +-
- abuild-fetch.c | 194 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
- abuild.in | 69 +-------------------
- 3 files changed, 200 insertions(+), 69 deletions(-)
- create mode 100644 abuild-fetch.c
-
-diff --git a/Makefile b/Makefile
-index 81c2851..b7332b2 100644
---- a/Makefile
-+++ b/Makefile
-@@ -11,7 +11,7 @@ abuildrepo ?= ~/.cache/abuild
- SCRIPTS := abuild abuild-keygen abuild-sign newapkbuild \
- abump apkgrel buildlab apkbuild-cpan checkapk \
- apkbuild-gem-resolver
--USR_BIN_FILES := $(SCRIPTS) abuild-tar abuild-sudo
-+USR_BIN_FILES := $(SCRIPTS) abuild-tar abuild-sudo abuild-fetch
- SAMPLES := sample.APKBUILD sample.initd sample.confd \
- sample.pre-install sample.post-install
- AUTOTOOLS_TOOLCHAIN_FILES := config.sub
-@@ -47,6 +47,7 @@ LIBS-abuild-tar = $(SSL_LIBS)
- CFLAGS-abuild-tar = $(SSL_CFLAGS)
-
- OBJS-abuild-sudo = abuild-sudo.o
-+OBJS-abuild-fetch = abuild-fetch.o
-
- .SUFFIXES: .sh.in .in
- %.sh: %.sh.in
-@@ -73,6 +74,9 @@ abuild-sudo: abuild-sudo.o
- abuild-tar: abuild-tar.o
- $(LINK)
-
-+abuild-fetch: abuild-fetch.o
-+ $(LINK)
-+
- abuild-tar.static: abuild-tar.o
- $(CC) $(CPPFLAGS) $(CFLAGS) $(CFLAGS-$@) -o $@ -static $(LIBS-$@) $^
-
-diff --git a/abuild-fetch.c b/abuild-fetch.c
-new file mode 100644
-index 0000000..51b41eb
---- /dev/null
-+++ b/abuild-fetch.c
-@@ -0,0 +1,194 @@
-+/* MIT license
-+
-+Copyright (C) 2015 Natanael Copa <ncopa@alpinelinux.org>
-+
-+Permission is hereby granted, free of charge, to any person obtaining a copy
-+of this software and associated documentation files (the "Software"), to deal
-+in the Software without restriction, including without limitation the rights
-+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-+copies of the Software, and to permit persons to whom the Software is
-+furnished to do so, subject to the following conditions:
-+
-+The above copyright notice and this permission notice shall be included in
-+all copies or substantial portions of the Software.
-+
-+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-+THE SOFTWARE.
-+
-+*/
-+
-+
-+#include <sys/wait.h>
-+
-+#include <err.h>
-+#include <fcntl.h>
-+#include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <unistd.h>
-+
-+static char *program;
-+static char lockfile[PATH_MAX] = "";
-+
-+struct cmdarray {
-+ size_t argc;
-+ char *argv[32];
-+};
-+
-+void add_opt(struct cmdarray *cmd, char *opt)
-+{
-+ cmd->argv[cmd->argc++] = opt;
-+ cmd->argv[cmd->argc] = NULL;
-+}
-+
-+int usage(int eval)
-+{
-+ printf("usage: %s [-d DESTDIR] URL\n", program);
-+ return eval;
-+}
-+
-+/* create or wait for an NFS-safe lockfile and fetch url with curl or wget */
-+int fetch(char *url, const char *destdir)
-+{
-+ int lockfd, status=0;
-+ pid_t childpid;
-+ char outfile[PATH_MAX], partfile[PATH_MAX];
-+ char *name, *p;
-+ struct flock fl = {
-+ .l_type = F_WRLCK,
-+ .l_whence = SEEK_SET,
-+ .l_start = 1,
-+ .l_len = 0,
-+ };
-+ struct cmdarray curlcmd = {
-+ .argc = 6,
-+ .argv = { "curl", "-k", "-L", "-f", "-o", partfile, NULL }
-+ };
-+ struct cmdarray wgetcmd = {
-+ .argc = 3,
-+ .argv = { "wget", "-O", partfile, NULL }
-+ };
-+
-+ name = strrchr(url, '/');
-+ if (name == NULL)
-+ errx(1, "%s: no '/' in url");
-+ p = strstr(url, "::");
-+ if (p != NULL) {
-+ name = url;
-+ *p = '\0';
-+ url = p + 2;
-+ } else if (strstr(url, "saveas-") == url) {
-+ *name++ = '\0';
-+ url += 7; /* strlen("saveas-") */
-+ } else {
-+ name++;
-+ }
-+
-+ snprintf(outfile, sizeof(outfile), "%s/%s", destdir, name);
-+ snprintf(lockfile, sizeof(lockfile), "%s.lock", outfile);
-+ snprintf(partfile, sizeof(partfile), "%s.part", outfile);
-+
-+ lockfd = open(lockfile, O_WRONLY|O_CREAT, 0660);
-+ if (lockfd < 0)
-+ err(1, lockfile);
-+
-+ if (fcntl(lockfd, F_SETLK, &fl) < 0) {
-+ printf("Waiting for %s ...\n", lockfile);
-+ if (fcntl(lockfd, F_SETLKW, &fl) < 0)
-+ err(1, "fcntl(F_SETLKW)");
-+ }
-+
-+ if (access(outfile, F_OK) == 0)
-+ goto fetch_done;
-+
-+ if (access(partfile, F_OK) == 0) {
-+ printf("Partial download found. Trying to resume.\n");
-+ add_opt(&curlcmd, "-C");
-+ add_opt(&curlcmd, "-");
-+ add_opt(&wgetcmd, "-c");
-+ }
-+
-+ add_opt(&curlcmd, url);
-+ add_opt(&wgetcmd, url);
-+
-+ childpid = fork();
-+ if (childpid < 0 )
-+ err(1, "fork");
-+
-+ if (childpid == 0) {
-+ execvp(curlcmd.argv[0], curlcmd.argv);
-+ printf("Using wget\n");
-+ execvp(wgetcmd.argv[0], wgetcmd.argv);
-+ warn(wgetcmd.argv[0]);
-+ unlink(lockfile);
-+ exit(1);
-+ }
-+ wait(&status);
-+ rename(partfile, outfile);
-+
-+fetch_done:
-+ unlink(lockfile);
-+ close(lockfd);
-+ lockfile[0] = '\0';
-+ return status;
-+
-+}
-+
-+void sighandler(int sig)
-+{
-+ switch(sig) {
-+ case SIGABRT:
-+ case SIGINT:
-+ case SIGQUIT:
-+ case SIGTERM:
-+ unlink(lockfile);
-+ exit(0);
-+ break;
-+ default:
-+ break;
-+ }
-+}
-+
-+int main(int argc, char *argv[])
-+{
-+ int opt, r=0, i;
-+ char *destdir = "/var/cache/distfiles";
-+
-+ program = argv[0];
-+ while ((opt = getopt(argc, argv, "hd:")) != -1) {
-+ switch (opt) {
-+ case 'h':
-+ return usage(0);
-+ break;
-+ case 'd':
-+ destdir = optarg;
-+ break;
-+ default:
-+ printf("Unkonwn option '%c'\n", opt);
-+ return usage(1);
-+ break;
-+ }
-+ }
-+
-+ argv += optind;
-+ argc -= optind;
-+
-+ if (argc < 1)
-+ return usage(1);
-+
-+ signal(SIGABRT, sighandler);
-+ signal(SIGINT, sighandler);
-+ signal(SIGQUIT, sighandler);
-+ signal(SIGTERM, sighandler);
-+
-+ for (i = 0; i < argc; i++) {
-+ if (fetch(argv[i], destdir))
-+ r++;
-+ }
-+ return r;
-+}
-diff --git a/abuild.in b/abuild.in
-index b8d8851..952048b 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -298,79 +298,12 @@ sourcecheck() {
- return 0
- }
-
--# convert curl options to wget options and call wget instead of curl
--wget_fallback() {
-- local wget_opts= outfile= opt=
-- while getopts "C:Lko:s" opt; do
-- case $opt in
-- 'L') ;; # --location. wget does this by default
-- 'f') ;; # --fail. wget does this by default
-- 'C') wget_opts="$wget_opts -c";; # --continue-at
-- 's') wget_opts="$wget_opts -q";; # --silent
-- 'o') wget_opts="$wget_opts -O $OPTARG";; # --output
-- 'k') wget_opts="$wget_opts --no-check-certificate";; #gnu wget
-- esac
-- done
-- shift $(( $OPTIND - 1 ))
-- wget $wget_opts "$1"
--}
--
- uri_fetch() {
- local uri="$1"
-- local d="${uri##*/}" # $(basename $uri)
-- local opts
- [ -n "$quiet" ] && opts="-s"
-
-- local lockfile="$SRCDEST/$d".lock
--
-- # fix saveas-*://* URIs
-- case "$uri" in
-- # remove 'saveas-' from beginning and
-- # '/filename' from end of URI
-- saveas-*://*) uri="${uri:7:$(expr ${#uri} - 7 - ${#d} - 1)}";;
--
-- *::*)
-- d=${uri%%::*}
-- uri=${uri#$d::}
-- ;;
-- esac
--
-- case "$uri" in
-- https://*) opts="-k";;
-- esac
--
- mkdir -p "$SRCDEST"
--
-- CLEANUP_FILES="$CLEANUP_FILES $lockfile"
-- (
-- flock -n -x 9 || msg "Waiting for ${lockfile##*/}..."
-- flock -x 9
--
-- [ -f "$SRCDEST/$d" ] && exit 0 # use exit since its a subshell
--
-- if [ -f "$SRCDEST/$d.part" ]; then
-- msg "Partial download found. Trying to resume"
-- opts="$opts -C -"
-- fi
-- msg "Fetching $uri"
--
-- # fallback to wget if curl is missing. useful for bootstrapping
-- local fetcher=
-- if ! [ -x "$(which curl)" ]; then
-- fetcher=wget_fallback
-- else
-- fetcher=curl
-- opts="$opts -L -f -k"
-- fi
--
-- $fetcher $opts -o "$SRCDEST/$d.part" "$uri" \
-- && mv "$SRCDEST/$d.part" "$SRCDEST/$d"
--
-- ) 9>$lockfile
--
-- local rc=$?
-- rm -f "$lockfile"
-- return $rc
-+ abuild-fetch -d "$SRCDEST" "$uri"
- }
-
- is_remote() {
---
-2.5.0
-
diff --git a/main/abuild/0001-abuild-fix-issue-in-maintainer-check.patch b/main/abuild/0001-abuild-fix-issue-in-maintainer-check.patch
deleted file mode 100644
index f405758324..0000000000
--- a/main/abuild/0001-abuild-fix-issue-in-maintainer-check.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From ac8b0e55cb2bd122624177a35de51eee24f8a9b2 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Wed, 16 Sep 2015 22:58:27 +0200
-Subject: [PATCH] abuild: fix issue in maintainer check
-
-seems the maintainer variable is not set anymore when building .PKGINFO
----
- abuild.in | 30 +++++++++++++++---------------
- 1 file changed, 15 insertions(+), 15 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index 557775e..fd6fb53 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -210,7 +210,7 @@ default_sanitycheck() {
- [ -n "$pkggroup" ] && spell_error pkggroup pkggroups
- [ -n "$subpackage" ] && spell_error subpackage subpackages
-
-- get_maintainer || die "Provide a valid RFC822 maintainer address"
-+ check_maintainer || die "Provide a valid RFC822 maintainer address"
-
- makedepends_has 'g++' && warning "g++ should not be in makedepends"
- return 0
-@@ -721,25 +721,24 @@ git_last_commit() {
- git log --format=oneline -n 1 "$startdir" | awk '{print $1}'
- }
-
--# this will try to check for a valid rfc822 address
--check_rfc822() {
-- local address="$1"
-- case "$address" in
-- *[A-Za-z0-9]*\ \<*@*.*\>) ;;
-- *) return 1 ;;
-- esac
--}
--
- get_maintainer() {
- if [ -z "$maintainer" ]; then
- maintainer=$(awk -F': ' '/\# *Maintainer/ {print $2}' "$APKBUILD")
- # remove surrounding whitespace
- maintainer=$(echo "$maintainer" | xargs)
-- if ! [ -z "$maintainer" ]; then
-- check_rfc822 "$maintainer" || return 1
-- else
-- warning "No maintainer"
-- fi
-+ fi
-+}
-+
-+check_maintainer() {
-+ get_maintainer
-+ if [ -z "$maintainer" ]; then
-+ warning "No maintainer"
-+ else
-+ # try to check for a valid rfc822 address
-+ case "$maintainer" in
-+ *[A-Za-z0-9]*\ \<*@*.*\>) ;;
-+ *) return 1 ;;
-+ esac
- fi
- }
-
-@@ -805,6 +804,7 @@ EOF
- fi
- echo "commit = $last_commit" >> "$pkginfo"
-
-+ get_maintainer
- if [ -n "$maintainer" ]; then
- echo "maintainer = $maintainer" >> "$pkginfo"
- fi
---
-2.5.2
-
diff --git a/main/abuild/0001-abuild-try-to-validate-maintainer-address.patch b/main/abuild/0001-abuild-try-to-validate-maintainer-address.patch
deleted file mode 100644
index 9198661356..0000000000
--- a/main/abuild/0001-abuild-try-to-validate-maintainer-address.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From aa32ec14e67bc003697625a1a4ca7cad69480c20 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Wed, 16 Sep 2015 11:00:10 +0200
-Subject: [PATCH] abuild: try to validate maintainer address
-
-abuild will error when the maintainer is set but is not a RFC822 address
----
- abuild.in | 19 +++++++++++++++++--
- 1 file changed, 17 insertions(+), 2 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index f2b322d..557775e 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -210,7 +210,7 @@ default_sanitycheck() {
- [ -n "$pkggroup" ] && spell_error pkggroup pkggroups
- [ -n "$subpackage" ] && spell_error subpackage subpackages
-
-- grep '^# Maintainer:' $APKBUILD >/dev/null || warning "No maintainer"
-+ get_maintainer || die "Provide a valid RFC822 maintainer address"
-
- makedepends_has 'g++' && warning "g++ should not be in makedepends"
- return 0
-@@ -721,9 +721,25 @@ git_last_commit() {
- git log --format=oneline -n 1 "$startdir" | awk '{print $1}'
- }
-
-+# this will try to check for a valid rfc822 address
-+check_rfc822() {
-+ local address="$1"
-+ case "$address" in
-+ *[A-Za-z0-9]*\ \<*@*.*\>) ;;
-+ *) return 1 ;;
-+ esac
-+}
-+
- get_maintainer() {
- if [ -z "$maintainer" ]; then
- maintainer=$(awk -F': ' '/\# *Maintainer/ {print $2}' "$APKBUILD")
-+ # remove surrounding whitespace
-+ maintainer=$(echo "$maintainer" | xargs)
-+ if ! [ -z "$maintainer" ]; then
-+ check_rfc822 "$maintainer" || return 1
-+ else
-+ warning "No maintainer"
-+ fi
- fi
- }
-
-@@ -789,7 +805,6 @@ EOF
- fi
- echo "commit = $last_commit" >> "$pkginfo"
-
-- get_maintainer
- if [ -n "$maintainer" ]; then
- echo "maintainer = $maintainer" >> "$pkginfo"
- fi
---
-2.5.2
-
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 61626772a4..e89e6fabb5 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abuild
-pkgver=2.24.0
+pkgver=2.25.0_rc1
_ver=${pkgver%_git*}
-pkgrel=10
+pkgrel=0
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -20,12 +20,6 @@ subpackages="apkbuild-cpan:cpan apkbuild-gem-resolver:gems"
options="suid"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
- 0001-abuild-fix-fetch-lock-file-on-nfs.patch
- 0001-abuild-try-to-validate-maintainer-address.patch
- 0001-abuild-fix-issue-in-maintainer-check.patch
- 0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch
- 0001-abuild-fix-check_depends_dev.patch
- 0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -70,24 +64,6 @@ gems() {
mv "$pkgdir"/usr/bin/apkbuild-gem-resolver "$subpkgdir"/usr/bin/
}
-md5sums="7821eea872e86a768d881fecce95e934 abuild-2.24.0.tar.xz
-3acc92254dbab1799f724394e1d49264 0001-abuild-fix-fetch-lock-file-on-nfs.patch
-8b647dd06b617d70250bbb3680aa9f82 0001-abuild-try-to-validate-maintainer-address.patch
-430baf288b197ef4b5133ac8ba392ccf 0001-abuild-fix-issue-in-maintainer-check.patch
-705ad3f7a598b2d5af58981f04773fbf 0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch
-4a93183e17d80b328f85dbc193fa02e5 0001-abuild-fix-check_depends_dev.patch
-d2ec4031bff83d96c5e3a7307a70ef22 0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch"
-sha256sums="0e0c0c7579c3b8d6668fad9d93a42f3ea18da88679e1a12a178f2676c79e94d6 abuild-2.24.0.tar.xz
-3f6d6f315c0531f900d7465abaf5f4bd0bbd59d884b2af363bc0105b0f2b3a95 0001-abuild-fix-fetch-lock-file-on-nfs.patch
-fcbdae9a224ed4705614e6c5f220e304e405e92d0a33c5dacca0d82fcf386aec 0001-abuild-try-to-validate-maintainer-address.patch
-ba588472ccc0ab86e42fd2f6a0a923cd8aa400f051e8c7acbd23f4d19a3dd93f 0001-abuild-fix-issue-in-maintainer-check.patch
-8601ea92162b434d281a33b7b3a6ba56caf93ec69d2d6093e8c560efe2a522cc 0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch
-b308cb064e67a3aef02cda92f937af4aca23a6969fcf5f611503893fd22734ee 0001-abuild-fix-check_depends_dev.patch
-326b4c1e0b40a3e0a2ec5008c4da43337f1bd0033d6e2f4097dd149a791f9d55 0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch"
-sha512sums="360d0164afed9c61576618d113d738327151c60f1bc1e6246fcf74f97db087ca2effb11a4ae045f1f288063d5311c6dddbe7721b3cbe65d11472b3d2b0f03ef6 abuild-2.24.0.tar.xz
-620fbf17f48f2732b7e7fd10f4c02bedae6d0c5c7988cefc8e1f2f233efd49514d08b72a367203c977b11272397e713e7551029f85b0dfc79c55587551600ced 0001-abuild-fix-fetch-lock-file-on-nfs.patch
-cf14d49d9ac2d4dadca9687c96ae2fc9ef43c7f86e31706c942cefa508b9c075506194e87b0189970e59261072e8cd523e0ced6d4d932936adb1c2c747b14663 0001-abuild-try-to-validate-maintainer-address.patch
-d57fdf1c17b7b201b45bfe6f2362e212cea2a6e1ea586acc20cca301db8bc39c7bc204582d0f6827b715b6d299fc3495bc3530cd461639a3d21e93fda47d0ad9 0001-abuild-fix-issue-in-maintainer-check.patch
-6b7927175dddd33e1e1b81a307f8b2b841a8c25e1467bc28dbcb894ea93caf693b1728100b587ea34830754aa30b13a165724f6261b3454c35b35aec35701e36 0001-abuild-check-if-depends_dev-is-set-unnecessarily.patch
-6c14120f314804173bed97e7ce0fd125c4b28f35f21d532849778f580cda93ff898d773cee8a28cf4fbd1502c9c2f44e2d5b5a85c51a02e3e23a8338eafca0c8 0001-abuild-fix-check_depends_dev.patch
-6598ceb721b1e203fd4104fe9381e8730829d10cb63e2b681c8202010b33ec7aa5f1134536954e639e45ecd3932ecf66ace8e6dd6640addac9d2d5d81ed279e0 0001-abuild-avoid-division-by-zero-when-input-is-zero-for.patch"
+md5sums="6fd1f7b99247618cbf0ca22b7c6cec1b abuild-2.25.0_rc1.tar.xz"
+sha256sums="2addf0e0a518d85669f5a6cbe593ea7d57232d8573acd1a9e322b68e5a14614d abuild-2.25.0_rc1.tar.xz"
+sha512sums="6dca86b68f57aaa4df0a1401098d2264d33c44380a0186ae3b03784e8f648ac17317d7ce7d3586db45d3d36ca65454fc53e032bd7b58f22f356c937038a991e5 abuild-2.25.0_rc1.tar.xz"