aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache2
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2019-02-14 05:33:02 +0100
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2019-02-14 23:45:37 +0200
commit04484bcf483551b290ed80468f0a53679399ce7b (patch)
treec030e09c0adcc05c49044a5e245de66d12630750 /main/apache2
parent022fc53172ffd278a45b388863b00864c6d9a614 (diff)
downloadaports-04484bcf483551b290ed80468f0a53679399ce7b.tar.bz2
aports-04484bcf483551b290ed80468f0a53679399ce7b.tar.xz
main/apache2: Create /run folder for apache2 on install
The directory /run/apache2 is only created when running in openrc (see apache2.initd). When installing on a non-openrc system (e.g. docker), this folder is missing and apache2 refuses to start. Closes https://bugs.alpinelinux.org/issues/9982
Diffstat (limited to 'main/apache2')
-rw-r--r--main/apache2/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index 45aa11766c..45fc04f33d 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache2
_pkgreal=httpd
pkgver=2.4.38
-pkgrel=1
+pkgrel=2
pkgdesc="A high performance Unix-based HTTP server"
url="https://httpd.apache.org/"
arch="all"
@@ -172,6 +172,10 @@ package() {
error "$i MPM was not built"
fi
done
+
+ # create the run directory
+ # ref #9982
+ mkdir -p "$pkgdir"/run/apache2
}
_make_conf_dir() {