aboutsummaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-05-05 09:11:56 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-05-05 09:12:47 +0300
commit1bb1827fa43c189ad0c0e02dac8bafb8e13aa195 (patch)
tree05597487234c1442a8e65c72e567706c74eccc62 /main/apk-tools
parent9ec25dbc2fd6f520d43433507c1b473386849053 (diff)
downloadaports-1bb1827fa43c189ad0c0e02dac8bafb8e13aa195.tar.bz2
aports-1bb1827fa43c189ad0c0e02dac8bafb8e13aa195.tar.xz
main/apk-tools: implicitly allow replacing files if source pkg is same
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-db-allow-replacing-files-of-origin-package-is-same.patch29
-rw-r--r--main/apk-tools/APKBUILD12
2 files changed, 37 insertions, 4 deletions
diff --git a/main/apk-tools/0001-db-allow-replacing-files-of-origin-package-is-same.patch b/main/apk-tools/0001-db-allow-replacing-files-of-origin-package-is-same.patch
new file mode 100644
index 0000000000..5ead3bc5ec
--- /dev/null
+++ b/main/apk-tools/0001-db-allow-replacing-files-of-origin-package-is-same.patch
@@ -0,0 +1,29 @@
+From 73a03c2e40b9c429342729d009801751bd0812da Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 25 Apr 2014 22:17:49 +0300
+Subject: [PATCH] db: allow replacing files of origin package is same
+
+basically this makes packager's life simpler as there is no need
+to list the subpkg names in replaces. this was also very error
+prone and tedious job to do properly.
+---
+ src/database.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/database.c b/src/database.c
+index 7fb700b..356ba22 100644
+--- a/src/database.c
++++ b/src/database.c
+@@ -2294,6 +2294,9 @@ static int apk_db_install_archive_entry(void *_ctx,
+ /* Upgrading package? */
+ if (opkg->name == pkg->name)
+ break;
++ /* Or same source package? */
++ if (opkg->origin == pkg->origin && pkg->origin)
++ break;
+ /* Does the original package replace the new one? */
+ foreach_array_item(dep, opkg->ipkg->replaces) {
+ if (apk_dep_is_materialized(dep, pkg)) {
+--
+1.9.2
+
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index ca0f271f63..4258c906a4 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
@@ -13,6 +13,7 @@ if [ "$CBUILD" == "$CHOST" ]; then
makedepends="$makedepends lua5.2-dev"
fi
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ 0001-db-allow-replacing-files-of-origin-package-is-same.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -82,6 +83,9 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
-md5sums="40e287741880f8a24ddaca5fe9f545b7 apk-tools-2.4.3.tar.xz"
-sha256sums="3198d3cdb718116665e609b5d3842a05f528f37fcbb6c52a2e9d46bfd2646288 apk-tools-2.4.3.tar.xz"
-sha512sums="327ca4bd19b35c521edddb4b1f56ac3f68e212c9b5be5a18219416048489a536bf948f6e4a0443456d42026aed71fd6255d2c73ff178e0726b392a5553e6680e apk-tools-2.4.3.tar.xz"
+md5sums="40e287741880f8a24ddaca5fe9f545b7 apk-tools-2.4.3.tar.xz
+cd234f5f9c5963a519332a99d9b73547 0001-db-allow-replacing-files-of-origin-package-is-same.patch"
+sha256sums="3198d3cdb718116665e609b5d3842a05f528f37fcbb6c52a2e9d46bfd2646288 apk-tools-2.4.3.tar.xz
+8810c75716c32e875a46143d371c15e954d81e2fe95a9097bfd849c5aebcca57 0001-db-allow-replacing-files-of-origin-package-is-same.patch"
+sha512sums="327ca4bd19b35c521edddb4b1f56ac3f68e212c9b5be5a18219416048489a536bf948f6e4a0443456d42026aed71fd6255d2c73ff178e0726b392a5553e6680e apk-tools-2.4.3.tar.xz
+03d8e95ed2f53126bc40494a5335b4b550edb532b1d1e90cd757b4b8a10efcf84fb030b913ba924ba42cc1ef38becef4c55b05383eb71c194c587b6212b49a52 0001-db-allow-replacing-files-of-origin-package-is-same.patch"