aboutsummaryrefslogtreecommitdiffstats
path: root/main/apr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-09-03 11:12:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-03 11:14:34 +0000
commit159c19b64ed54d83268a98ab413a91addfce64e8 (patch)
treeda6ae60c1565b55e52127d4e25206b9a77f4b9e0 /main/apr
parente1edc99b9401e7f24f0b1c0bc5d0f726f274b784 (diff)
downloadaports-159c19b64ed54d83268a98ab413a91addfce64e8.tar.bz2
aports-159c19b64ed54d83268a98ab413a91addfce64e8.tar.xz
main/apr: work around test suite hang on s390x
For some reason test suite hangs when testing sysv semaphores. It is unclear if semtimedop(2) in musl, or apr or the testsuite in apr is broken. We work arund this by avoid use semtimedop(2) for now.
Diffstat (limited to 'main/apr')
-rw-r--r--main/apr/APKBUILD4
-rw-r--r--main/apr/semtimedop-s390x.patch16
2 files changed, 19 insertions, 1 deletions
diff --git a/main/apr/APKBUILD b/main/apr/APKBUILD
index c7a864c77f..c2a40dad1e 100644
--- a/main/apr/APKBUILD
+++ b/main/apr/APKBUILD
@@ -11,6 +11,7 @@ makedepends="$depends_dev"
subpackages="$pkgname-dev"
source="https://www.apache.org/dist/apr/apr-$pkgver.tar.bz2
apr-1.6.2-dont-test-dlclose.patch
+ semtimedop-s390x.patch
"
build() {
@@ -48,4 +49,5 @@ dev() {
}
sha512sums="3dc42d5caf17aab16f5c154080f020d5aed761e22db4c5f6506917f6bfd2bf8becfb40af919042bd4ce1077d5de74aa666f5edfba7f275efba78e8893c115148 apr-1.7.0.tar.bz2
-9fb931e45f30fbe68af56849dfca148c09cdf85e300af14fb259cbd43470113288680bdb21189d4cf13f5ce95f8d28666822535e017e64ace5324339ab50cbef apr-1.6.2-dont-test-dlclose.patch"
+9fb931e45f30fbe68af56849dfca148c09cdf85e300af14fb259cbd43470113288680bdb21189d4cf13f5ce95f8d28666822535e017e64ace5324339ab50cbef apr-1.6.2-dont-test-dlclose.patch
+5d1afa9419d0481e7c3369724e8b4c1e199cbfd5d031bd9d9fc4f46ee0d3819353ff03c3b2c508d5b939f66ef4549953bbf9cdae7ff934002b9a01d824c843e8 semtimedop-s390x.patch"
diff --git a/main/apr/semtimedop-s390x.patch b/main/apr/semtimedop-s390x.patch
new file mode 100644
index 0000000000..7c0d2cf512
--- /dev/null
+++ b/main/apr/semtimedop-s390x.patch
@@ -0,0 +1,16 @@
+the testsuite hangs on s390x when testing locking mechanism sysvsem. Work
+around by avoid use semtimedop for s390x.
+
+diff --git a/locks/unix/proc_mutex.c b/locks/unix/proc_mutex.c
+index 8e2187f..cad6c4a 100644
+--- a/locks/unix/proc_mutex.c
++++ b/locks/unix/proc_mutex.c
+@@ -449,7 +449,7 @@ static const apr_proc_mutex_unix_lock_methods_t mutex_sysv_methods =
+ proc_mutex_sysv_create,
+ proc_mutex_sysv_acquire,
+ proc_mutex_sysv_tryacquire,
+-#if defined(HAVE_SEMTIMEDOP)
++#if defined(HAVE_SEMTIMEDOP) && !defined(__s390x__)
+ proc_mutex_sysv_timedacquire,
+ #else
+ proc_mutex_spinsleep_timedacquire,