aboutsummaryrefslogtreecommitdiffstats
path: root/main/binutils
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-23 12:56:33 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-23 12:56:33 +0000
commit057d88bfead5f65fe94ba1aae7dc14481ae7cd1c (patch)
tree73246c9bd1c744d5930d858cd53f614e2e8dad56 /main/binutils
parent0dceb86c0b230eb083bc86711a57e9abd1b459f3 (diff)
downloadaports-057d88bfead5f65fe94ba1aae7dc14481ae7cd1c.tar.bz2
aports-057d88bfead5f65fe94ba1aae7dc14481ae7cd1c.tar.xz
main/binutils: fix crosscompiler packaging
Diffstat (limited to 'main/binutils')
-rw-r--r--main/binutils/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index ad65c862d8..492adb1348 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -67,6 +67,11 @@ package() {
rmdir "$pkgdir"/usr/lib64
fi
rm "$pkgdir"/usr/lib/libiberty.a
+ if [ "$CHOST" != "$CTARGET" ]; then
+ # creating cross tools: remove any files that would conflict
+ # with the native tools, or other cross tools
+ rm -r "$pkgdir"/usr/share
+ fi
find "$pkgdir" -name "*.la" -delete
}