aboutsummaryrefslogtreecommitdiffstats
path: root/main/binutils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-25 09:20:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-25 13:01:12 +0000
commit137560ac0ca5d097eb2cd79d9df21ea8853beae7 (patch)
treed6015b722642baac4898ac2ac63fe8064cff529e /main/binutils
parent2392bc5142a7183fa2eacc669d6880770ce2fa2a (diff)
downloadaports-137560ac0ca5d097eb2cd79d9df21ea8853beae7.tar.bz2
aports-137560ac0ca5d097eb2cd79d9df21ea8853beae7.tar.xz
main/binutils: upgrade to 2.24
Diffstat (limited to 'main/binutils')
-rw-r--r--main/binutils/APKBUILD18
-rw-r--r--main/binutils/binutils-ld-fix-static-linking.patch31
2 files changed, 28 insertions, 21 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index bd298c001a..29d3e4ccad 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
-pkgver=2.23.2
-pkgrel=5
+pkgver=2.24
+pkgrel=0
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -31,8 +31,6 @@ prepare() {
;;
esac
done
-
- update_config_sub || return 1
}
build() {
@@ -81,9 +79,9 @@ libs() {
mv "$pkgdir"/usr/lib/lib*.so "$subpkgdir"/usr/lib/ || return 1
}
-md5sums="4f8fa651e35ef262edc01d60fb45702e binutils-2.23.2.tar.bz2
-6b744d0574338cc69d3096a890a7b609 binutils-ld-fix-static-linking.patch"
-sha256sums="fe914e56fed7a9ec2eb45274b1f2e14b0d8b4f41906a5194eac6883cfe5c1097 binutils-2.23.2.tar.bz2
-a3ebf58f95fc6c1bfe05377d222d876593f692fa9098d1ccce43874ecbb0501d binutils-ld-fix-static-linking.patch"
-sha512sums="dec753bbba008f1526b89cf1bd85feba78f362f5333ffdf93953fd131eb755976dec82a0a4ba38c43d2434da007137780cfe674de5414be5cf7ce7fbc6af6d16 binutils-2.23.2.tar.bz2
-d013566655041eee1e484d6f8b7168a2817839e88d370f064be3917c9c6be11d1b13e90fd9e769f5f095e6709520b6308d3cfca69c2956ada311c07ff697bab4 binutils-ld-fix-static-linking.patch"
+md5sums="e0f71a7b2ddab0f8612336ac81d9636b binutils-2.24.tar.bz2
+c9f308494b87c243f121a56d58f2da87 binutils-ld-fix-static-linking.patch"
+sha256sums="e5e8c5be9664e7f7f96e0d09919110ab5ad597794f5b1809871177a0f0f14137 binutils-2.24.tar.bz2
+d5c5581d0ba04ef2e3690f6fb57435bf7ce343f2376fe972a2a693c5429eec9c binutils-ld-fix-static-linking.patch"
+sha512sums="5ec95ad47d49b12c4558a8db0ca2109d3ee1955e3776057f3330c4506f8f4d1cf5e505fbf8a16b98403a0fcdeaaf986fe0a22be6456247dbdace63ce1f776b12 binutils-2.24.tar.bz2
+ecee33b0e435aa704af1c334e560f201638ff79e199aa11ed78a72f7c9b46f85fbb227af5748e735fd681d1965fcc42ac81b0c8824e540430ce0c706c81e8b49 binutils-ld-fix-static-linking.patch"
diff --git a/main/binutils/binutils-ld-fix-static-linking.patch b/main/binutils/binutils-ld-fix-static-linking.patch
index b192936af7..bc5d762656 100644
--- a/main/binutils/binutils-ld-fix-static-linking.patch
+++ b/main/binutils/binutils-ld-fix-static-linking.patch
@@ -1,19 +1,20 @@
-Index: binutils-2.22/ld/scripttempl/elf.sc
-===================================================================
---- binutils-2.22.orig/ld/scripttempl/elf.sc 2011-04-11 18:38:12.000000000 +0300
-+++ binutils-2.22/ld/scripttempl/elf.sc 2011-12-09 09:11:24.000000000 +0200
-@@ -225,8 +225,8 @@
+This fixes static linking for our hardened toolchain
+diff --git a/ld/scripttempl/elf.sc b/ld/scripttempl/elf.sc
+index e8126cb..9532bfb 100644
+--- a/ld/scripttempl/elf.sc
++++ b/ld/scripttempl/elf.sc
+@@ -235,8 +235,8 @@ test "${LARGE_SECTIONS}" = "yes" && LARGE_SECTIONS="
if test "${ENABLE_INITFINI_ARRAY}" = "yes"; then
SORT_INIT_ARRAY="KEEP (*(SORT_BY_INIT_PRIORITY(.init_array.*) SORT_BY_INIT_PRIORITY(.ctors.*)))"
SORT_FINI_ARRAY="KEEP (*(SORT_BY_INIT_PRIORITY(.fini_array.*) SORT_BY_INIT_PRIORITY(.dtors.*)))"
-- CTORS_IN_INIT_ARRAY="KEEP (*(EXCLUDE_FILE (*crtbegin.o *crtbegin?.o *crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .ctors))"
-- DTORS_IN_FINI_ARRAY="KEEP (*(EXCLUDE_FILE (*crtbegin.o *crtbegin?.o *crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .dtors))"
-+ CTORS_IN_INIT_ARRAY="KEEP (*(EXCLUDE_FILE (*crtbegin*.o *crtend*.o $OTHER_EXCLUDE_FILES) .ctors))"
-+ DTORS_IN_FINI_ARRAY="KEEP (*(EXCLUDE_FILE (*crtbegin*.o *crtend*.o $OTHER_EXCLUDE_FILES) .dtors))"
+- CTORS_IN_INIT_ARRAY="EXCLUDE_FILE (*crtbegin.o *crtbegin?.o *crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .ctors"
+- DTORS_IN_FINI_ARRAY="EXCLUDE_FILE (*crtbegin.o *crtbegin?.o *crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .dtors"
++ CTORS_IN_INIT_ARRAY="EXCLUDE_FILE (*crtbegin*.o *crtend*.o $OTHER_EXCLUDE_FILES) .ctors"
++ DTORS_IN_FINI_ARRAY="EXCLUDE_FILE (*crtbegin*.o *crtend*.o $OTHER_EXCLUDE_FILES) .dtors"
else
SORT_INIT_ARRAY="KEEP (*(SORT(.init_array.*)))"
SORT_FINI_ARRAY="KEEP (*(SORT(.fini_array.*)))"
-@@ -262,8 +262,7 @@
+@@ -270,15 +270,14 @@ CTOR=".ctors ${CONSTRUCTING-0} :
doesn't matter which directory crtbegin.o
is in. */
@@ -23,7 +24,15 @@ Index: binutils-2.22/ld/scripttempl/elf.sc
/* We don't want to include the .ctor section from
the crtend.o file until after the sorted ctors.
-@@ -278,9 +277,8 @@
+ The .ctor section from the crtend file contains the
+ end of ctors marker and it must be last */
+
+- KEEP (*(EXCLUDE_FILE (*crtend.o *crtend?.o $OTHER_EXCLUDE_FILES) .ctors))
++ KEEP (*(EXCLUDE_FILE (*crtend*.o $OTHER_EXCLUDE_FILES) .ctors))
+ KEEP (*(SORT(.ctors.*)))
+ KEEP (*(.ctors))
+ ${CONSTRUCTING+${CTOR_END}}
+@@ -286,9 +285,8 @@ CTOR=".ctors ${CONSTRUCTING-0} :
DTOR=".dtors ${CONSTRUCTING-0} :
{
${CONSTRUCTING+${DTOR_START}}