aboutsummaryrefslogtreecommitdiffstats
path: root/main/binutils
diff options
context:
space:
mode:
authorWilliam Johansson <radar@radhuset.org>2017-05-13 17:04:13 +0200
committerWilliam Pitcock <nenolod@dereferenced.org>2017-05-15 06:35:44 +0000
commit1e88af3fadc195df9cccc0d4623e75939fd5d2fb (patch)
tree80c1bfa4ed46f9c982b471b5222b28311b325dcf /main/binutils
parentda6001832585d292b9bdb448815c6de618f4a512 (diff)
downloadaports-1e88af3fadc195df9cccc0d4623e75939fd5d2fb.tar.bz2
aports-1e88af3fadc195df9cccc0d4623e75939fd5d2fb.tar.xz
main/binutils: enable x86_64-pep target
On x86_64, enable the additional target x86_64-pep. This will allow Xen to build it's EFI bootloader.
Diffstat (limited to 'main/binutils')
-rw-r--r--main/binutils/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index 4097b934a2..ab4c5259c7 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.28
-pkgrel=1
+pkgrel=2
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -31,12 +31,17 @@ fi
build() {
local _sysroot=/
local _cross_configure="--enable-install-libiberty"
+ local _arch_configure=""
if [ "$CHOST" != "$CTARGET" ]; then
_sysroot="$CBUILDROOT"
_cross_configure="--disable-install-libiberty"
fi
+ if [ "$CARCH" = "x86_64" ]; then
+ _arch_configure="--enable-targets=x86_64-pep"
+ fi
+
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -56,6 +61,7 @@ build() {
--enable-relro \
--enable-deterministic-archives \
$_cross_configure \
+ $_arch_configure \
--disable-werror \
--disable-nls \
--with-system-zlib \