aboutsummaryrefslogtreecommitdiffstats
path: root/main/binutils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-14 12:04:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-14 12:04:18 +0000
commit769e8abc929888966579468b1dcfe1f218e8fb58 (patch)
tree7273041fac41ec81ba8daad9f667a5d960327a16 /main/binutils
parent91ccc3f802870c943ea2d4ea9b2fb16013fd78c2 (diff)
downloadaports-769e8abc929888966579468b1dcfe1f218e8fb58.tar.bz2
aports-769e8abc929888966579468b1dcfe1f218e8fb58.tar.xz
main/binutils: add sysroot support
without sysroot support it's hard to build against a local glibc and do libc comparisions.
Diffstat (limited to 'main/binutils')
-rw-r--r--main/binutils/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index bddbcbed63..5c87757739 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.25
-pkgrel=0
+pkgrel=1
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -35,16 +35,15 @@ prepare() {
}
build() {
- local _cross_configure=
- [ "$CHOST" != "$CTARGET" ] && _cross_configure="--with-sysroot=$CBUILDROOT"
-
+ local _sysroot=/
+ [ "$CHOST" != "$CTARGET" ] && _sysroot="$CBUILDROOT"
cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--target=$CTARGET \
--with-build-sysroot="$CBUILDROOT" \
- $_cross_configure \
+ --with-sysroot=$_sysroot \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \