aboutsummaryrefslogtreecommitdiffstats
path: root/main/binutils
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-03 01:46:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-03 01:47:59 +0200
commitf741c9ab82d6eaf9bf2d86dc12ec97309328335b (patch)
tree2fc562f346d950237f1436c11de0f976ca5773a5 /main/binutils
parent44f68f62deb39b825137a1093bffe39967672d22 (diff)
downloadaports-f741c9ab82d6eaf9bf2d86dc12ec97309328335b.tar.bz2
aports-f741c9ab82d6eaf9bf2d86dc12ec97309328335b.tar.xz
main/binutils: fix invalid source when cross-compiling
Diffstat (limited to 'main/binutils')
-rw-r--r--main/binutils/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index 2b72c1b74a..4097b934a2 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -11,13 +11,6 @@ makedepends="$makedepends_build $makedepends_host"
arch="all"
license="GPL2 GPL3+ LGPL2 BSD"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-gold"
-
-if [ "$CHOST" != "$CTARGET" ]; then
- pkgname="$pkgname-$CTARGET_ARCH"
- subpackages=""
- sonameprefix="$pkgname:"
-fi
-
source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
binutils-ld-fix-static-linking.patch
hash-style-gnu.patch
@@ -25,6 +18,12 @@ source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
"
builddir="$srcdir/$pkgname-$pkgver"
+if [ "$CHOST" != "$CTARGET" ]; then
+ pkgname="$pkgname-$CTARGET_ARCH"
+ subpackages=""
+ sonameprefix="$pkgname:"
+fi
+
# secfixes:
# 2.28-r1:
# - CVE-2017-7614