aboutsummaryrefslogtreecommitdiffstats
path: root/main/bitlbee
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-11-08 11:22:22 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-08 07:43:12 +0000
commitc0082d445f7da2e4a8f5186f6699483f20445012 (patch)
tree5f36d4218c32596bfa7a541347d3b62264498d8e /main/bitlbee
parentd5c3025a97915a654fef24d8a8630fe43a7355fb (diff)
downloadaports-c0082d445f7da2e4a8f5186f6699483f20445012.tar.bz2
aports-c0082d445f7da2e4a8f5186f6699483f20445012.tar.xz
main/bitlbee: fix build
Diffstat (limited to 'main/bitlbee')
-rw-r--r--main/bitlbee/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/bitlbee/APKBUILD b/main/bitlbee/APKBUILD
index 267e0a5149..fd66421b6d 100644
--- a/main/bitlbee/APKBUILD
+++ b/main/bitlbee/APKBUILD
@@ -2,12 +2,13 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=bitlbee
pkgver=3.5.1
-pkgrel=4
+pkgrel=5
pkgdesc="An IRC to other chat networks gateway"
url="https://www.bitlbee.org/"
arch="all"
license="GPL-2.0"
makedepends="python3 glib-dev openssl-dev libotr-dev"
+checkdepends="check-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-otr $pkgname-openrc"
source="http://get.bitlbee.org/src/$pkgname-$pkgver.tar.gz
openssl-1.1.patch
@@ -30,6 +31,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install install-etc install-dev