aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-07-09 12:57:58 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-07-09 12:58:29 +0200
commit4c0690cdb031de356976e867aa0ec2bbef24b9af (patch)
tree6ff1299e38b5cc49814c5ac5f1f0275507000149 /main/boost/APKBUILD
parent03a63708450b24f7cf7379a7d9c07e2a1d5443d0 (diff)
downloadaports-4c0690cdb031de356976e867aa0ec2bbef24b9af.tar.bz2
aports-4c0690cdb031de356976e867aa0ec2bbef24b9af.tar.xz
main/boost: add patch to fix int128 detection
Diffstat (limited to 'main/boost/APKBUILD')
-rw-r--r--main/boost/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index 0b834654ef..050b4a547e 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -8,7 +8,7 @@ _y=${_y#*.} # strip x.
_z=${pkgver##*.} # strip x.y.
_ver=${_x}_${_y}_${_z}
-pkgrel=0
+pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="http://www.boost.org/"
arch="all"
@@ -36,6 +36,7 @@ $pkgname-wserialization
"
source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$_ver.tar.gz
stdint.patch
+ boost-1.54.0-Fix-macro-for-int128-detection.patch
"
_builddir="$srcdir"/${pkgname}_${_ver}
@@ -135,8 +136,11 @@ wserialization() { _mvlib wserialization; }
md5sums="efbfbff5a85a9330951f243d0a46e4b9 boost_1_54_0.tar.gz
-44d1879459159367448967a2c43c36d1 stdint.patch"
+44d1879459159367448967a2c43c36d1 stdint.patch
+cba4ae04208e6adf331e78eabee4ba53 boost-1.54.0-Fix-macro-for-int128-detection.patch"
sha256sums="412d003299e72555e1e1f62f51d3b07eca2a1911e27c442ee1c08167826ef9e2 boost_1_54_0.tar.gz
-b48f6ba5ffbc04c88dedb6b6639d2870a8f0901693d762f5c8d2e912d8ab47a6 stdint.patch"
+b48f6ba5ffbc04c88dedb6b6639d2870a8f0901693d762f5c8d2e912d8ab47a6 stdint.patch
+6e5e868ca8218c23537cf5108d2998280a2cbbd3e6b5f69245469c38f8cf00b8 boost-1.54.0-Fix-macro-for-int128-detection.patch"
sha512sums="c2c56a50828d14d7eb34bb309702e232dbe2afa4ed6837a0e5af16f553e563b91f65a98413f5458f09d5899e42754277ce0d2556a642e9aed77eaa3bc2a28b36 boost_1_54_0.tar.gz
-b964488c9c74d89a55480b3a0078d4e7a19df91c9a7ba9ea2695142b54335191a3c0fbb004893c03b498bc270680403e1ba3681eb94ef4407a70f0727aa66c0a stdint.patch"
+b964488c9c74d89a55480b3a0078d4e7a19df91c9a7ba9ea2695142b54335191a3c0fbb004893c03b498bc270680403e1ba3681eb94ef4407a70f0727aa66c0a stdint.patch
+0d62aadd3021e435553ee5764a3b16259e160ab5607813ec69a026d646f76cf1eff8ccf37f6f85db7af3e193f23b8ef2e6a0e034ae41b22f5f12d319f34d5363 boost-1.54.0-Fix-macro-for-int128-detection.patch"