aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-28 12:59:41 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-02 10:31:57 +0000
commitea0f75ee78e21966e30d819ff88f23c33b3e7e31 (patch)
treecbcf1e825ce5db1f74274f707cb486c97b6e8744 /main/boost
parentb6602c39d7cf4cf5f39a9eda39884212a4f55a50 (diff)
downloadaports-ea0f75ee78e21966e30d819ff88f23c33b3e7e31.tar.bz2
aports-ea0f75ee78e21966e30d819ff88f23c33b3e7e31.tar.xz
main/boost: add zstd-dev for zstd support
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index e9e398f572..6127857e63 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -30,6 +30,10 @@ case "$CARCH" in
;;
*) _boostarch=$CARCH ;;
esac
+case "$CARCH" in
+ armhf) ;; # zstd is not available for armhf
+ *) makedepends="$makedepends zstd-dev";;
+esac
_enginedir="tools/build/src/engine"
_bjam="${builddir}/${_enginedir}/bin.linux${_l_suffix:-$_boostarch}/b2"