aboutsummaryrefslogtreecommitdiffstats
path: root/main/botan
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-20 17:06:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-20 17:06:12 +0000
commit46e81292bd788d59dfcab79d258f1c36444ce3ed (patch)
tree1e5d034d03de575e7a666233541710b053160fcd /main/botan
parent357ebd83e6849e0dea5f37a13a3ba5cf1ae08d86 (diff)
downloadaports-46e81292bd788d59dfcab79d258f1c36444ce3ed.tar.bz2
aports-46e81292bd788d59dfcab79d258f1c36444ce3ed.tar.xz
main/botan: move from community, claim maintainership
Diffstat (limited to 'main/botan')
-rw-r--r--main/botan/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/main/botan/APKBUILD b/main/botan/APKBUILD
new file mode 100644
index 0000000000..eef6f93104
--- /dev/null
+++ b/main/botan/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: tcely <tcely@users.noreply.github.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=botan
+pkgver=2.11.0
+pkgrel=3
+pkgdesc="Crypto and TLS for C++11"
+url="https://botan.randombit.net/"
+arch="all"
+license="BSD-2-Clause"
+depends_dev="boost-dev bzip2-dev openssl-dev sqlite-dev xz-dev zlib-dev"
+makedepends="$depends_dev python3"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://botan.randombit.net/releases/Botan-$pkgver.tar.xz"
+builddir="$srcdir/Botan-$pkgver"
+
+# secfixes:
+# 2.9.0-r0:
+# - CVE-2018-20187
+# 2.7.0-r0:
+# - CVE-2018-12435
+# 2.6.0-r0:
+# - CVE-2018-9860
+# 2.5.0-r0:
+# - CVE-2018-9127
+
+build() {
+ # botan benefits from -O3. Upstream is using it when testing.
+ CXXFLAGS="$CXXFLAGS -O3" \
+ ./configure.py \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-boost \
+ --with-bzip2 \
+ --with-lzma \
+ --with-openmp \
+ --with-openssl \
+ --with-sqlite3 \
+ --with-zlib \
+ --with-os-feature=getrandom \
+ --disable-static
+
+ make
+}
+
+check() {
+ ./botan-test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/python*
+}
+
+sha512sums="a697a7f29788afc561cde35431e65e2f37e40fd45af89a6d060bf9988d28089905c6a1c005f9b23fb377547cd7a96a41f62c8d2f61a7f80d1ca1b9ccf857a2ce Botan-2.11.0.tar.xz"