aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2018-12-31 19:48:58 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2018-12-31 19:50:15 +0200
commit7e42b775063cedb30f5935ba01a606fca119cb51 (patch)
tree4afceb116983c6a1ec7a55f4bf2eb240ab5769ce /main/busybox
parent40430505ce0c33401bb5a22d73b70930a6405b77 (diff)
downloadaports-7e42b775063cedb30f5935ba01a606fca119cb51.tar.bz2
aports-7e42b775063cedb30f5935ba01a606fca119cb51.tar.xz
main/busybox: ip: print dadfailed flag
fixes dad.if-up getting stuck
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0015-ip-print-dadfailed-flag.patch28
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 31 insertions, 1 deletions
diff --git a/main/busybox/0015-ip-print-dadfailed-flag.patch b/main/busybox/0015-ip-print-dadfailed-flag.patch
new file mode 100644
index 0000000000..96c26bb04e
--- /dev/null
+++ b/main/busybox/0015-ip-print-dadfailed-flag.patch
@@ -0,0 +1,28 @@
+From a8c618c63e88064ae07d34f3c92469624e097376 Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Mon, 31 Dec 2018 19:32:21 +0200
+Subject: [PATCH] ip: print dadfailed flag
+
+Signed-off-by: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+---
+ networking/libiproute/ipaddress.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/networking/libiproute/ipaddress.c b/networking/libiproute/ipaddress.c
+index 9ec665b69..d088caf4c 100644
+--- a/networking/libiproute/ipaddress.c
++++ b/networking/libiproute/ipaddress.c
+@@ -327,6 +327,10 @@ static int FAST_FUNC print_addrinfo(const struct sockaddr_nl *who UNUSED_PARAM,
+ ifa->ifa_flags &= ~IFA_F_TENTATIVE;
+ printf("tentative ");
+ }
++ if (ifa->ifa_flags & IFA_F_DADFAILED) {
++ ifa->ifa_flags &= ~IFA_F_DADFAILED;
++ printf("dadfailed ");
++ }
+ if (ifa->ifa_flags & IFA_F_DEPRECATED) {
+ ifa->ifa_flags &= ~IFA_F_DEPRECATED;
+ printf("deprecated ");
+--
+2.20.1
+
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index faa9932e9a..9837ffe15d 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.29.3
-pkgrel=4
+pkgrel=5
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -33,6 +33,7 @@ source="https://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0012-udhcpc-Don-t-background-if-n-is-given.patch
0013-testsuite-fix-cpio-tests.patch
0014-miscutils-microcom-Fixed-segfault.patch
+ 0015-ip-print-dadfailed-flag.patch
acpid.logrotate
busyboxconfig
@@ -208,6 +209,7 @@ f96d66ce5a0295a2459a2c49c281b64e016de675ebd31a49af18cb06f3498fe27dfbc8667324b439
025ad19f4e0cd299f11eba4a0c852c166fc91787756838f9c755405dad924fd1fe3c08067b938e14f9d8c609881d2ce5915152810e855eaa5ca510a76650069e 0012-udhcpc-Don-t-background-if-n-is-given.patch
d8926f0e4ed7d2fe5af89ff2a944d781b45b109c9edf1ef2591e7bce2a8bbadd7c8ca814cb3c928ae09027d9603434fe70496f308d701f3d42260ebd1e9e9b29 0013-testsuite-fix-cpio-tests.patch
8cb91903f2be3620b5500a4e8f4190537c93601282510b82303c3b516141b36ab872aeff5a7f5ae00f270439abab862ceabda531bdf180643da165b2f3b35d9f 0014-miscutils-microcom-Fixed-segfault.patch
+2fdf01e4bb26a3b6fd7ff73649f15eff599d38db1bc61a699576ec9caae2fb37c49d689baca8b1a3a7b2999fbe04751da897518c2fb42d6f21756b468aa7599d 0015-ip-print-dadfailed-flag.patch
aa93095e20de88730f526c6f463cef711b290b9582cdbd8c1ba2bd290019150cbeaa7007c2e15f0362d5b9315dd63f60511878f0ea05e893f4fdfb4a54af3fb1 acpid.logrotate
8fc1b81f39cb73430ebc9bca8706a71ae82b51efd2fee8ac15b4abe9b0899239075a46234cb7eae58f906c7499d1f75d11b29bcb9ca8dada8b34822df0948e73 busyboxconfig
1dc5c94708fc4d4129015c0cdd64fbe0edd2794bb10422ac2686db8a4ef06182d306ec89560d0310190c1ed86b8422c13594d2cc2b9281c8895145d5a233cc0c busyboxconfig-extras