aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-12-10 21:38:33 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-11 08:18:03 +0000
commit87bb76ed96f4e38b57737ccf20e130a60ad17c7a (patch)
tree41c3c36f347b90b1cc4f994fd573d00ef1f5cd23 /main/busybox
parentfb52d82f08036874ea402f06f32304cbf5fcc1bf (diff)
downloadaports-87bb76ed96f4e38b57737ccf20e130a60ad17c7a.tar.bz2
aports-87bb76ed96f4e38b57737ccf20e130a60ad17c7a.tar.xz
main/busybox: Fix license
Busybox is licensed gpl2-only. Fix this. While here, also disable pkg-config related shellcheck warning, where we need word splitting. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 69807312e6..6a8f499479 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -7,7 +7,7 @@ pkgrel=3
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url="https://busybox.net/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-only"
makedepends_host="linux-headers openssl-dev libtls-standalone-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="zip"
@@ -74,6 +74,7 @@ build() {
${LDFLAGS} "$srcdir"/bbsuid.c -o "$_dyndir"/bbsuid
msg "Building ssl_client"
+ # shellcheck disable=SC2046 # Allow wordsplitting for pkg-config
${CC:-${CROSS_COMPILE}gcc} ${CPPFLAGS} ${CFLAGS} $(pkg-config --cflags libtls-standalone) \
"$srcdir"/ssl_client.c -o "$_dyndir"/ssl_client ${LDFLAGS} $(pkg-config --libs libtls-standalone)