aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-08-09 22:05:13 +0300
committerTimo Teräs <timo.teras@iki.fi>2018-08-09 22:07:10 +0300
commitf87f8c66131ddb3153c62122080714795ba92c6e (patch)
tree8c4384dd7f91e175dbe5c8c35eacd2fd4c8959f2 /main/busybox
parentd76cafc1b58d50688d04e15ff1d5be1885ccfd4a (diff)
downloadaports-f87f8c66131ddb3153c62122080714795ba92c6e.tar.bz2
aports-f87f8c66131ddb3153c62122080714795ba92c6e.tar.xz
main/busybox: fix fbsplash console switching
Fixes #9215 This was broken in commit dc6cfb7cebc64cdb which just removed opt_complementary (due to that being removed in bb). Add proper getopt flag to get correct behaviour.
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0007-fbsplash-support-console-switching.patch2
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/main/busybox/0007-fbsplash-support-console-switching.patch b/main/busybox/0007-fbsplash-support-console-switching.patch
index ef226d0096..7d76d4f1f4 100644
--- a/main/busybox/0007-fbsplash-support-console-switching.patch
+++ b/main/busybox/0007-fbsplash-support-console-switching.patch
@@ -75,7 +75,7 @@ index 5b2e5ac56..bc80f728c 100644
fifo_filename = NULL;
- bCursorOff = 1 & getopt32(argv, "cs:d:i:f:",
- &G.image_filename, &fb_device, &cfg_filename, &fifo_filename);
-+ bCursorOff = 1 & getopt32(argv, "cs:d:i:f:T:",
++ bCursorOff = 1 & getopt32(argv, "cs:d:i:f:T:+",
+ &G.image_filename, &fb_device, &cfg_filename, &fifo_filename,
+ &G.silent_tty);
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 6807faa647..c078b17cbe 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.28.4
-pkgrel=1
+pkgrel=2
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -208,7 +208,7 @@ cc5e5ce7a822ef51eb6b8065e1b802bc9d690857b8123cb4decf51b09c4ef655784401a68dd26e0a
5f0611d21d1dc106d43ba23234babd41a2167d7032f3b09e825ae3dc9f9aaeb8d1882f59341daff99adecdfb8ba52a5c9fb423c8df3168b2e2304c5bd0ac4991 0004-app-location-for-cpio-vi-and-lspci.patch
bd4bb1f29f0287aa2ae4e43d791072802ba4f8863ea968612410a2819f7afaec5c0c731b4d91f360461ebfe26942f21e9ff69cbd5fb7d9800e62ef59fe954ab2 0005-udhcpc-set-default-discover-retries-to-5.patch
f03f852b97f3875d3051b225e6ffe52ed02ae8a8550287b3e09c2ef4d63914e1ab045ba5e2bc2dc2f3c8bf643485de4ebb36b97c74a8a6e49b6ba0261f2ddb94 0006-ping-make-ping-work-without-root-privileges.patch
-a7b4ddb838f51e86040246e11a4b0df7bce37ed5159634bd2a8f388cf57be0551e6e63887b71b530a8a7b86dbdda6bbb3a090173f040050ea864b5f07674395d 0007-fbsplash-support-console-switching.patch
+b8d276dd84b996be9414e0215e2fd96a343346bf7584c252af138a579dc956366b690ea0888c35dfbcef43ed384ae94aebb3b4f2b11f89c27ba408ebdc0087eb 0007-fbsplash-support-console-switching.patch
f8655833f71715629a4a93997939ca295cacb35f17843a36cb6fda285213bdbd258b2f84e321f81859491971412a520f697748ebd6fb46808f830f4ccfa77af4 0008-fbsplash-support-image-and-bar-alignment-and-positio.patch
f69031d048aa5e087cb6597ad2f7b39b520a5ef3713731e9090c5b65680cd7075bdf3a9443725fac49dce4345bc3345dc702b95d618d45a6d3be8682844784f4 0009-depmod-support-generating-kmod-binary-index-files.patch
b558f3ceb63e39545c3219796da64a7962bb53515a4eedea2bf9d81057774096b429145f0cd98da2542e3bdadaf92fb11d710fb1879768c9980bf58ccd104b6e 0010-Add-flag-for-not-following-symlinks-when-recursing.patch