aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-07-25 20:54:53 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-25 20:54:53 +0200
commitec9189e2b709e2d680647c71ca920909121479f5 (patch)
tree4414d6aad370b9f37a5caacd8f18a8cb8256a3f1 /main/busybox
parent044aff334d9d032abc079a09d19cefb81896909c (diff)
downloadaports-ec9189e2b709e2d680647c71ca920909121479f5.tar.bz2
aports-ec9189e2b709e2d680647c71ca920909121479f5.tar.xz
main/busybox: fix regression in unzip on s390x
introduced with 1.27 release
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0001-unzip-fix-regression-on-big-endian-machines.patch31
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 34 insertions, 1 deletions
diff --git a/main/busybox/0001-unzip-fix-regression-on-big-endian-machines.patch b/main/busybox/0001-unzip-fix-regression-on-big-endian-machines.patch
new file mode 100644
index 0000000000..e0307430cf
--- /dev/null
+++ b/main/busybox/0001-unzip-fix-regression-on-big-endian-machines.patch
@@ -0,0 +1,31 @@
+From 32ba988add53a003cf086ac660809f2a33a55b02 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 25 Jul 2017 20:38:18 +0200
+Subject: [PATCH] unzip: fix regression on big-endian machines
+
+This fixes a regression which was introduced with commit 2a0867a5
+("unzip: optional support for bzip2 and lzma") and causes unzip to exit
+with error when extracting archives:
+
+ unzip: unsupported method 2048
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ archival/unzip.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/archival/unzip.c b/archival/unzip.c
+index bb39d954e..8ed9ae7d5 100644
+--- a/archival/unzip.c
++++ b/archival/unzip.c
+@@ -114,6 +114,7 @@ typedef union {
+
+ #define FIX_ENDIANNESS_ZIP(zip) \
+ do { if (BB_BIG_ENDIAN) { \
++ (zip).fmt.method = SWAP_LE16((zip).fmt.method ); \
+ (zip).fmt.crc32 = SWAP_LE32((zip).fmt.crc32 ); \
+ (zip).fmt.cmpsize = SWAP_LE32((zip).fmt.cmpsize ); \
+ (zip).fmt.ucmpsize = SWAP_LE32((zip).fmt.ucmpsize ); \
+--
+2.13.2
+
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 0010854105..012df29aa0 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.27.0
-pkgrel=2
+pkgrel=3
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -29,6 +29,7 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0009-sysklogd-add-Z-option-to-adjust-message-timezones.patch
0010-udhcpc-Don-t-background-if-n-is-given.patch
0011-testsuite-fix-cpio-tests.patch
+ 0001-unzip-fix-regression-on-big-endian-machines.patch
top-buffer-overflow.patch
@@ -179,6 +180,7 @@ baac796f8aa96fbeab19f96eea7787ace5737b182f49e02f1b1e911d0a927ae14f3c334daad42418
d1c375184f806f7550bac5c82ab5471bdb8085d845172c973724b22af05ab3759b3ce982e088b4c45815ade56b9adfb7a677d0c180e077545ac7ec003c8aa7c4 0009-sysklogd-add-Z-option-to-adjust-message-timezones.patch
9b5143d0be615b1604d82007628d59a62721f1e61a63cca7a4ffa5e60fa8da102bfc21fa20cc35c2f5a0a24bc8013598f8eff5888f9d0f3bcfa796343b5f5a91 0010-udhcpc-Don-t-background-if-n-is-given.patch
f4e00eb13fda752df13f300a7ed9b1320ca9f573c4309247f292c8710464d7be8740148f42e4aff16312335eadabce5a629dce4af58334b9199faf2fd658e4f9 0011-testsuite-fix-cpio-tests.patch
+daa6732a95a52a194d2031f2d5af5f658b9da3e8669fc2206000faaab7da56966a62646eed615fd1cbc5f07d42c03bf19ff183ef6f933b7daaeef1d388e21874 0001-unzip-fix-regression-on-big-endian-machines.patch
524e858b52cb31fb8d24e8c7f18606fff349aeab6a14da9cca3902641f6127980daed73c53586c6e8b41eecda06cdb29c40ff1dde2dc82a318c2649680458921 top-buffer-overflow.patch
a9b1403c844c51934637215307dd9e2adb9458921047acff0d86dcf229b6e0027f4b2c6cdaa25a58407aad9d098fb5685d58eb5ff8d2aa3de4912cdea21fe54c acpid.logrotate
857dece10267a065e0e8c16dd6190656f890a5aff774e96321715673dda23e75a8e61148e81d6286b7bdfe737a0b99104f9b04deeb4f392c72b63d8e3d00e556 busyboxconfig