aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-31 10:04:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:12 +0000
commita04744a85bafe6b66c7f2c3e48e496d0dd4eb5b0 (patch)
tree2b39d17fef6cb5341c9845ee5346c2f9943b4c19 /main/busybox
parente0c4bf32c3423530abb4919dd2fd0f20ae7df2e8 (diff)
downloadaports-a04744a85bafe6b66c7f2c3e48e496d0dd4eb5b0.tar.bz2
aports-a04744a85bafe6b66c7f2c3e48e496d0dd4eb5b0.tar.xz
main/busybox: rebuild against libtls-standalone
build against libtls-standalone and openssl 1.1
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index c9ef9ef762..82bd654aca 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,13 +3,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.29.3
-pkgrel=1
+pkgrel=2
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
license="GPL-2.0"
makedepends_build=""
-makedepends_host="linux-headers libressl-dev"
+makedepends_host="linux-headers openssl-dev libtls-standalone-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="zip"
provides="/bin/sh"
@@ -72,8 +72,8 @@ build() {
${LDFLAGS} "$srcdir"/bbsuid.c -o "$_dyndir"/bbsuid
msg "Building ssl_client"
- ${CC:-${CROSS_COMPILE}gcc} ${CPPFLAGS} ${CFLAGS} $(pkg-config --cflags libtls) \
- "$srcdir"/ssl_client.c -o "$_dyndir"/ssl_client ${LDFLAGS} $(pkg-config --libs libtls)
+ ${CC:-${CROSS_COMPILE}gcc} ${CPPFLAGS} ${CFLAGS} $(pkg-config --cflags libtls-standalone) \
+ "$srcdir"/ssl_client.c -o "$_dyndir"/ssl_client ${LDFLAGS} $(pkg-config --libs libtls-standalone)
# build dynamic
cd "$_dyndir"