aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-17 14:44:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-17 14:45:59 +0000
commit83aab393ce2e4ef8d4107d23075f103269503a4e (patch)
treeba4991f671e50c7188cf4890c0eb807bea270f0e /main/busybox
parent8cefef913520db312cf770a820f209753de5491f (diff)
downloadaports-83aab393ce2e4ef8d4107d23075f103269503a4e.tar.bz2
aports-83aab393ce2e4ef8d4107d23075f103269503a4e.tar.xz
main/busybox: avoid run depmod if kmod is installed
dont run busybox depmod if we have kmod. This prevents us from running depmod twice.
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD2
-rw-r--r--main/busybox/busybox.trigger5
2 files changed, 5 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index bae37e1f02..b1c844ba21 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.31.1
-pkgrel=6
+pkgrel=7
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url="https://busybox.net/"
arch="all"
diff --git a/main/busybox/busybox.trigger b/main/busybox/busybox.trigger
index e531a45b84..4daec8c56d 100644
--- a/main/busybox/busybox.trigger
+++ b/main/busybox/busybox.trigger
@@ -5,7 +5,10 @@ do_bb_install=
for i in "$@"; do
case "$i" in
/lib/modules/*)
- if [ -d "$i" ]; then
+ # don't run busybox dpemod if we have kmod installed
+ # we dont need to run it twice.
+ target=$(readlink -f $(command -v depmod))
+ if [ -d "$i" ] && [ "$target" = "/bin/busybox" ]; then
/bin/busybox depmod ${i#/lib/modules/}
fi
;;