aboutsummaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-30 10:43:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-30 10:44:48 +0000
commitaf000ceb424d71d72d091338b96912fa4fed1c3f (patch)
tree5fe8722634224bcc8ed2f9a8089d8a2716491cad /main/busybox
parent1d0560a9b6b5597b191e5aff69a31c2fe0aba273 (diff)
downloadaports-af000ceb424d71d72d091338b96912fa4fed1c3f.tar.bz2
aports-af000ceb424d71d72d091338b96912fa4fed1c3f.tar.xz
main/busybox: upgrade to 1.28.4
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/0001-nsenter-Rename-network-option-to-net.patch36
-rw-r--r--main/busybox/0002-nsenter-fix-parsing-of-t-S-and-G-options.patch61
-rw-r--r--main/busybox/APKBUILD11
3 files changed, 3 insertions, 105 deletions
diff --git a/main/busybox/0001-nsenter-Rename-network-option-to-net.patch b/main/busybox/0001-nsenter-Rename-network-option-to-net.patch
deleted file mode 100644
index ab3cff5e7b..0000000000
--- a/main/busybox/0001-nsenter-Rename-network-option-to-net.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 40394cb1c963c35d2daa9570ba968afa981cf1fc Mon Sep 17 00:00:00 2001
-From: Euan Harris <euan.harris@docker.com>
-Date: Thu, 3 May 2018 13:34:46 +0100
-Subject: [PATCH 1/2] nsenter: Rename --network option to --net
-
-In nsenter from util-linux, the long version of the -n option is
---net=<path>. BusyBox's version expects --network=<path>, so scripts
-and examples written for util-linux's version cause BusyBox's version
-to exit with the usage message.
-
-Confusingly, until commit 036585a911a5f, the usage message erroneously
-claimed that the long option was indeed called --net; after that commit
-long options are not listed at all.
-
-Signed-off-by: Euan Harris <euan.harris@docker.com>
-Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
----
- util-linux/nsenter.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/util-linux/nsenter.c b/util-linux/nsenter.c
-index c6933c8..35439a2 100644
---- a/util-linux/nsenter.c
-+++ b/util-linux/nsenter.c
-@@ -112,7 +112,7 @@ static const char nsenter_longopts[] ALIGN1 =
- "user\0" Optional_argument "U"
- "ipc\0" Optional_argument "i"
- "uts\0" Optional_argument "u"
-- "network\0" Optional_argument "n"
-+ "net\0" Optional_argument "n"
- "pid\0" Optional_argument "p"
- "mount\0" Optional_argument "m"
- "target\0" Required_argument "t"
---
-2.7.4
-
diff --git a/main/busybox/0002-nsenter-fix-parsing-of-t-S-and-G-options.patch b/main/busybox/0002-nsenter-fix-parsing-of-t-S-and-G-options.patch
deleted file mode 100644
index 7a81bba14c..0000000000
--- a/main/busybox/0002-nsenter-fix-parsing-of-t-S-and-G-options.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 254e47372f77ea1070be6dbb44b5c45770115a07 Mon Sep 17 00:00:00 2001
-From: Euan Harris <euan.harris@docker.com>
-Date: Fri, 4 May 2018 16:18:47 +0100
-Subject: [PATCH 2/2] nsenter: fix parsing of -t, -S and -G options
-
--t, -S and -G each take mandatory integer arguments. getopt32long()'s
-option string syntax for this type of argument is 'c:+', however nsenter's
-opt_str uses 'c+', which specifies two options 'c' and '+' which do not
-take arguments. This means that giving a target PID causes nsenter to
-exit and print the usage string:
-
- # nsenter -t1 sh
- nsenter: unrecognized option: 1
- BusyBox v1.27.2 (2017-12-12 10:41:50 GMT) multi-call binary.
- ...
-
-The long form options are also broken:
-
- # nsenter --setuid=1000 --setgid=1000 sh
- BusyBox v1.29.0.git (2018-05-04 13:56:49 UTC) multi-call binary.
- ...
-
-`nsenter --target=<pid> sh` parses correctly and appears to work, but
-<pid> is ignored and set to 0. This doesn't raise an error unless one
-of the namespace arguments is also given:
-
- # ./busybox_unstripped nsenter --target=42 sh
- # exit
-
- # ./busybox_unstripped nsenter -n --target=42 sh
- BusyBox v1.29.0.git (2018-05-04 13:56:49 UTC) multi-call binary.
- ...
-
-This has caused problems in a couple of places:
-
- https://github.com/linuxkit/linuxkit/issues/567
- https://github.com/gliderlabs/docker-alpine/issues/359
- https://github.com/kontena/pharos-cluster/pull/81
-
-Signed-off-by: Euan Harris <euan.harris@docker.com>
-Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
----
- util-linux/nsenter.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/util-linux/nsenter.c b/util-linux/nsenter.c
-index 35439a2..ae8103a 100644
---- a/util-linux/nsenter.c
-+++ b/util-linux/nsenter.c
-@@ -105,7 +105,7 @@ static const struct namespace_descr ns_list[] = {
- /*
- * Upstream nsenter doesn't support the short option for --preserve-credentials
- */
--static const char opt_str[] ALIGN1 = "U::i::u::n::p::m::""t+S+G+r::w::F";
-+static const char opt_str[] ALIGN1 = "U::i::u::n::p::m::""t:+S:+G:+r::w::F";
-
- #if ENABLE_LONG_OPTS
- static const char nsenter_longopts[] ALIGN1 =
---
-2.7.4
-
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index de1a1fcbf0..946cccbb8f 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Oliver Smith <ollieparanoid@bitmessage.ch>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
-pkgver=1.28.3
-pkgrel=2
+pkgver=1.28.4
+pkgrel=0
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -39,9 +39,6 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
0001-cat-fix-cat-e-and-cat-v-erroneously-numbering-1st-li.patch
- 0001-nsenter-Rename-network-option-to-net.patch
- 0002-nsenter-fix-parsing-of-t-S-and-G-options.patch
-
0001-wget-emit-a-message-that-certificate-verification-is.patch
external_ssl_client.patch
@@ -204,7 +201,7 @@ ssl_client() {
"$subpkgdir"/usr/bin/ssl_client
}
-sha512sums="0e87019d9d1179bc072a5ef9752d7342747e311db13c0b0dfa9f380a1e3ad1c265cca118d41f86829629ec5c8eb3e83985421c6f3ea6c8a9991b92ed301a4982 busybox-1.28.3.tar.bz2
+sha512sums="92471617fcf3c1e28b468f3de2c83a1041f5ba5106580cc791e9c4cd602b7ccffabc51ce0807881ed734a89c3089113048265d6659a4d595528bd9150288d2ed busybox-1.28.4.tar.bz2
51d4d58baff825a51d476bd4594cb8980ec2aa4d0c864a0eec39ccbbadd1ae9f1cd1b20f492a735ffcdf7c925573594f3c4363b0561c8aa7b91ef534bfc7b2e0 0001-ash-add-support-for-command_not_found_handle-hook-fu.patch
5d2fd3e521ee29d970f377363e3a3144eaf9f7714bc57494d743ded9e39c1ad93ea8759b2febd9c3786968b41e61b8d01ce2361aa997df177b644d63718470ba 0002-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
cc5e5ce7a822ef51eb6b8065e1b802bc9d690857b8123cb4decf51b09c4ef655784401a68dd26e0a681fbb64bd2c0fed4001be6e33cac9049e516587ea53c17d 0003-ash-exec-busybox.static.patch
@@ -223,8 +220,6 @@ a96aa81d2f0104b5c28f02e80b3f77dbce77af93c174c09015a34850474d69e42c160fc8061c62f0
185f11578dc3c3637f1acd1285c71b9e31f4244c57cd85b0848912c085a7a8c833d4c935ab1cadcb9852cf3185c7ffb08db8ea728fb19ab6e6fa90d89f13c75b 0016-top-handle-much-larger-VSZ-values.patch
d90d6b3406760fe3df6dbed46a0f4d1c02a69d5184ebc86d8c1692bc4576532127283ba3ff9a81e64f3660c279b8ee324dac7a426350873c45957067648651c6 0017-ifupdown-do-not-fail-if-interface-disappears-during-.patch
0dbe3ee424c0a6e4aba4f551f6b6b9ee087655a03747a40906961b141d40b1cbb2345438f17887a1b78d880cb3a7ad0116936dd7c05e95160febfd299423e83b 0001-cat-fix-cat-e-and-cat-v-erroneously-numbering-1st-li.patch
-d2364e20b12c5215c4baecc3c6faf903e6e1e2bee95d697af047d680e9d57e7aeea54c8584d062d92daa0ea64898b502fbae010b22ab236ec4018966b74deeec 0001-nsenter-Rename-network-option-to-net.patch
-0dbffae82b62317fc4144a01940ebc601e58b0e14eb8338bc42db79407d0b74dbe9f0f44758b9a5baa399eb90f8e8ee8f9c344bebd1b03bdd2ce520cb2b28d5e 0002-nsenter-fix-parsing-of-t-S-and-G-options.patch
90f9e95f6f953df2cf579f701b3135bad910f514e94b3e23b953acec12b10f33aa9200169dc7b454c6a04fbd992a370e6ca835406f9b5495951e0a8416137000 0001-wget-emit-a-message-that-certificate-verification-is.patch
27bd37af65f48b52fe6329f5ddf86ce9afdd1c156f94c6e868d35434298ec96c3b436097ced57f403940a29a9721b56e09bee66da3ee2cfc49c0d90d2e7a2d3d external_ssl_client.patch
a9b1403c844c51934637215307dd9e2adb9458921047acff0d86dcf229b6e0027f4b2c6cdaa25a58407aad9d098fb5685d58eb5ff8d2aa3de4912cdea21fe54c acpid.logrotate